Vero 4K+ will not play certain MKV- files and other nuisances

Hi, I’ve got the Vero 4K+ since about a month and it has been rather a disappointment to me.
LAN is not functioning, sudden crashes, very slow interface and not able to play video files randomly.
After hours of playing around I finally got files playing through a Samba server (through WiFi), but it is randomly able to play MKV-files. Different Movie folders with all MKV-files and the file is present in the folder, but it will not play. A different movie folder with another MKV-file will play fine.

Together with an extremely slow interface, updating of the movie database takes initially more than 2 hours, this media player is driving me nuts with lots of peculiarities. I reached the point of going back to my old mede8er med600x3d and toss it in the bin.

Another issue is when it is put in SUSPEND mode (because there is no Standby), the LED will light up RED, but it will never wake up by the remote control, a hard reset with the adapter is needed.

Am I really the only one with lots of issues, just out of the box?


Sorry your having out of the box issues and what you are describing does not sound like the normal experience. Please could you provide some logs, so we can get these issues resolved ASAP:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Regards Tom.

This is not normal – please provide some logs so we can get this fixed for you.

Hi, I just uploaded the logs here: rusawuhoji

I tried to play 3 movies (Waves, Yesterday and Parasite) and it doesn’t play. Then I opened House of hummingbirds and that one plays fine.

By the way, opening the movie folder (with 66 films) takes a long time. It seems sometimes the mediaplayer is locked up and doesn’t respond. Than after a long time it responds again.
Another issue is the strange characters it gives to Korean movies.

Can you find the problem with LAN not working in there as well?

Library scanning is slow because of timeouts when trying to access files.

The movie Waves doesn’t play because of this error:

2021-02-16 19:53:05.997 T:3590205664   DEBUG: CSMBFile::Open - opened smb://USERNAME:PASSWORD@ films/Waves (2019)/Waves 1080p BluRay DTS (2019).mkv, fd=-1
2021-02-16 19:53:05.997 T:3590205664    INFO: SMBFile->Open: Unable to open file : 'smb://USERNAME:PASSWORD@'
                                            unix_err:'2' error : 'No such file or directory'

I suspect your issues are coming from a permissions issue with your NAS.

Can you confirm the make/model of the NAS and show us how you have configured the share?



You would need to change the Font to a Font supporting those characters (e.g. Arial) via Settings -> Interface -> Skin -> Fonts

For the other issue check your NAS permissions but you may also try settings>services>SMB client> and enable the “Mitigate MTU issues with SMBv2” option

Always annoying these permissions, they only cause anger. Never had this issue with my old mede8er player.

Compared on my desktop with windows 10 the permissions on 2 files (1 playable, 1 not) and cannot find any problems. All permissions of the files seem to be the same.

@fzinken: Thanks for the mitigate suggestion, I will try it tonight.

@zinken: Mitigate suggestion unfortunately did not solve the issue.

Same files still unable to play. Copied the files to my Windows 10 desktop PC and checked all permissions and compared a good video file and a bad file.
Could not find any differences. Deleting the bad movie on the NAS and copying the file from the desktop PC to the shared drive, does not solve the issue.

Checked all 63 films in the folder on the Vero 4K+ and 6 of them are unable to play.

I never had all these different problems with a media player and in 15 years I owned about 8 different players. Imho the Vero 4K+ is more suited for specialists and definitely not for people who like stuff working out of the box and just enjoy a nice movie or tv show.

Another 4 hours wasted on this issue and still no solution.

Anyone interested in a 2 months old secondhand Vero 4K+?

We’ll get it solved.

Can you reboot the device and then, with debug logging switched on, play one film that you know works for 20 seconds, then a film that you know doesn’t work.

Upload a new set of logs and tell us the names of the two films.

Hi dillthedog,

I just uploaded the logs you requested at ivujiqomiz

First movie is Penguin Bloom (2021), and the bad movie is Waves (2019)

Hope you can help me out!

I’m not able to answer why you can access one movie file in a directory but not another but I believe you have other setup issues which may be contributing to your problems.

For example, your setup of video sources looks wrong to me.

You seem to be storing media on three folders on the NAS:

smb:// Shows/
smb:// films/
smb:// films/

Within those movie folders you mix between both a flat structure and folder structure. Recommended naming of files for movies can be found on the kodi wiki

Yet in the media sources (Settings > Media > Library > Videos…) on Kodi you have only one directory called “video” that is linked to smb://

There should be three for each of the above directories. Perhaps this is because you are experimenting with smb rather nfs but the scraping logic in Kodi is really going to struggle with your current setup.

I would be tempted to clean up the file naming for movies and tvshows on the NAS and start again by wiping the myvideos db and re-scraping videos into Kodi.

Thanks djbloc, I will try to update the SMB folders. I am not using NFS, because it gives errors when I try. So I am already very glad at least something is playing from my NAS. UPNP doesn’t work either. But I don’t think it is related to my problems with unplayable files.

Quite a while ago, Sam asked:

I can’t find an answer to either of those questions.

I agree with @djbloc. You should rationalise your sources, and remove all the unused stuff, preferably just keeping SMB – though if the server is Linux, NFS usually works very well (though there is a known NFS bug with kernel 5.10.11)

Hi dillthedog,

I am getting the feeling that, a few more responses later, it is propably caused by my setup.
Although everything worked great with my old Mede8er player on the same setup! Never had any of these issues, only lately some audio sync issues.
Whenever we want to watch a movie in the weekend I have to switch back to my old mede8er!
For a professional media player like the Vero 4k+ should be, the out off the box experience is extremely disappointing.
If you have to spend 100+ hours to get it functioning sometimes, people should be warned it is a time consuming media player.

Mede8ers use SMB1 so, in the absence of any info about the NAS, would setting the Vero to use SMB1 be beneficial?

I am not affiliated with OSMC, merely a user of their products, a regular denizen of these forums, and someone with an interest in media players generally. But I can assure you that your experience is very unusual. It took me half an hour to get my Vero 4K+ up and running. I don’t pretend to know what’s odd about your setup, but I’m quite confident that if you give Sam and the guys enough information, they will be able to figure it out.

I’m a former Mede8er owner myself, and the Vero 4K+ is vastly superior to it in any number of ways.

That’s assuming he was using SMB. Back when I was using a Mede8er player, its SMB performance was so poor I had no choice but to use NFS at the server end, otherwise it couldn’t cope with blu ray remuxes.

1 Like

Hi Guys,

After half an hour, my son, an IT-student and I, were still trying to get the LAN working properly. Still not functioning to this date. Only connection is WiFi.

Apologies for not mentioning the type of NAS. Iit’s a Zyxel NAS 540 4 bay.
Never used the SMB1, but always used the UPnP option on the Mede8er, works great, no hiccups, no file permissions crap.

Probably the Zyxell NAS is my problem now, right? If I owned a QNAP or Synology I wouldn’t have these problems?

Do you have more than one ethernet cable plugged into it?

Yes and no. Your problem is likely centered around the configuration of your NAS, but not the fact that it isn’t a QNAP or Synology. I would bet that if you tried to configure Kodi on a Windows box right now connected to your NAS you would have the exact same issues your blaming on the Vero.