Vero 4K+ will not power up with Harmony remote

I’m having an issue with my Harmony Elite Hub remote since the June update. Everything appears to be working ok with the remote other than I cannot powerup the unit with my Harmony remote. It will powerup with the supplied OSMC remote. As I’ve indictate all other features/programing of the remote works, Navigation… and even powering off works. But once its powered off I can not power it on with the Harmony remote. I’m probably missing something really simple but at the moment I can’t think what would have changed with the last upgrade that would affected that one aspect of the powering on. Any ideas anyone?

I had the same but it appeared earlier. I’m on the 4.9 kernel.

I created my own solution, as mentioned in the link.

I supposed it has something to do with an change in kodi, cause this was the only change then.

I’d suggest logging in via SSH and seeing if any key presses are detected at all. You’ll need debug logging enabled for this


To ensure we understand it correctly, with “power off” you mean using standby mode which is the one you can reactivate it from with the OSMC remote.

Yes I mean ‘standby mode’. I’ve checked my Harmony and Kodi Settings and they appear to be correct from how things had been setup before the June software upgrade. I even used both the Harmony remote and the Harmony app to send the Bluetooth code 61511 that’s assigned to ‘G’ Command.
By pressing the ‘G’ command within the Harmony App it sends the unit into standby (red cross on the LED) but when I press the ‘G’ command again to power it up nothing happens.

Try any other button. The wake up is not linked to the Standby button.
Also as Sam wrote check debug enabled logs (via tail -f .kodi/temp/kodi.log if any key is transmitted in that situation.

I’ll try to do that later today as well, i’m very sure while i use the procedure for more the 1.5 years, pressing G aka bluetoothcode 61511 worked to put it into suspend and take it out from suspend.

Log will follow later.

I add the log :slight_smile:

I didn’t upgrade to June version yet, but the behavior is the same, G to “un-suspend” does not work anymore, pressing another button like home on the osmc remote or harmony OK button works.

In the log there most be seen G pressed first time, to go to into suspend, second G doesn’t answer, then pressed home on remote.

I think the issue in your case is that you were using the Kodi suspend function to act as a power toggle. This worked previously because the fake screensaver was allowing the suspend command to go though regardless of machine state. As I understand it this was causing issues with some other users so with this last update there was a power state check added as you can see in your logs…

2020-06-08 12:09:41.496 T:4069158912   DEBUG: HandleKey: g (0xf047) pressed, action is suspend
2020-06-08 12:09:41.496 T:4069158912   DEBUG: Keyboard: scancode: 0x22, sym: 0x0067, unicode: 0x0067, modifier: 0x0
2020-06-08 12:09:41.541 T:4069158912  NOTICE: Activating standby mode
2020-06-08 12:09:41.541 T:4069158912    INFO: Ignoring standby request: we are already in standby

I think for a harmony user having discrete power on/off commands would actually be a better way to go as the help button will automatically send the power state commands as part of the initial attempt to automatically fix the sync between the remote and the A/V system whereas this doesn’t happen when power is programed as a toggle. I think in your case you could just leave your Kodi setup as is and just change the remote setup such that you define ‘g’ as off and ‘enter/select/OK’ as on. As you have an OSMC remote plugged in I would avoid using esc as a power on command as that will send out a CEC activate source command when you are on the home screen and that may throw off the harmony as that has the ability the change sources as well as wake multiple devices (depending on how CEC is configured in Kodi).

1 Like

Thank you @darwindesign for the secure explanation which describes the issue that we are experiencing and it’s caused by changes within the screensaver :slight_smile: .

I already changed the power on (aka resume from suspend) with sending OK and BACK (because otherwise the screen will stay in the powermenu) , which works nicely and G (aka 61511) to put it into suspend.

So with your explanation @Digitalfm is wiling to update the guide (Guide to using Harmony Elite Remote/hub via Bluetooth (Vero 4k+)), so that harmony hub users, can succesfully put the vero into suspend and take it out of it.

Why is it in the power menu? That guide you linked maps to a suspend action and that does not bring up the power menu in my testing. My Harmonys are only IR but taking a quick stab at this using an OSMC remote I found that a nooped key will also wake up from suspend. Assuming BT works the same I think this is actually the best was as ideally you don’t want the power buttons to do anything other than on/off. You can’t do this in keymap editor but this is what I would manually edit it to…

			<some_other_key>noop</some_other_key> <!-- wake -->
1 Like

I’ll deepdive into it. I don’t use anything other then what was mentioned into the guide. From my view pressing home on the vero remote the screen came up with power menu, but maybe something has changed that with the june update. I’ll update to june version with my 4.9 setup and will look it up.

That sounds like you custom keymapped something other than just ‘g’. Off the top of my head I think the only default mapping that brings up the power menu is long-press back from the home screen (which is from Kodi, not us). There was changes to how the home button acts that came in the June update that would be enabled if an OSMC remote dongle is plugged in, but there is no actions programed to that key for bringing up the power menu (in the UI it is only navigation and CEC power actions programed to that button).

The only thing that is mapped was G for 61511.

CEC is turned off

I’ll will try some other commands

Ok. After reviewing the various comments I just added an extra step in my Harmony setup to issue a ‘OK’ command in the startup sequence and everything is honky dory. Thanks for the tip/leads :slight_smile:

So i’ve sorted it out, why the powermenu came up

It appeared i had the habit to put the cursor on power button in kodi left in top screen, so then OK started the power menu. :nerd_face:
So now i changed it to only BACK as start command and that works as well. So the procedure in step 4 of the power toggle process would be 2 buttons for on and off, on is any key ( back in my case) and G for suspend.
Thanks again @darwindesign for your help and clarifying why the un-suspend did stop working due the screensaver-change. Repeating the steps I now discovered my habit why the powermenu came up with OK. :nerd_face:

1 Like