Vero 4K Will Not Stay Connected to 5Ghz Wifi

I just received my Vero yesterday - and I went through the set up … no problems.

Then I installed the PlexKodiConnect and it would not remain on Plex. Kept saying I was not connected to Plex and that there was no Plex server. I had no issues with any other devices, so looked online for resolutions with OSMC but nothing really worked. So, I uninstalled PKC and connected the through NFS to the folder locations.

That’s when the Wifi started dropping out.

So, I reinstalled OSMC to try to get a fresh start and it connects fine to 5Ghz Wifi. Then as soon as I try to stream a movie using NFS - it drops from 5Ghz and I’m left unconnected. I try to reconnect and it tells me I am unable. I can join the 2.4GHz just fine and no dropping - just a lot of stutter on playback.

I am completely ignorant of Linux, so debugging is a mystery to me. :frowning:

I should mention that the OSMC Wifi still sees the 5Ghz connection, it simply will not connect.

Also, strangely, the Samba server stopped being accessible by Windows10. It denies the access. Meanwhile, my Mac can connect fine.

Overall, I’m just befuddled and frustrated.


Try the following, you will need access to the command line (

sudo rm -rf /var/lib/connman/wifi*

Then via my myosmc try connecting to the 5g network again, you will need to re-enter your password.

Now please debugging logs, try playing a movie via NFS; reboot and upload logs. Details on how to do this can be found here:

Thanks Tom.

Whatever magic that you had me do to the wifi has stabilized it currently.

Just watched 10 minutes of a 4K HDR movie and everything worked properly.

Mahalo Nui!