Vero 4k with wrong black levels?

Hey guys! I think I found a big with the output of my vero. Some video files seems to have some blacker than black informations stored in the files ans the vero seems to show this weird compression artifacts. I tried it on 2 different TVs with the same result. If I play the video via the TVs USB port (with the same input settings)black is black with no weird artifacts. I can get rid of the articats if I lower my tvs black level from 50 to 48, but that crushes black details. Could that be a wrong setting?

I took a picture of the weird artifacts with may phone if you want to have a look at it. It is a lot overexposed due to the bad camera. It isnt as bad looking in real.

Any idea?
Vero4k runs with the latest kodi 19+kernel 4.9 build,

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

https://paste.osmc.tv/ekaxokunug

I can upload a small sample file if you want to replicate it

You can use https://videosam.pl/ for that

https://paste.osmc.tv/bisefulode

Sample Video. Movie turns full black before the white writing comes onscreen. This should be full black. It is black via usb but not via the vero. Testet with 3 different tvs. You test it best with an oled, which shows more details on low light scenes.

Here is what it looks like:

did someone manage to reproduce it?

I’m still scratching my head as to what this means. Are you saying the video is fine until you get the OSD brightness setting up? If so, and that’s the Kodi brightness setting in your pic, then I suspect your display is reacting to the average luminance going up. I get the same effect when subtitles (embedded in the video) are displayed.

Do the blacks go back to black when the brightness setting goes away?

no. With the standard tv brightness settings (calibrated Sony A9F) the video shows this weird near black patterns, which should be complete black. If i lower the tvs settings, I can get it complete black, but near vlack details get crushed because it is 2 points lower (48 insted of 50).

Kodis brightness settings are just on the screenshot because i tried if that can bring a benefit, which it does not, so ignore this

Have you noticed this only with kernel 4.9? And is it only SDR or both SDR and HDR?

BTW the file you uploaded has gone missing. videosam.pl is still a bit ‘beta’ - sometimes you have to upload a clip twice, especially if it asks you to log on. Could you try again, please? If you get the login request, please upload it twice.

Ok, I will upload it again tomorrow. I noticed it with 4.9 but I can‘t say if it was a problem before. I‘ve got a second vero here and I will try it tomorrow with the old kernel too

1 Like

https://paste.osmc.tv/tagibavine

did it upload this time?

@grahamh wasn’t referring to the Log Upload (that worked) but upload of the sample via https://videosam.pl/

ok, I tried to upload it again, but got no confirmation if the upload worked

The clip’s not there. Can you upload it somewhere else, please?

Videofile is uploaded.

Testet with old kernel (2020-11) and it works flawless. So it seems it is a kernel 4.9 bug…

Thanks for that. You were running Matrix with the older kernel or Leia?

tested it today with a fresh install from the downloader (kodi 18.9)

Did you download the videoclip? Just saw it was delete soon after upload

I did, but it won’t play on any OSMC device - I just get Kodi crashing and re-starting.

strange. worked here on my two devices. Maybe something is wrong with the uploaded / downloaded file. I uploaded it again.

https://www.file-upload.net/download-14565456/Test.mkv.html