Vero 4K+ won’t connect to any repository

Hi, my OSMC Vero 4K+ just won’t connect to any repository except for the default kodi repo, I’ve tried many and get the same error “could not connect to repository”

It’s doing my head in now, I just can’t find a solution. I can connect to any of the repo urls from a browser so they’re not blocked.

In the log there lots of errors like “Error opening…” (different for each repo) but again I can connect to these urls from a browser without any issue.

Any suggestions ? Thanks.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks , I’ve done that now and the log file has been uploaded. The url provided is

I have exactly the same kodi configuration running on 4 different devices and the Vero4K is the only one giving this error.


This might be part of the issue
2020-10-07 11:48:32.793 T:3791917792 DEBUG: DEPRECATION: The OpenSSL being used by this python install (OpenSSL 1.1.0l 10 Sep 2019) does not meet the minimum supported version (>= OpenSSL 1.1.1) in order to support TLS 1.3 required by Cloudflare, You may encounter an unexpected reCaptcha or cloudflare 1020 blocks.

But further than that we can not support/discuss this on this forum due to our piracy rules.

Thanks, I appreciate that but my issue is not piracy related. It happens with every repository I’ve tried.

I assume the OpenSSL being used by this python install is part of the osmc/kodi build ? My device says there are no updates available. Is it possible for me to update the OpenSSL ?

Thanks for your help.

Well the two repositories that you have installed are both falling in the “no support” category. Can you reproduce with a legal Repo? E.g. Index of /repository/

It will be updated automatically with the next major update for Buster which should come in the next 2 weeks.

Ok thanks, I’ll try that.

OK great thanks for your help.

OK, I’ve upgraded my Vero box to the latest Buster build and removed all “pirate” sources. I’ve installed the yatse repo and I’m getting the same error when trying to use it “Could not connect to repository”

I’ve uploaded a new log file [here]

I can see in the log that it’s just failing to reach the url like my first post…
ERROR: Open - Error opening

I can access this url no problem from any browser and have no issue with repos on other kodi boxes, I’m baffled!

Connect via SSH to the Vero and run wget and check what happens

osmc@osmc-vero4k:~$ wget
–2020-10-07 15:43:36--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 32 [text/plain]
Saving to: ‘addons.xml.md5’

100%[==========================================================================================================>] 32 --.-KB/s in 0s

2020-10-07 15:43:37 (161 KB/s) - ‘addons.xml.md5’ saved [32/32]

no issues that way it seems

Well then something must be going wrong within Kodi.
Maybe try to enable debug logging in Kodi and then upload the logs again after trying the Repository maybe that gives more details what goes wrong.

Yes that’s what I done and posted the log in my last post, anyway thanks for all your help.

Nope, you didn’t enable debug logging.

1 Like

Oh sorry, I must of disabled it again.

New log file [here]

Well you get a unhandled exception thrown which is still strange. I just tried the Yatse Repo on my system and don’t get an issue.

2020-10-07 16:35:28.335 T:3918524640   ERROR: Open - Unhandled exception
2020-10-07 16:35:28.335 T:3918524640   ERROR: Open - Error opening

Last test that comes up my mind try curl on command line


yes that works no problem and retrieves the md5

osmc@osmc-vero4k:~$ curl

The osmc repo and standard kodi repo work, it’s all a bit odd.

Yeah I am out of ideas other than Kodi is damaged

I’ve got to the bottom of it after a day of debugging and googling.

I had an incorrect setting in my advancedsettings.xml for increasing the video cache. I had the wrong number in there and was asking for more ram than the device has. After a lot of googling I came across this thread on the kodi forums that helped me solve it. I’ve changed the memorysize number and it’s all working now.

Thanks a million for all your help.