Vero 4K won't boot on second start

My Vero 4K is brand new. Well, it’s been run once.

It had its first start about a week ago.

It booted and appeared to update itself. However, I was unable to configure it to work with my W7 system.

(As I explained in an earlier post, I don’t want to stream - just play videos from my wired network and a player-connected USB hard drive dock)

I imagine that anyone who’s had experience with Linux would probably find the configuration a breeze, but I certainly couldn’t get it set up, even though I’ve been building and servicing Windows systems for over twenty years.

Anyway, I tried. I read the booklet but the instructions only explain how to turn it on. I couldn’t find any coherent instructions, or YouTube videos online.

So I gave up, unplugged the device (having found no on\off button) and re-connected my WDTDLive player, which I’d hoped the Vero would replace.

After searching the net unsuccessfully for another day or two (for more info), I finally decided to try again.

Not to be. The Vero 4K won’t turn on, now. Red light only. Tried 2 or 3 times over the course of several hours, plus leaving it on for a 30 min stretch, but still no blue light.

Incidentally, I’ve been reading through various pages on this board and I note that some users have mentioned the lack of a power button. OK, I understand that the device’s power consumption is minimal, but I’m curious as to why it’s equipped with a red light. I mean, if it’s not intended to be turned off, why not just show blue if it’s on, otherwise no light at all?

BTW Sam, if you read this, I’m Ian - the NZ guy who had trouble with the USB3 hub EU power adapter that came with the Vero.

I won’t bother returning it.

But I would like to get my Vero working, please.

Hi

If you’re streaming from SMB via Windows 7, selecting SMBv1 under Settings -> Services -> SMB Version would probably do the trick. Otherwise we’d need more details about how you’re trying to add these shares.

We don’t produce an AU/NZ plug for the USB hub. A plug must be selected before placing an order. You can return it for a refund.

The Vero 4K is intended to be turned off when users want to turn it off (halt it) and move it somewhere else, or perhaps power it off and go away for a while. Pulling the plug is never good.

When the Vero 4K is showing this red light, what is connected to it? What was connected to it before?

The next update features a virtual on/off mode which will indeed utilise the red light.

Sam

I’m aware of that. You told me in your several emails. As I said, I won’t bother returning it for a refund.

Re the red light: Today I disconnected the WDTVLive player that we used last night to watch several movies.

I reconnected the Vero to the network cable, the HDMI lead and the power adapter. Then I plugged the power adapter into the mains. This is the same method I used when it was last connected. And partially configured before I gave up.

No blue light, only red. As I noted in my original post.

I’ve just connected it again and still red light only.

Note: You said ‘Pulling the plug is never good.’

Where does it say this in your instructions?

As someone with 20 years of experience I’d think you’d know that pulling the power on a running computer can be a problem. Including Windows systems.

I don’t think we’ve mentioned this, but I will make sure we do make it clear in the future.

Pulling the plug can cause system corruption.
You could try reinstalling OSMC. This is a very simple process. See Reinstalling OSMC - Vero 4K - OSMC.

Otherwise, I’m not sure what could be wrong with your device. It would have to be returned to us for checking. Can you confirm you’re powering it with the supplied adapter and you haven’t powered it with any other adapter? (this can sometimes cause problems)

The red light displays if the device cannot boot properly; or it has been halted.

I’ve done this dozens of times with the WDTVLive. It’s never faltered. The only reason I want to replace it is, as many users have noted, sometimes unwilling to play certain files.

IMHO, if NOT pulling the plug on a device is crucial to the device’s health, it should be fully documented in the delivery instructions.

Whether or not I (as an experienced Windows user) chose to do this when the device has no visible means of turning it off (except perhaps in the OSMC menu that I never managed to get working because of a lack of documentation) , then this is no more than would happen to a much less experienced user.

Sam posted while I was typing this reply. Yes, I can confirm that I have not tried to power the device with any other power supply than the one that came with the player.

Pulling Vero 4K’s power is no different to pulling a PC’s power.

Recovery operations will be undertaken to repair the filesystem on the next boot.

You will almost always be fine, but it’s something to avoid.

WDTV Live also recommends against sudden power loss when using attached storage. A quick search for ‘WDTV power loss’ will show this.

Vero 4K can’t be bricked from power loss. It can end up in a bad state; but this can easily be recovered using a thumb drive or SD card.

It can be bricked from using an incorrect power supply however.

I’d suggest trying to reinstall as per the previous instructions. Otherwise we’d need to receive it back. The only time I have ever seen this situation is due to powering with the wrong adapter or backfeeding via USB. Even then, I can count the instances on one hand.

Sam

Hang on: has the device ever booted for you successfully?
If not: I think something is very wrong.

The only way that the second configuration attempt differed from the first was that I connected the USB dock to the player, and powered it on before booting the Vero.

Because the Vero had previously unsuccessfully (or incompletely) recognized my network, I did this to see if the player would recognize a ‘local’ drive, regardless of whether or not I’d managed to establish a network link to my various computers.

Sam, I’m sure you’re very busy, but didn’t you read my OP?

Yes, the Vero DID boot once, and I managed to do a small amount of configuration before I got totally confused and gave up.

I’ve read your posts.

I’d recommend trying re installation. Failing that, there’s something wrong with the device or the dock has caused some problem to the Vero 4K’s circuitry.

Just to confirm: the Vero 4K is connected directly to the wall socket (no extension chords)?

If you have another 5V, 2A device power supply you could try this. Make sure it’s 5V and not 12V!

Sam

Re installation didn’t work. I’ve tried it twice.

From your website I downloaded osmc-installer.exe and OSMC_TGT_vero3_20180207.img.gz

I don’t understand why the image file has ‘vero3’ in its name but it’s the file that downloaded after I clicked the 2018 file at the top of the list, as shown below:

Vero 4K
Release Checksum (MD5)
2018.01-1 f819b4fab78ee31caba522d64605224a
2017.12-1 42d7ce69c1c365b3e96890b0c5909277

The second, the 2017.12.1 file also shows ‘vero3’ in its name.

Anyway, the first attempt was loaded onto a 64gb micro sd card. The second was on a 1GB USB memory stick. The OSMC loader reported no problems with either install.

But the result was the same. When powered up, the red light came on and didn’t flicker at any time. There was no activity at all with either source.

I doubt I have another 5v, 2A power supply but I’ll look.

The Vero 4K is the third Vero, hence the name vero3.

It sounds like your hardware has failed which is extremely strange. You can email support@osmc.tv to initiate a return.

The Vero 4K will display a permanent red light when the internal circuitry is damaged.

We will inspect it upon arrival.

Can you provide more information about the ‘USB dock’? If it provides power via USB and you also had the barrel connector attached, then you could have effectively backfed the device.

Sam

HDD dock for Vero-OSMC

The hard drive dock is this one. It holds a 1TB SATA2 hard drive.

I’ve had it connected to the WDTVLive player for 2-3 years. Sometimes it’s been switched on when the WD player booted, or has been switched off at boot and powered on later.

So you’ll understand that I had no reason to suspect that its connection-at-boot to the Vero would cause any problems. If this is what happened.

You mentioned a ‘barrel connector’. I don’t know what you mean.

The barrel connector is the connector you use to power the Vero 4K.
It’s a DC jack.

If you power the disk and connect it via the USB, it may backfeed via USB which would cause problems.

You’d have to initiate a return if you see the red light so we can look in to this. It means the internal circuitry is blown. As mentioned before, this has only happened very rarely.

We’ll update our manual to make it clear that users should be careful.

Sam

Sam, further to your remark about the ‘barrel connector’ - which I understand you to mean the power pin of the Vero power supply - I’m not sure of the relevance.

To summarize the way I connected the Vero on the second attempt to set it up - the day it reused to boot - the sequence went like this:

Connect network cable to Vero.
Connect HDMI cable to Vero and TV.
(USB hard drive dock already holds 1TB SATA drive).
Connect USB hard drive dock (switched off) to Vero.
Switch on USB hard drive dock (it has its own power supply).
Connect the Vero power adapter to the mains.
Plug the ‘barrel connector?’ (Vero adapter power pin) into the Vero.
Switch on the mains power socket.

From that moment on, the Vero has only ever displayed a red light.

Regarding the USB dock: Correct me if I’m wrong, but you seem to be implying that connecting this device to the Vero is a possible cause of the Vero’s failure.

I’d like to remind you of several of the many emails that passed between in early February 2018 regarding my requirements, and what you said in reply.

On 7Feb18 I said, in response to your question about why I hadn’t completed the website purchase, ‘Reason I haven’t proceeded with the purchase is that I have one concern about the Vero’s ability to do something I need, but I can’t find anyone to answer my question.’

Later on 7Feb18 you replied, ‘What would you like to know about the device?’

On 8Feb18, I replied, in part,
'…I’m not into streaming, although I’d probably try it if I had a suitable player.
Mostly, I download movies and TV shows, then watch them on my lounge TV.
All I want to do at the moment is:

  1. Plug the player into my TV via HDMI
  2. Connect the player to a USB dock that sits alongside the player. It holds a 2TB HDD.
  3. Connect the player to my home network by cable.
  4. From my W7 Ultimate 64bit be able to see, and upload\delete files to and from, the docked 2TB HDD.

On 9Feb18 you replied,
'1. Yes – there’s an HDMI connector
2. Yes. It will read most formats of drives: exFAT, NTFS, FAT32 (not recommended); ext4. If you swap the drive in to other machines regularly, exFAT is your best bet.
3. Yes – we recommend using an Ethernet cable over WiFi because it’s less subject to environmental interference.
4. Yes – however on receiving the device, you’d need to go to My OSMC -> App Store and install the Samba Server. This can all be done from the remote. Windows will then be able to see any attached USB drives, SD cards as well as the internal storage itself.

Your response to item #2 above was obviously affirmative, and said nothing about any possible risks associated with connecting a USB dock. As I’ve said, my 7-year old WDTVLive has had that same dock, or several other models, connected to it since it was new, and it has never faltered during that time.

I can only conclude that either the Vero 4K is not suitable for connection to a powered USB dock, or that the device you sent me is a lemon.

You’ve said that I should return the device to you ‘so that it can be assessed’.

This isn’t a good idea. Apart from the matter of the device’s possible general unsuitability for its purpose, and the considerable delay before I receive a replacement, and the liklihood that you’ll expect me to pay a not inconsiderable postage charge to return this faulty item, I’m not now convinced that the Vero will do the job for me.

However, I might be willing to try again, given the following:

I send the device to your reseller in Timaru to confirm that it is unusable, after which you either send me a replacement or have NiceGear do this. Or, refund the purchase price of the Vero*. As you said in one of your previous emails, ‘With our 14 day money back guarantee, you have nothing to lose.’

I hope this is so, Sam.

*As I said, I’ll keep the USB3 hub that I purchased along with the Vero and write off the cost to experience.

Unfortunately without inspecting the hardware, it’s impossible to remark why you are experiencing a problem here. I hope you can appreciate that.

Connecting a USB device to the Vero 4K will not usually damage it’s circuitry. A large number of users use attached media to either stream from it or share it on the network.

The only way that Vero 4K could have been damaged is if it was powered with the incorrect power supply; or if there was a malfunction. This malfunction could come from an attached peripheral, but is less likely.

I am sure many others will be happy to confirm that using Vero 4k with a USB hard drive does not cause issue. Obviously we can’t certify all hardware; and some are better than others. But a good caddy won’t give you any problems.

Every device is tested before dispatch.

From your original post, it’s clear that Vero 4K did boot; performed updates and you struggled with Windows shares. Did you only experience the red light after attaching the powered dock?

The sale contract is with us, and not the reseller in New Zealand. As such, the item needs to be returned to us for replacement. Getting it back will let us identify the problem and resolve it promptly for you.

As explained: we are happy to accept a return of the USB3 hub as well. We will also add a message on our page so that users don’t accidentally order the wrong power supply in the future. Currently, a customer needs to select their plug type but I can see that may not always be obvious.

I’m sourcing this dock locally (it seems to be a generic product) so that I can give it a test here too.

Thanks for your understanding

Sam

Sorry about delay replying, getting legal advice.

Understood.

As per our terms of sale, at this time of writing, a customer can return any purchased item within fourteen days of receipt for a full refund. The customer must cover the return cost.

These terms were accepted when you placed your order.

We need to receive an item back before we can refund you.

If your dock had damaged your device, we would have been happy to replace this regardless for you. Again: we don’t know what the problem is until it’s received back and our resellers are not able to determine this. It’s pointless to issue you a replacement if there’s something wrong with the supplied PSU or the peripherals you’ve attached, as we’ll just run in to the same problem.

Usually for replacements, we’ll ask customers to retain proof of postage and reimburse them upon receipt and dispatch of a replacement item.

Actions, and responses like yours can ruin things for everyone. You seem very doubtful that the Vero 4K can be operated with attached media; but this is a core feature of OSMC.

Please help us help you.

Again, sorry for delayed reply, my solicitor has only just become available.

I won’t go into details of our conversation, so I’ll just say that his recommendation was that I comply with your request to have the device returned for repair or replacement.

Regarding your comment that the device’s failure could only be caused by a) being incorrectly powered or b) due to some unknown circuitry problem, I can only repeat my earlier statement that the only power source that has been connected to the Vero is the one that came with it.

Even if I had been so careless as to connect the only other power source in the vicinity - the WDTVLive power adapter - to the Vero, both the WDTVL and its power adapter are housed on the opposite side of my TV cabinet to the Vero and the WDTVL’s adapter lead is too short to reach the Vero.

The only other possibility is the connection, on second boot of the Vero, of the USB dock of which I sent you a photo and which you said you’d experiment with.

The Vero booted the first time and the only reason I discontinued the programming was that I couldn’t understand what was required. Your leaflet says that the ‘instructions’ are on screen. I suggest that this is not so. The MENUs are on screen, but there is no information to show how the menus should be used.

So when I tried again the next day, it seemed logical to see if the USB dock could be recognized by the Vero, as that would have meant I could leave the Vero connected to some source of local content, rather than having to continually replace the WDTVLive player overnight so as to have a working media player.

However, the Vero wouldn’t boot with the USB dock connected, and has only shown a red light ever since.

Finally, I’m not sure what you meant by saying ‘Actions, and responses like yours can ruin things for everyone’.

All I want is to be able to use to use the Vero 4K to do what you assured me was possible.

I will package and return the device today or tomorrow. I assume you’ll want all of the components - leads, remote, power adapter etc.

However, as I said earlier, I don’t need to return the USB3 hub for a refund - my daughter travels in Europe frequently and gave me a plug adapter.

Ian.