Vero 4K won't turn on

When I got home last day, I found that my Vero 4K is turned off and the red light is on. I tried to replug it, but it didn’t turn on. I checked the power supply and it seems to work fine. What can be the problem here and how can I fix it?

How did you verify that the power supply works fine?

Have you tried powering the device via a USB cable?

Sam

Checked voltage an current with multimeter.

How can I try that? There is no microUSB or USB-c port on Vero 4K :thinking:

There are USB ports on the side of the device.
Unplug the barrel connector first.

So, I need a double USB head cable?

Just a USB A->A cable

This is what happens after plugging by USB:

https://send.firefox.com/download/06c1e5fbdf78befe/#ogAXFZW6A2Yz4YtMK4jqQQ

I plugged the USB and the barrel connector at same time and installed OSMC again.With both 2020.01-1 and 2019.11-1 and they both get sad face over and over again, with this error on startup: failed to start load kernel modules.

I would recommend a reinstallation of OSMC from https://osmc.tv/download as the system is likely corrupted.

It looks to me that the system is not receiving enough power.

Can you confirm if the adapter is 5V,2A and try another adapter (must be the same voltage)?

Do you have anything else connected to the USB, like an external drive, TV tuner, etc?

It’s a quick charge 3 adapter with output 5V 2.5A, 9V 2A.

I used to connect a USB DVB-T receiver, but it’s unplugged now.

The receiver may have been an issue. They can draw a lot of power.

I’d recommend doing as @sam_nazarko suggested and re-install OSMC.

You should use a USB powered hub if using a DVB-T2 tuner.

Reinstalled, but getting a sad face loop ):

I don’t use the tuner for a while and stream from the Internet instead.

How are you powering it now? Can you SSH in and get logs?

Did you definitely see the install screen come up?

Using USB and barrel connector at same time.

No, SSH port is closed.

Yes, I get the install successful message and then it reboots.