Vero, GUI shown in 4:3 aspect after RC2 upgrade. Slow menus

Just updated my Vero to RC2. After the reboot the menus seemed sluggish so I rebooted the Vero.
The slowness went away but now my TV shows the GUI in 4:3 aspect ratio. You can see that it is a 16:9 that has been “squished” on the sides. When I look in the settings it shows “Windowed” and 1920x1080.
Playing videos is shown in the correct aspect ratio and working fine. Tried several reboots.

Also, just turning off and starting the TV makes the menus get slow again. You can see the animation is not smooth, jerky motion.


Can you try and set your TV resolution (I assume 1080p), in the Settings?

Failing that, a log will help us fix this up


Hi, issue still persists.
The resolution was already at 1920x1080. However, there was an option at the bottom of the list also showing 1920x1080. I selected that and rebooted, but still the same problem. Restarting the TV with the Vero on makes the menus and transitions go slow afterwards.
Here is my logs:

I had the same problem, I cycled through all the resolutions by selecting them all. After I chose the 1920x1080 at the bottom the problem disappeared.

Update on my issue. The problem described only occur with 1920x1080 and 60hz. 30, 24, 50 Hz all work OK with no slowness after TV restart and correct aspect ratio.

Hi, I have this same issue. I tried cycling resolutions, but both of the 1920x1080 resolution choices result in a 4:3 aspect ratio. Menus are obviously compressed. Switching to 1280x720p will fill the screen at the correct aspect ratio, but as soon as I go back to 1920x1080, I’m back in a 4x3 mode.

This started happening after installing RC2.

I have the same issue too with RC2 :frowning:

Hi guys,

This took a couple of days as I’m in the middle of writing my degree dissertation (due in next week) at the moment. The issue should hopefully be resolved now (head to My OSMC -> Updates -> Manual Control) and check for updates there to get the new update immediately.

There are still a few bug fixes I need to address as well as some performance that we can grab, so I’ll be doing that after Tuesday 28th.


Best of luck on your dissertation @sam_nazarko.

Just to let you know that I’ve updated my Vero last night and the problem still persists after the update.
It boots to 4:3, but while playing it sets itself to 1920x1080.

It’s nice to progressively have things addressed and corrected. Good work guys.

In my setup I have two issues that need maturing before being reported. One related to 3D playing of content and another related with the subwoofer audio channel of DD and DTS content not being passed to my Denon. When I have some time available I’ll so some testing and report it with more information.

This is being worked on. I hope to get something out within a couple of weeks. Basically I need to flip the SBS ‘switch’ on.

Not heard any report of this yet. First thing to check would be if DD/DTS lights up on the receiver. Start a new thread for it and I’ll check it out


As a workaround try setting your TV to a 1:1 pixel mode. This might be called 1:1, just fit, screen fit or a number of other names. Usually it’s in the menu option where you choose 4:3, 16:9 etc.

This will lock the TV to a 1:1 pixel mode where it will not try to squash the picture to 4:3, also it will disable overscan of the picture.

You should really be using 1:1 mode for Kodi anyway as the overscan that 99% of TV’s apply when you leave it on Auto or 16:9 causes a significant loss of picture quality not to mention some of the picture gets cut off.

Kodi itself handles Pillarboxing of 4:3 content for you anyway - so there is no need for your TV to be in a mode that tries to switch between 4:3 and 16:9.

Most TV’s have the option to let you choose 1:1 pixel mode just for the input that Kodi is connected to, and this is recommended for all Kodi users regardless of what platform you run OSMC/Kodi on.

Apparently my TV doesn’t have an option for 1:1 mode. It has settings like Wide, Zoom, and Normal, but none of those seem to correspond to what you’re describing. Are there any other possible workarounds or coming fixes? This didn’t happen until RC2, so it was something in that release that caused this.


I don’t know of another workaround at the moment but yes we are trying to get it fixed with a new Kodi build. Part of the problem is none of the dev’s who have Vero’s can reproduce the 4:3 issue so we’re working a little bit in the dark. (There are a number of possible causes)

It’s very unlikely that your TV doesn’t have an option for 1:1 pixel mode, it just may be hard to find it.

What model is your TV ? Can you list the exact names of the options you have in the picture size settings ? Note that if you have a size button that cycles through the options you may not find it there - you may need to go right into the menus to find it.

If we know the brand and model of TV a google search will probably turn up the answer.

Normal is probably it

It’s a Visio M552I-B2. According to Google, the “Normal” mode is supposed to be a 1:1 pixel mapping, but that’s what I have it in and still get the 4:3 picture in 1080p mode. Dropping to 720p in Kodi displays things correctly.

I can relate with @JasonMKusar problems. He describes the exact behaviour that I can verify in my setup.

I own a Sony TV LED Smart TV 3D 55’’ SONY KDL-55X8505B.

No 1:1 pixel mapping available to be selected in the TV. With Normal setting Vero is show in 4:3, changing either the refresh frequency from 60Hz to 50Hz, or the resolution to other than 1920X1080 servers as a work around to this issue.

And this problem didn’t exist before RC2.

Saw an update today and thought the issue might be fixed but alas not :frowning:

I too have a Sony TV and all was fine before RC2. Have changed refresh rate output to 50Hz rather than 60Hz to temporarily get around the problem but would like it fixed.

Is there a solution to this issue?

Anyone seeing “sluggish” menu animation on their Vero after their TV is turned off and on can you run the following command via SSH (at the time the menus are sluggish) and see if it temporarily fixes the issue ? (The command is all on one line)

/bin/fbset | grep geometry | awk '{print $2"x"$3 * 2}' > /sys/class/graphics/fb0/virtual_size

If it does, we know what the underlying issue is, it’s just a matter of finding the correct way to fix it. (Not as easy as it sounds)

Almost there now. We should see improved CEC stability, a fix for the 4.3 bug and a fix for laggy menus when turning the TV off and on.