Vero loses video once Plex is launched

Exactly as the title states. I started having issues with the Kodi upgrade and the problem with Plex. I posted in the Plex thread, but it seems everyone else is working.

  • The issue you are currently experiencing with OSMC
    Loss of video signal.
  • What you were doing when this issue occurred
    As soon as PLEX starts there is a 5 second day with an image swirling in the center, then no signal.
  • Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.
    Happens every time. Have to restart the device to get it working again.
  • The device you are currently running OSMC on
    Vero 4k+
  • What peripherals are attached to the device?
    Nothing, just the remote receiver plug.
  • Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?
    A few months ago?

Link from the log: losoficiha


Use sear h futures. Solution there i think with moddedplex for new update

Your not running the latest update to Kodi so I’m not sure why you were trying to use the tweaked Plex add-on. Did your problem start when Plex reset all the accounts? Is it working on other devices and/or with the Composite add-on? When you uninstalled the Plex add-on did you select the option to also delete the settings?

I’m not sure. I just went into the OSMC settings and updated to the latest version. Should I do something different?

The problem started a couple of months ago. The unit would just lose video/green screen and/or lock up and I would have to restart it. Now it won’t work at all.

What is the composite add-on? Should I load this?

Yes. I deleted the settings and then had to re-add it with my laptop.

Plex has been working on my Sony TV without any issues with my server and from my Roku (which I have had to use instead of the Vero) in my main system, etc.

Let me know what you think I should try first.


Try it again, your not on the newest update.

That sounds a bit more like a problem bigger than just the Plex add-on. Maybe you could try playing a video via USB just for a sanity check?

Composite is a different Plex add-on that can be found in Kodi’s repository. It has a completely different look but it provides most of the same function. My thought was that if it worked then maybe that would tell us something.

I’m not exactly sure what you meant by this. I see in your logs that Plex didn’t seem to be reading existing settings. Perhaps what you have on your device has become corrupt? Telling Kodi to remove settings when you removed the add-on should have made it so their was a clean slate when you reinstalled the add-on.

A while back Plex had a data breech and forced most of their customers to change their password. They also recommended with an option to one button deauthorize all devices. This caused a bit of a pain getting Plex reauthorized on Kodi sometimes with the easiest option sometimes being to just delete the add-ons settings so it brought it back to a clean slate and the authorization code on startup.

My version says OSMC March 2022 2022.03-1 It won’t update to anything newer than this.

In Kodi my build says 19.4.0

As soon as I went to install Composite I got the same swirling in the center of the image and then lost video. Seems like something is seriously wrong.

what should my next steps be? As I said I dont’ have any other add-ons, so not worried about losing any sort of configuration, etc.

Could it be something with my hardwired network connection? Should i try doing anything via wi-fi? When I initiate an update I do see it downloading something…

Thanks again for all your help…


Hi Brian

Best thing you could do is upload some logs via My OSMC.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Here is the most recent:


As your not worried about preserving anything the path of least resistance might be to just perform a clean install. You will find a “Download” link at the top of this site that will get you what you need for that.

So blow it up is the recommendation?


Well, since composite didn’t work I would say it isn’t an add-on issue. It is probably not a Plex server issue since you say it is working on several other devices. I wasn’t spotting anything obvious and you seem to have an issue with updating the OS. Given that you say that there isn’t anything that you need to save or much configured… yes, just doing a clean reinstall would be my recommendation.

Ok. Found the instructions. Will let everyone know if it is a success.

Edit: Ok, I guess I need more instruction. I downloaded the image and copied to a USB stick. I inserted it and powered up the unit and it just boots to the normal Kodi interface. It doesn’t install anything from the stick.



You would need to “write” the image to the USB stick with something like etcher not just copy it.

Ok. Instructions should probably say you need to create a bootable device with instructions how to do that.

Anyway, got the system back up and now the remote no longer works. Any ideas? I am able to access the unit via the web interface currently. I tried plugging and unplugging the USB receiver and restarting by pulling the power as well as a reboot.


  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

You mean remove the USB/IR receiver? I did this and there is no blue light. Where is the light supposed to light up?


On the remote controller.

Front of the Remote where the red front window is

Turns out the remote battery needed replacement.

Once I changed the battery the remote worked as before.

However, when I try to do a manual update check–>loss of video.

If I try to run add-ons like installing emby the same thing happens. The unit will work for a while and then if I select something–>loss of video.

I think there is something wrong with my hardware.

Fresh install and I can’t even try to update?


Well black screen could come from a HDMI issue. Have you tried replacing HDMI cable and clean the contacts?
It could also be coming from a failing power supply (while I would expect also other symptoms) but it might not harm to try another power supply with identical specs.