Vero & OSMC Issues

Hello Everyone!

New member, long time crystalbuntu2 / apple tv 1 with Crystal HD card user

Just bought a new Vero and i have some issues.

  1. the opening in the case for the toslink SPDIF does not allow most of my cables to connect properly.

  2. All streaming stuff with 5.1 soundtracks is stuck buffering at zero per cent, will not budge

  3. menus are a little sluggish

  4. the slideshow screensaver doesnt run too smooth. CAn anyone help. I updated from the OSMC settings menu

  1. Bad design, has been discussed on the forum. The solution for me was to take it apart and make the hole bigger. But it voids the Warranty, which is strange, because you can not use the port without making the hole bigger.
  2. Are you using Wifi or Ethernet. If you are using Wifi it can be the reason, Another bad design.
  3. Same problem here, hopefully some future software updates fixes it.
  4. Can’t help you with that one.

hiya thanks for the reply

1.really bad basic design error. very unfair that its not highlighted in the shop

  1. im using really good ethernet. i have an apple tv 1 with crystalbuntu 2 and crystal HD card also. after becoming seriously frustrated with the vero, plugged the apple back in, and all the streams from with 5.1 work fine. In vero, will not budge from zero per cent

3 and 4. Usability overall is not great at all, in comparison to apple. the vero remote is very loud clicky and plasticy. For the money (cost me about 215 euro!) it seems quite poor in comparison to the apple tv, which Sam has made brilliant with all his work. Interestingly, the same apple with card and the last openelec software is terrible, so same has to be seriously congratulated for his CB1 & 2 work, i have not found a better all round player. Im very disappointed with Vero. I bought it specifically so i could ouput full FLAC music to a DAC and my stereo amp, and also as my sitting room media player. now i am stuck and need help to get this thing right. Surely there should be some recompense for the SPDIF issue alone?

anyhow, thanks a million for reply, anyone else out there that can help me get going right?

I don’t think anyone can really help you with the issues as they really are hardware related. In case Vero doesn’t live up to your expectations, the Vero team does offer a 14day return policy.

The SPDIF is recessed. There shouldn’t be a need to modify the unit. Some SPDIF cables are more accommodating than others. It is something we will address in the future.

We cannot help with that addon (please see our piracy policy). There are some improvements coming to Ethernet stability due with the Isengard release which is due shortly. Can you try some local content or from a NAS and see if you get the same problem?

We tried to give it an audible click as people said they prefer that, but we can look at making this less pronounced in the future.

There is one outstanding issue causing the ‘slow’ menus which will be fixed shortly with the Isengard release.


hi sam

many thanks for your reply, big fan of your work with ATV1 CB1 & 2. brilliant

the spdif is a case / component mount design fault unfortunately, if its recessed it still should take the cable. 3 out of 4 of mine dont fit at all, and the 4th only precariously, and it has a tiny head, and is a cheap lightweight cable. usually the good spdif cables have bigger heads and sheaths.

all the streaming stuff over internet / ethernet is buffering at zero. This is an issue with the vero / osmc as its working absolutely fine with your atv 1 and cb2.

local content from my NAS is fine.

SO its unusable to me really unless this streaming thing can be solved. I am unhappy with usability overall and thinking seriously about returning it. Its not functioning how i imagined it would, and the SPDIF port and remote is annoying.

other than HDMI, is there any other port on the vero that kicks out full hi res audio?

thanks Sam


Please provide debug logs that can be examined for the precise cause of the issue before making assumptions that currently have no factual basis… The fact that cb2 has no issues could simply indicate a misconfiguration of the vero…

a misconfiguration by who?

i havent done any configuring at all, it came pre configured. all i did was click on the osmc under programs and clicked the manual updater

I would suggest trying another (more legal?) streaming addon such as YouTube. If it’s broken on that, something’s definitely wrong



hi sam thanks again for the quick reply

unfortunately using youtube is not going to solve anything for me.

whats happening is the low quality stuff is playing, but HD 720 stuff, and especially HD 720 with 5.1, is buffering at zero. so something is wrong. Youtube is pretty low res and i would not use that for anything at all really.

its ok on my NAS.

On apple 1 with crystalHD card and CB2 all is fine

It certainly didn’t come with Genesis installed. If everything works except Genesis, then I hardly think this is a fault of the Vero… I would also warn here, further discussion specifically regarding Genesis (or any other addon for the purpose of pirating content FAQ - OSMC Forums) will result in the thread being locked.

If your problem is with a 3rd party addon, you should be taking your support requests to the provider of that addon. But if you won’t provide logs, then we’ll never know the cause of your problem.

ok, no third party talk

i never said i would not provide logs, give me a chance. i have never done it before so i am looking it up how to do it.

thanks for your time. good evening

I am not suggesting you use YouTube, I’m simply suggesting trying another streaming addon. Feel free to try Apple iTunes trailers (available via the Kodi repository) which does offer 1080p content. If that plays fine, then it is highly probable the issue is with Genesis streams you are trying to play instead.