Vero V and Dolby TrueHD/DTS HD Master issue

Hi team,

I got some issues with audio on Vero V, but only with the losless codecs DTS HD Master Audio and Dolby True HD. When I start a movie with that audio stream, I have only sometimes sound. Most of the time it doesnt playback. In some cases it helps to switch the audio stream to a different one (if movie is multilanguage) while the movie is running, then in some cases it starts to play the sound.
Here is a log snippet while the movie was running and where you can see that I switch the audio stream a couple of times until it starts to work after the last listed switch.

Aby idea what may cause this? Didnt have it so often on the RPi4, so I thought it is maybe related to those very fews movies, but until now I had issues with each movie I tested so far with those streams :confused:

My Receiver supports those formats, passthrough is enabled and all audio formats selected. I also tried SPDIF port from Vero but learned, that this port doesnt support the lossless codecs :wink:

/edit: just realizing, when I fast forward/backward in those movies, the video stream gets also laggy and sometimes stuck… that is really weird, that wasnt at all on RPi4…

/edit2: no longer sure if it is only an audio issue :confused: even on dts or dd5.1 if I fast forward many different movies start lagging and then get stuck… not all, but the more I try, the more I find, that is so odd…

Wow ok… got the hint to check network connectivity, and with ipfer I found out I get ~900mbit sending from Vero, but only ~200mbit receiving. So I switched the old cables and tada getting same almost gbit speed in both directions now, so far so good. Stuttering and movies getting stuck is fixed now.

The issue with the losless codecs therefore is still present ;(
On rpi it still works with the same movies.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

While creating debug logs I saw CPU usage, is it normal that the Vero has high cpu load for minutes after booting up? Between 170 and 250%?! (kodi.bin)

Also now after reproducing the problem it still is at 100% hmmm

I rebooted twice, waited, started the movie, got no sound, stopped playback.

Maybe you have a scraper running or some add-ons are updating

Scraper is only running on demand, AddOns are up2date as far as I can see, is there a way to find out what exactly is consuming the CPU time?

Hi, just regarding the DTS HD issues you have. Can you try settings → system → audio → output configuration → best match ?

There also seems to be a user specific advancedsettings.xml file in place. Why is this? The default is located at /usr/share/kodi/system/advancedsettings.xml and yours is much shorter.

What AVR model/brand is it?

Hi, yes can test it later today. Will post the outcome.

The advancedsettings.xml I created in the past on the rpi4 with the following content:

<?xml version="1.0" encoding="utf-8"?>

Just a few settings I manually set. Didnt know there is another file in place. Mine is located in the kodi userdata folder.
Should I put my special settings in the advancedsettings.xml you mentioned?! Thought this file is only created manually if you want to change something beside the defaults…

The AVR is a Yamaha RX-V473, old one, yes, but working :slight_smile:

If you want to add specific things I suggest you copy the default advancedsettings.xml to the userdata folder and add/change the specials you want but leave the rest untouched.

The file you mentioned contains the following hint:

  <!-- If you wish to override any of these values, then create a file in /home/osmc/.kodi/userdata/advancedsettings.xml !-->
  <!-- It will override these settings, and your settings will be preserved across OSMC updates !-->

So I guess what I did was correct as it is or is the file with the osmc optimized settings now fully ignored?

I think the default will be ignored. It doesn’t hurt if you first copy the default and then make your changes/additions.

Ok will give it a try as well


Ok, changing to ‘best match’ doesnt help, still the same. What exactly is the difference for the available settings here, as the explanation in the menu doesnt help really help hehe…

I copied over the advancedsettings.xml to the kodi userdata folder and added my specials to that one, also didnt make a change for audio (I rebooted the Vero of course) :frowning:
As per the posted log, both advancedsettings.xml files seem to have been loaded though…

Only difference in used hardware between rpi4 and vero v is the HDMI cable, for Vero I am using the one that came delivered together with it. For RPi4 it needs micro HDMI, so I cant test the same cable. All other HDMI cables I have are too old, dont even trying to use those hehe.

The article Audio hardware and software configuration explains the difference between ‘best match’ and ‘optimized’.

Since now all settings are done as suggested in this wiki article and there is no general known problem using DTS HD Master and Dolby True HD on the VeroV, I suggest:

  • provide another log set with the current settings showing the issue
  • swap the HDMI ports on the AVR and see if the problem moves
  • What DTS-HD and True HD have in common is that they require relatively large bandwidths. Another highspeed or premium highspeed HDMI cable for tests would be helpful.
  • Since you also seem to have this audio issue with a RPi4 (“Didnt have it so often”), it sounds to be more located on the AVR side in this scenario. I think you’re German, so this Yamaha RX-V473 topic sounds a bit like the behaviour you describe: Yamaha RX-V473 - Decoder Off bei Dolby True HD und DTS HD, Yamaha - HIFI-FORUM.

What really surprises me is the extremely large number of messages like

2024-04-27 21:59:52.521 T:3042    debug <CSettingsManager>: requested setting (label1018) was not found.
2024-04-27 21:59:52.521 T:3042    debug <CSettingsManager>: requested setting (label1029) was not found.
2024-04-27 21:59:52.521 T:3042    debug <CSettingsManager>: requested setting (label1035) was not found.
2024-04-27 21:59:52.521 T:3042    debug <CSettingsManager>: requested setting (label104) was not found.
2024-04-27 21:59:52.521 T:3042    debug <CSettingsManager>: requested setting (label1067) was not found.
2024-04-27 21:59:52.521 T:3042    debug <CSettingsManager>: requested setting (label1078) was not found.
2024-04-27 21:59:52.521 T:3042    debug <CSettingsManager>: requested setting (label1084) was not found.


in the logs. Obviously, you have installed or changed something on the system causing this but I cannot see what is the root cause for it. Whether this is related to the AVR behaviour … I don’t know.
Perhaps, others in the OSMC team have an idea.

Addition: Ok, these CSettingsManager messages seem to have its origin by the addon service.vpn.manager, see Debug logs fills up.

Ok will provide logs tonight most likely. Thanks for the linked article, will have a look at this.
I already switched the HDMI ports, but will buy new cables and try with those agsin.
Yeah the vpn manager is depricated, already looking for a replacement :wink:

Is your Vero plugged directly into your AVR or is it routing through your display? I would search the internet for the make of your AVR and the phrase “soft reset” and see if there is an option to do this with your device. I’ve had a few occasions with my Denon where it starts doing funny stuff and pulling the power plug has no positive effect but the soft reset fixes it up (soft in that it doesn’t delete your settings).

@morti : @darwindesign corrected me that the way you did your settings in davancedsettings.xml is correct and even better than copying the default file first. The default will be processed first and only extended or even overlayed by the user settings in advancedsettings.xml. Thx @darwindesign ! :slightly_smiling_face:

Ok, still the audio is left. As in the German blog mentioned, there seems to be a kind of reset with your AVR but that is very Yamaha specific.

1 Like

Maybe I found the issue. Changing cables didnt fix it. But resetting the AVE as described in the above mentioned link improved the situation, as it is on the RPi4 :innocent:

I am using a FeinTech VAX01202 splitter to split output into audio and video, as my avr only is HDMI 1.4, so to not need to buy a new one, I am this splitter. If I remove it from the chain and directly connect Vero to AVR and AVR to projector, it works without issues (only that I dont have BT2020 color space and also no HDR, as HDMI 1.4 doesnt support it… just for trsting). So need to work on that FeinTech stuff to get it fixed finally, I guess… contacted support already. Another fix would be buying a nee AVR what I would like to postpone until I move to my new home…


Just to let you know… couldnt resist any longer and bought a new AVR… and as it supports Atmos, ok bought additional 4 speakers along haha. But focus onmain point: no splitter, no more issues with HD codecs!! <3