Vero V at 100mbps?

My overall Vero V experience has been very good so far but I have run into one issue, attempting to run the wired Ethernet interface at 100mbps. I realize this is likely a bit of a one off and there may not have been a lot of testing on this setup.

I swapped out one of my Vero 4K+ units, which has been running on the LAN cable for a few years with no issues, for a Vero V. Everything was up and running fine but a few minutes later I noticed my SSH session hung. It wasn’t doing anything, just sitting there. The Kodi interface was fine but I couldn’t connect to anything. I rebooted the device and it happened again, after a few minutes. I swapped in another Vero V and the same result. Somewhere between 5-30 minutes the Ethernet interface stopped responding and on the System Info under network it said Busy.

I tried swapping cables to the wall jack and such with the same results. There were no errors in the ifconfig. Believing this was a negotiation issue I inserted a Netgear 5 port switch between the LAN cable and the Vero V unit. In this configuration the Vero V sees a solid 1 gig connection to the Netgear switch and the uplink on the Netgear 5 port switch is 100meg to the rest of my network.

it’s been running over 12 hours this way with no issues. When the problem was occurring I could unplug the LAN cable from the Vero V and reinsert it and the Ethernet interface would come back for a period of time and then go away again. I can run some debug logs if thee is interest in looking at this. It is not urgent and I can run with the Netgear switch. Upgrading the LAN cabling to 1Gig isn’t an option right now since this is structured cabling inside walls and floors.

Not sure what you mean with this? What is the other side of this cable? Is it a 1G capable switch but the cable is only 4 wire?
You could try to force the interface to 100M and see if that helps?

Correct. It is only 4 wires. There’s a bit of a longer story here.

I was looking for the option to force it to 100meg in OSMC but couldn’t find the instructions. I am also going to try wireless but where this one box is located doesn’t have the best wireless coverage. I had tried wireless previously with the Vero 4K+ and was able to run it at 2.4g but 5g was on the edge. I’ll do some more testing with the Vero V .

Four wire or four pairs of wires?

It is 4 usable wires. The longer story here is that I pulled a Cat5e cable years ago to this area but in doing so I broke one of the wires which supports 1G somewhere along the way (I believe it may be pin 7 white / brown stripe) and have never gone through the effort of repulling it due to the distance and difficulty. I wired the entire house 10 years ago and have just never gone back and fixed it. Again it worked for years this way with the Vero 4K+.

So you have three usable pairs (blue, orange, and green) and one dead pair (brown)?
Depending on the quality of the wiring you may be able to still pull 1Gbps.
It’s been done over cat3, although not recommended.
I have a cat5e outlet in my home that randomly drops from a gig link to a 100 link.
Usually unplugging the cable and waiting a few seconds before reconnecting it will get it to re-establish a gigabit link.
So it might just take a re-plug or reboot every now and then.

Basic ethernet cable testers are pretty cheap nowadays so you could figure out which wire is broken. Assuming you had already re-punched your jacks at some point to rule out a bad connection I would just pick two of the good pairs and rewire it to a two pair jack so it doesn’t ever try connecting at gigabit in the first place.

It only lasts 5 - 30 minutes when I do that. With the Netgear switch between the wall jack and the Vero V it’s been rock solid. 1000BaseT spec requires all 8 wires except 1000base T1 which uses 1 pair but that’s for automotive usage.

Not a noob here. EE degree and been doing this for many years. I have Ethernet testers and such. Been doing networking professionally for close to 40 years on some of the largest networks in the world.

I broke a wire because the holes in the floor joists weren’t quite large enough when I pulled the last 3 Cat5e runs through them. I am quite sure I pulled on this one too hard. I did test the cabling and tried to fix this one after I pulled it 10 years ago but I just don’t remember which wire I broke.

sudo apt install ethtool
sudo ethtool -s eth0 autoneg off speed 100

1 Like

Thanks. I did this including setting the duplex to full and then reconnected to the wall jack. I confirmed it was running 100mbps and full duplex but got the same results. After 10 minutes the Ethernet interface dropped. I reinstalled the 5 port Netgear and set back to 1 gig and it’s stable again.

I’ll do some more investigation like connecting a Vero V to my upstream 24 port switch with a 75 foot Cat 5e patch cable. If that works then it points to an incompatibility with the Vero V and my cabling. If not then it points to an incompatibility with the Vero V and my Netgear 24 port switch.

I suggest to install a Keyboard on the Vero and go to Console when this happens to check the interface with ethtool and also the system journal.

Yes, something like dmesg > log would be useful.

You only need 2 usable wire pairs (that’s all that is used for data transfer - even at 1G), one for receive and one for transmit, they must be twisted pairs (properly terminated).
If, for example using T568B, the white/orange orange pair that connect to pins 3 & 6 was damaged you could substitute the the white/blue blue pair or the white/brown brown pair in those positions at each end. They must be twisted pairs, you can’t use white/blue brown for example or any other non-twisted pair combinations.

Got it. Where would you like me to send it ? One thing I notice is that when it running at 100 meg there is no flow control. Where with 1gig both Tx/Rx flow controls are enabled.

Just upload with paste-log after you have connection recovered and share URL

Only pins 1&2 and 3&6 are used for data transfer and the white/brown brown pair in most standard configurations (T568B and T568A) connect to pins 7&8 and would cause no issues if they were broken/missing even at gigabit speeds.

paste-log log should upload it to or you can manually copy and paste with your browser there.

Dome. This is the link.

What was ethtool showing?