Vero V crashing

Not sure what is going on over the last few days but certainly something is not right as my V is freezing up and becoming non responsive. I know I need to provide a log file but here is the issue, it seems that it freezes up over night. This has happened the last few days in a row where I switch over to the Vero and get either a black screen or a screen with ton of vrticle blue/black lines. I can neither get to any menu item or ssh in as it just times out. If I enable logging, will the log file not be massive by having it run for maybe 24 hrs? If not, I will just enable logging and then upload.

As an aside, when I unplugged it yesterday and plugged it back in, it starts normal, so I thought maybe there is an update so I went to the update page (OSMC) and ran a manual update. There was zero progress as it sat at 0% for maybe 5 minutes and then froze up. I have no external drive connected to it as I access files via smb and my nas. Before the freezing happened a week or so back, I would start a tv show or movie and the image would freeze for a split second every 30 seconds or so. If I rebooted just the Vero V, not the nas, all would be back to normal.

Don’t get me wrong, I love my Vero 4k+ and the V, it just seems this V is cursed with the amount of issues I have had. Who knows, maybe Kodi 21 will fix things up?

Cheers, Al

As a starting point I would just upload logs after the next crash maybe they tell something.
But enabling debug logs and upload even after 24 hours of running debug logs should still be fine.
they can be too large but then there are also solutions for that.

Let’s get a log first, then I am sure we can ascertain what the issue is.



Thanks guys. I turned on logging late last night so it is now running. I will use the V a bit this am and then let it sit. It seems it is the idle sitting is when the issue occurs.

OK, update. The V was still working just now and I was also still able to ssh in.

  • I started a show and watched a few minutes, no freezing of video, all appears good.
  • Stopped video
  • checked for updates, worked but none found
  • ran a manual backup, said it worked, back to main menu
  • blue screen, unhappy face, restarted itself maybe 3 times then GUI was back up
  • one press of the direction arrow to move on home screen, blue screen and unhappy face
  • tried to restart itself multiple times, GUI came back, then instantant blue screen
  • again it tried multiple restarts and finally came back, disable logging
  • ran osmc log upload

Cheers, Al

Looks like there was some corruption on the boot drive…

Jul 06 06:17:01 osmc fsck: E2fsck run: /bin/e2fsck -p -C 0 /dev/osmcroot
Jul 06 06:17:01 osmc fsck: Filesystem UUID: be694db2-71a7-4191-baca-f7ee54836b56
Jul 06 06:17:01 osmc fsck: Journal checksum error found in /dev/osmcroot
Jul 06 06:17:01 osmc fsck: Filesystem UUID: be694db2-71a7-4191-baca-f7ee54836b56
Jul 06 06:17:01 osmc fsck: Superblock last mount time (Fri Jul  5 23:52:34 2024,
Jul 06 06:17:01 osmc fsck: now = Wed Jan  1 00:00:09 2020) is in the future.
Jul 06 06:17:01 osmc fsck: FIXED.
Jul 06 06:17:01 osmc fsck: Free blocks count wrong (7005522, counted=6982605).
Jul 06 06:17:01 osmc fsck: Free inodes count wrong (1832765, counted=1832755).
Jul 06 06:17:01 osmc fsck: /dev/osmcroot: 43213/1875968 files (0.1% non-contiguous), 512051/7494656 blocks
Jul 06 06:17:01 osmc fsck: Exit status: 1

I’d try a clean install and see if that fixes the issue.

1 Like

Uuuuuuugh, not want I wanted to hear. I have had so much trouble doing a clean install either via usb or micro sd (previous thread), not looking forward to the grief. Yes it was grief :frowning: The current install is less than 10 days old. Never had all these issues with the 4k+.

FYI - Just tried to ssh in, seems it froze up again overnight. Will maybe try to tackle it after I watch the British Grand Prix.

Cheer, Al

Are you using the supplied power supply or the one that came with the previous Vero?

Do you still have a Vero 4K that you could swap the power supply with? Might be worth a shot in case you happened to get one with your V that has a fault.

I am using the new power supply, I swapped from the 4k+ one on my first round of issues.


Back to the issue I had when I first got this Vero V, struggling to get it to do a re-install. I have tried 6 times in a row, 2 times on each media, downloading a new image each time. Media used is;

Lexar microSD - HC32GB * This was the only sd that allowed reinstall last go round *
Kingston microSD -Select Plus 512MB
Get corrupt data everytime.

Now up to 9 unsuccessful installs. I also tried loading a image via download rather than have the installer download it witch made no difference. No idea what I am could possibly be doing wrong.

Another update, now it is stuck on the first screen, mlogic S905X4 logo and goes no where.

Cheers, Al

Maybe there is something wrong with the device. You could contact and we can swap it over



I’ll also give you an alternative way to reinstall the software shortly.

Would love to try an alternate way rather than swap it out. I just went and bought a new microSD, used the installer and, same thing, waits the 60 seconds, writes the files, then get the error corrupt file.


Morning Sam, any idea when I might expect to see an alternative method to the install. Curious if after it is installed, is there a way to check for any file corruption that may or may not have caused this issue of not being able to reinstall OSMC?

Cheers, Al

Will need a bit of time.

Thanks for your patience.

Please write the following image to a SD/USB drive using the OSMC Installer selecting ‘local image’.

And please take a screenshot of the contents of the media after doing so to ensure it’s correct.

With the Vero powered off, insert the USB or SD card.
Now apply power with the toothpick pressed in for about 10 seconds and release it.

After a period of time, Vero V’s blue LED should start blinking periodically.
This means that the device has been re-imaged.

You can now remove the installation media, remove power, wait five seconds and re-apply power.
The device should now boot.

This process has an integrity check for every partition as it is written. The process will not complete if it fails. This is the same process we use in factory provisioning.

Hi Sam,

I have 2 files that were created, see attached.


Looks good. You can now follow the instructions as advised above.
It will take several minutes depending on:

  • whether you used the USB3 or USB2 port / SD slot
  • the speed of the USB drive / SD card

I can see you’ve sent an email through requesting a replacement. No problem – will pick it up from there.