Vero V & Harmony Elite

Have tried to follow previous instuctions, but the mobile app just says ‘connecting’ when I’m on Vero bluetooth screen. Key presses on the Harmony remote are not registered either.

1 Like


Have you checked your software is up to date?

Can you try pair another Bluetooth device?



Software as in on OSMC ? Yes, that’s update as is Harmony.
Not really, no

OK – maybe another Harmony user can chime in here. I know it’s quite a popular remote and I’m sure some are using it on Vero V.

1 Like

I’m using a harmony elite with the Vero V and it is working just fine. Perhaps you could list the steps you took?

For me, as per the guides I added it as Microsoft - Kodi in order to use bluetooth, then using the original remote went into bluetooth settings and turned both bluetooth and discovery on, then tried to use the remote on the Vero device. After a short delay it appeared in the list on the Vero V bluetooth screen, selected it and selected “Pair and Connect” (from memory) and it was fine.


I already had it set up as MS Media Player on my Harmony as that was what worked last time. Then as I mentioned above, same steps as you really

So it never shows up in the Bluetooth list on the Vero, with both Bluetooth and Discovery turned on?

Yep. What did you have the remote set as in Kodi settings? fliirc?

I have my Vero in Harmony set up as a Microsoft mediaplayer.

on the Vero V?

No, the 4K+

Whatever the default is, I don’t think it matters as the Harmony presents as a Bluetooth keyboard.

1 Like

Added a new device: Microsoft/ Kodi , which comes up as MS Media Player. Going through Harmony app, when I click on new device, it opens a new screen with some text about bluetooth pairing etc but the only options there is to skip.

I do remember this was a pita on the 4k and I had to use bt commands to get system to see it

I have got Kodi to find it by:

[bluetooth]# scan on
Discovery started
[CHG] Controller 5C:C5:63:2A:E1:26 Discovering: yes
[NEW] Device 24:E8:53:2F:68:5F [LG] webOS TV OLED77C16LA
[NEW] Device C8:DB:26:03:89:E1 Harmony Keyboard
[bluetooth]# pair C8:DB:26:03:89:E1
Attempting to pair with C8:DB:26:03:89:E1
[CHG] Device C8:DB:26:03:89:E1 Connected: yes
[CHG] Device C8:DB:26:03:89:E1 UUIDs: 00001124-0000-1000-8000-00805f9b34fb
[CHG] Device C8:DB:26:03:89:E1 UUIDs: 00001801-0000-1000-8000-00805f9b34fb
[CHG] Device C8:DB:26:03:89:E1 UUIDs: 830a5548-5c66-23bd-0949-c0040000227e
[CHG] Device C8:DB:26:03:89:E1 ServicesResolved: yes
[CHG] Device C8:DB:26:03:89:E1 Paired: yes
Pairing successful
[CHG] Device C8:DB:26:03:89:E1 ServicesResolved: no
[CHG] Device C8:DB:26:03:89:E1 Connected: no
[CHG] Device C8:DB:26:03:89:E1 LegacyPairing: yes
[CHG] Device C8:DB:26:03:89:E1 RSSI: -68
[CHG] Device C8:DB:26:03:89:E1 Trusted: yes
[CHG] Device C8:DB:26:03:89:E1 LegacyPairing: no
[CHG] Device C8:DB:26:03:89:E1 RSSI: -60
[bluetooth]# trust C8:DB:26:03:89:E1
Changing C8:DB:26:03:89:E1 trust succeeded
[bluetooth]# connect C8:DB:26:03:89:E1
Attempting to connect to C8:DB:26:03:89:E1
[CHG] Device C8:DB:26:03:89:E1 Connected: yes
Connection successful

Show it shows in MyOsmc UI under paired devices, but the icon is red.

When I try to reconnect:

[bluetooth]# connect C8:DB:26:03:89:E1
Attempting to connect to C8:DB:26:03:89:E1
Failed to connect: org.bluez.Error.Failed br-connection-create-socket

Bump. Not only is the offical remote not working v well, my trusty replacement won’t pair

Unfortunately I don’t have a Harmony to advise, but other users have reported success. Can you try pairing another Bluetooth device?

You could also try reinstall OSMC

I just ordered my Vero V so will try to get it working with my Harmony Elite upon arrival.

1 Like

Same here, it will probably take some time though, haven’t had any update yet … ordered Sunday, so quite early still.

1 Like

@pinn73: You own a “Harmony Elite”. Is this the set with the Logitech Harmony hub?
Here, I have the Harmony hub as standalone and could pair it with the VeroV.

Yep, Harmony hub one.

Did you do through osmc hub?