Vero won't update


My Vero 4K is at update June 2020, but when I try to update it says no updates available.
I tried also with the command-line.

apt-get update
apt-get dist-upgrade

Also, TvHeadend is doing cyclic restarts, so I tried un-installing it with My OSMC, but now I can’t re-install it.

Any ideas?

Many thanks


Did you try the hotfix method?

Hi Sam,

I tried the hotfix.
It still shows ‘no updates available’

When I try command-line, it looks like it is already updated?

> osmc@osmc-Cavendish:~$ sudo apt-get update
> Hit:1 stretch/updates InRelease
> Ign:2 stretch InRelease
> Hit:3 stretch-updates InRelease
> Hit:5 stretch Release                       
> Hit:4 stretch-devel InRelease
> Reading package lists... Done
> osmc@osmc-Cavendish:~$ sudo apt-get dist-upgrade
> Reading package lists... Done

I don’t know if this is the latest kernel…

osmc@osmc-Cavendish:~$ uname -a

Linux osmc-Cavendish 3.14.29-158-osmc #1 SMP Thu Apr 2 18:40:24 UTC 2020 aarch64 GNU/Linux

That’s still out of date.

Is it possible to reinstall the OS and take a backup? That’s the quickest route.

Best the other way around, take a backup and then reinstall a newer version of the OS and restore Backup afterwards

1 Like

Yes, ok I will make a new install.
Is it possible to re-install on the command-line, ie without making SD card first?


No, you need SD Card or USB Stick with the new image

I did re-install with USB stick, and now everything perfect :slight_smile:

Míle buíochas - Many thanks.

1 Like

Glad to hear this.

1 Like