Vero2 - update changed UI resolution to 720p

Running 2016.06-2

How can I set it back to 1080p ? Using Confluence skin in Expert mode but could not find the screen resolution setting.

Thank you in advance

We have not changed hotplug or EDID parsing code for Vero 2 for a few months. Which version of OSMC were you on before?

I see that you are having problems with hotplugging in another thread: TV not "seeing" my Vero2 (sometimes) when turned on - #2 by sam_nazarko

We really need logs to know what’s going on. I would also suggest keeping with one thread so we don’t get too confused.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Enable debug logging, reboot your device, and upload logs via My OSMC → Logger.


Thank you very much.

Here is the log:

Hope it does give you some clues.

Take care

I have limited connectivity, which doesn’t permit downloading logs very easily (sometimes the Internet here works and sometimes it cuts out) so maybe @DBMandrake can give it a quick lookover. Please also run these commands and post the output:

cat /sys/class/display/mode
cat /proc/cmdline (so we can see U-Boot setup)
cat /sys/class/amhdmitx/amhdmitx0/disp_cap


echo 1080p >/sys/class/display/mode

Put your TV in 1080p?

Have you made any changes to your equipment recently?



Dear Sam,
I have found the proper entry in the Settings menu and had put back the GUI in 1080p manually so that problem is now apparently fixed.

I don’t know if the output you asked for is still of use but anyway here it is:

osmc@osmc:~$ cat /sys/class/display/mode
osmc@osmc:~$ cat /proc/cmdline
init=/init console=ttyS0,115200n8 no_console_suspend storage=1 vdaccfg=0xa001 logo=osd1,loaded,0x7900000,720p50hz,full hdmimode=720p50hz cvbsmode=576cvbs androidboot.firstboot=0 hdmitx= mac=08:61:60:11:27:1d console=tty0 consoleblank=0 osmcdev=vero2 root=/dev/vero-nand/root hdmitx=cecf quiet
osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/disp_cap

No the Sony TV and Yamaha DSP are the same I had before with the Vero and then the Vero2 since I got it and I’m experiencing the “Vero2 not detected” glitch for a few weeks but not before. Sorry I am not able to be more precise.

Can live with it by ssh-ing and rebooting it via cmdline but it’s not optimal !

Thanks a LOT !


Looks like your TV doesn’t advertise a preferred mode of 1080p, so U-Boot picks it up as 720p.

Try powering your TV first, then your AV receiver to fix the ‘not detected’ issue. Otherwise we can possibly disable hotplugging.

cat /sys/class/display/mode
cat /sys/class/amhdmitx/amhdmitx0/disp_cap

Would also be useful when your TV is not detecting the Vero 2 signal.


Will try and report. Thanks a lot