Vero4K+, after idle, blank screen and no response (have to reboot via ssh or power cord)

Do you have SSH access to the system?
Also does the LED stays blue when the display is blank?

Indeed - it is worth checking if your TV is turning off the device via CEC.

I’ve noticed on mine that I need to press the “stop” button after an extended downtime to bring the screen back (I use a universal infra-red remote, not sure if the out-of-box vero remote has a stop button). Only the “stop” button has any affect, none of the other buttons have any effect. I’ve always assumed it was the screen saver. (I think I’ve got it set to the “black screen” saver)

So, if you’ve got a stop button, try that.

I disabled the CEC. No button on the remote seems to have an effect unfortunately.

I have SSH access and I’m not sure I’ve seen a blue LED?

Hi,

If you are using your TV remote, you will need cec enabled. ActionA meant check settings relating to the display being switched off, so I would check the following cec settings are set to:

Put devices in standby when activating the screensaver - disabled
When the TV is switched off - Ignore
Devices to also put in standby mode - disabled.

And renable cec.

Thanks Tom.

Apologies for explaining poorly. I’m not using CEC, I’m using a harmony remote. I can still utilize it after disabling CEC, but pressing buttons did not have an impact on the blank screen.

Hi,

I think we going need some logs before we can investigate further. If you happy to have the debug overlay visible while you wait for this issue to reproduce its self, you can follow these instructions:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Or if you prefer you can make the debug logs overlay invisible by adding:

<loglevel>1</loglevel>

to advancedsettings.xml.

Thanks Tom.

Thank you Tom and sorry for the delay.

https://paste.osmc.tv/ekeyeyenov

Hi,

Does issue still occur if you disable the Unsplash Photo Screensaver addon?

Thanks Tom.

Hi Tom

I disabled and uninstalled unsplash and rebooted. Behavior persists unfortunately.

Please provide a fresh log, with unsplash uninstalled.

Thanks Tom.

Hi Tom,

Here is the log

https://paste.osmc.tv/amididoput

Can you confirm if you have tried it with HPD lock disabled?

1 Like

Hi there!

Turning HP lock to OFF has fixed this issue!

What happens now (and why I had originally enabled the HPD Lock feature) is that when I return to the Vero box after the TV is off, the resolution is set to 1920x1080 and I have to go into settings and select 4K as the screen is off-the-edge.

On the vero or the TV?

Sorry, the Vero changes to this resolution.

You don’t want to run your Vero with Kodi set to a 4k resolution. This setting is really only relevant to the GUI, not the media you play. Set it to 1080, use the zoom/aspect or setting on your TV that disables the overscanning (off-the-edge as you call it).

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Thanks! This was really helpful. Is there a curated list of recommended configurations available somewhere?

Not really, different configurations are site specific. This one is not one of those.

Got it.

Just wanted to say thanks to everyone – really appreciate the support, and I’ve had no issues since I modified my setup as specified.

Thanks once again!

1 Like