Vero4K Crashes


With some friends, we recently bought 3 Vero4k.
Sadly, the one I kept sometimes crashes:
Without any obvious cause, my TV screen goes completely black (no input). At the same time I lose any opened connections to the device (Transmission, FTP, SSH,…)

The issue happened while I was watching a movie, while I was browsing menus, and several times when I wasn’t even there.

When that happens, the only thing I can do is unplug the power supply, it does not reboot or come back even after hours.

I tried to reinstall OSMC twice.

I have nothing connected to the Vero4k (well, except remote, screen and network obviously)

I use a network drive mounted with fstab.

At first I thought of a software issue that would hopefully be fixed soon, but seeing that none of my friends got the same behavior at all, I’m not that sure anymore…

I retrieved logs:
Issue happens around 19:50 and I can see nothing significant :frowning:

Thanks for your help :slight_smile:


These are not debug logs, and therefore:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.


When you say you tried to reinstall? Was this successful? Did you see the OSMC installer come up?

I can see you’ve installed a few packages on your device. Do you have problems before installing them?

Was this problem always present, or did it only occur recently?

Sorry, I meant I reinstalled twice (successfully)

It happened the first time it booted, though I didn’t pay much attention at first. But now it’s happening more and more.

I’ve had the Vero for 4 days now, it was completely new when it crashed.

And when I reinstalled, I just had a black screen until I got to the configuration menu (language and so on), is that normal?

Sorry to hear this.

As you and your friends seem to have a few devices, have you tried taking the Vero 4K to their house or swapping it and seeing if it works there?

No I haven’t tried that? Do you really think it could change anything?

Regarding the installer, is it normal that I see nothing on the screen until the install is complete?

I enabled debug yesterday, I am waiting for the issue to happen again to check whether I get better logs.

It depends. It’s possible there’s a display bug for the installer, as the display code isn’t as robust in that.

So depending on your display and the capabilities it advertises there could be a problem there. If the installer is successful your SD card should have a file called installer.log on it after running

I’ll check that as soon as I get home.
Though I don’t see why it wouldn’t be successful, at the end of the process I had to start my entire configuration from scratch, reinstall packages and so on.

The installation was indeed a success.

Regarding the crash, it hasn’t occurred since I enabled debug mode… It’s its longest run ever I think.

I think you can consider this topic as invalid. I don’t know what changed but it does not crash anymore :smile:
I don’t think I changed anything, but as long as it stays that way, I’m perfectly fine with it ^^

Thanks anyway :slight_smile:

Great. Let’s keep an eye on things and see how they go.


Hi again,

Sadly, the issue came back. Debugging mode was enabled in the settings, but it looks like there is nothing more in the logs than last time.

Issue happened around 20:43 but there is nothing between 20:17 and 20:45 (time of the manual reboot)
The screen just froze with all CPUs to 100%. SSH, FTP and all web services stopped working at the same time.

I have no idea what else to try or provide :frowning:

Sorry to hear that.

Are you able to swap the PSU with anyone else (albeit temporarily) to see if it resolves the problem?

Do you have any background services running on the device?
I can’t think of why all cores would be at 100% in Kodi or playing back any media. If you’re running some other programs, does disabling them prevent the crashes?

Otherwise we can of course swap this out for you. If you have a program causing a crash though, I don’t want to send you a replacement and for you to have the exact same problem.

Hi Sam,

I’ll ask m’y friend to swap the PSU, just to be sure.

As background services, I have Couchpotato, Transmission, Sickrage, SSH and FTP server.
I also have Library Auto Updater and TVshow time, but I don’t think those are running in the background.
I recently added Headphones (the service) but I had the issue before.

I didn’t find anything about any of those causing problems, but I’ll try disabling everything and see if it keeps crashing.

I’ll keep you posted

Once it freezes I can’t take a screenshot so here is a photo ^^’

I think too many services on your device may be overheating it. That’s obviously a bug.

Another user has a problem with overheating, he’s also running Transmission. So I will investigate.


Please try running these commands via SSH before changing the power supply:

wget "" -O kernel.deb
sudo dpkg -i kernel.deb
sudo reboot

I think either the power supply or the update above should resolve your problem; but you should try the software fix first.

Verify that the version is installed with cat /proc/version. It should show a compile date of Wednesday, 5th April.



I installed it (compile date is tuesday 11:30pm so I guess it’s ok)
Let’s see how it does today

Well it froze again, I’ll try the PSU thing tomorrow.

Have you tried with transmission disabled? If this is causing 4 CPUs > 99% and overheating, then that’s probably the issue.
I have Vero4K with Live TV (HD channels), and kids watching youtube videos, movies, etc. It’s running 24/7and doesn’t get hot, and CPU is always very low.
I also have ftp and ssh, but not transmission.
I don’t think CouchPotato/Sickrage cause high CPU, but definitely transmission does.
Also the Library Auto Updater - try disabling that.

I think me too, but mine crashes with and without transmission enabled…