Vero4K doesn't see update newer than November 2020 2020.11.1

I’ve tried to apply the hotfix (first one mentioned here) but after that still no new update. Also did a reboot in between.
Latest version OSMC still: November 2020 2020.11.1

Here is my log file:
I prefer not to do a reinstall.

Tom asked me to run this, so here is the result:

osmc@osmc2:~$ sudo apt-get update && sudo apt-get dist-upgrade
Get:1 buster/updates InRelease [34.8 kB]
Get:2 Index of /debian buster InRelease [122 kB]
Get:3 Index of /debian buster-updates InRelease [56.6 kB]
Hit:5 Index of /debian/ stretch InRelease
Hit:4 Index of /osmc/osmc/apt buster InRelease
Reading package lists… Done
E: Repository ‘ buster/updates InRelease’ changed its ‘Suite’ value from ‘stable’ to ‘oldstable’
N: This must be accepted explicitly before updates for this repository can be ap plied. See apt-secure(8) manpage for details.
N: Repository ‘Index of /debian buster InRelease’ changed its ‘Versi on’ value from ‘10.10’ to ‘10.13’
E: Repository ‘Index of /debian buster InRelease’ changed its 'Suite ’ value from ‘stable’ to ‘oldstable’
N: This must be accepted explicitly before updates for this repository can be ap plied. See apt-secure(8) manpage for details.
E: Repository ‘Index of /debian buster-updates InRelease’ changed it s ‘Suite’ value from ‘stable-updates’ to ‘oldstable-updates’
N: This must be accepted explicitly before updates for this repository can be ap plied. See apt-secure(8) manpage for details.
N: Skipping acquire of configured file ‘main/binary-arm64/Packages’ as repositor y ‘Index of /debian/ stretch InRelease’ doesn’t support architec ture ‘arm64’


The Following should get you up to date:

sudo apt-get --allow-releaseinfo-change update
sudo apt-get dist-upgrade -y
sudo reboot 0
sudo apt-get dist-upgrade -y  

Running the above commands should be perfectly safe, but being as the base OS is being updated; I suggest backing up via MyOSMC first.

Regards Tom.

Apologies, I’ve just been informed the above upgrade method is no-longer officially supported. I suggest backing up your settings and restore them on a fresh install.

Regards Tom.

thanks Tom. I’ve reinstalled completely and restored my settings (that I back-upped before starting).

I can now make the subtitles darker grey and transparent so perfect for HDR media!

Unfortunately however, everything is running worse now.

  1. Some files are completely unwatchable because they lag a lot already from the start. (file 1 below)
  2. All media have microstutters visible while the image is moving (panning). It’s not going fluently (file 2 below). Maybe some people wouldn’t notice this but I clearly notice it.
  3. Some files are unwatchable due to a lot of stutters, but I’ve only seen that in a movie that is 140gb and probably has all the bells and whistles (.2160p.BluRay.REMUX.HEVC.DTS-HD.MA.TrueHD.7.1.Atmos-FGT) so maybe that’s just undoable for the Vero4k.
    I never saw this file before upgrading so I don’t know how this would’ve ran before upgrading. (file 3 below)

Here are the logs:

  • Full log
  • 3 mediainfo’s of the 3 files I tested. 1 and 2 are series episodes (different series) and the 3rd one if the large movie.
    file 1
    file 2
    file 3

PS After I created the logs I saw in my own advancedsettings file that it was overwriting some OSMC suggested settings so I also removed those and tested again but it had the same results. Mind you I didn’t create new logs files after that. If needed I can do so.

I see some errors in the logs so perhaps with tweaking something we can solve these issues.
Mainly 1 and 2.
I hope you have any ideas. Also tell me if I need to create a new topic for this.

grab-logs -A output will be more useful than this Kodi log alone in order to see more/other configuration that has been done or missed.

Additionally, after checking your original log it seems you have the UI resolution set to 3840x2160. This could be part of your issue.

We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate>Always

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Many thanks for your reply. This has helped a lot!
Much appreciated that you guys take the time to support and give specific information/guidance!

So far issue 1 and 2 seem fully solved! I’ll do some more testing to be sure about issue 2 though.
Issue 3 I think has to do with caching/buffering. It’s a very large file and stream (bitrate) and when I pause it it plays well for a minute or so.
I’ll see if I can fine tune the buffering somehow but if you have a tip let me know.

Again many thanks for your (and your team’s) quick and helpful support!

Glad to hear it.

That might be a problem with network speed. How are the Vero 4K+ and the data source networked (WiFi, wired Ethernet)? Is your source defined as an SMB or NFS source within Kodi, or are you using something like autofs or fstab to mount it at OS level? Have you tried copying the file onto a USB stick and connecting directly to the Vero to see if that plays any more smoothly?

Running iperf3 might give you some info about network performance:

We’re not quite there yet. Video seems to be going well now in both sdr and hdr.
Couldn’t check on issue 3 yet by the way.

However I notice that sometimes the subtitles don’t go away instantly. Rather they build down from top to bottom or the other way around (it’s too fast so I can’t see the direction).
It’s a matter of milliseconds and others maybe don’t even see it.
It’s not with every subtitle, just occasionally but enough for me to notice. I can’t tell if the same happens with the whole video/screen, I just see it clearly on the subtitles.
Happens with both sdr and hdr videos.

I grabbed the logs as ActionA said. I stopped the video after I saw a few of those occurrences.

Any ideas?
Let me know if I need to create a new topic.

Might be the same issue that was raised in this thread…?

If so, you’re probably going to have to learn to live with it.

Ok yes that sounds exactly what I notice. Thanks for mentioning that topic.
I’ll reply there just to it’s visible I encounter it as well.

At least I know it’s just the subs :).