Vero4k+ Extremely slow network speed

Hi,
I have the same issue as

Same setup (everything wired) and with iperf3 i get varying speeds, mostly somewhere 1 - 10MBit. If I run it multiple times, sometimes I get lucky and hit >900MBit. But mostly <10MBit.

With autofs this works fine for watching 1080p x264 content, but recently i tried to watch some 4k stuff and it buffers for 1min every 1min.

In the post above it is said, that it may be a “faulty unit from the early days” - I ordered mine very early as well (last email I found was the order update from 10th August 2018).

Thanks for looking into it.

PS: Another thing: the remote stopped working after ~1month of use. I didn’t care much and switched to the Android app. But would be nice to have it working again :slight_smile:

Have you tried running an iperf test in both directions?
If your hardware is faulty, you will never reach the 900Mbps speeds.

Try changing the battery / repairing the remote.

Sam

Yes, same thing, no matter the direction.
Just did it twice and both times ~3MBit

Then the issue will not be hardware related, but rather a problem with the network cable, switch or network environment.

Sounds like a potential duplex mismatch

Affected devices only had issues in the TX direction and not the RX direction.

I suggest some logs and learning more about your network setup

Well, just to make sure and “exclude” it as a source of error, I used another switch - no change.
Then I used a different LAN cable - problem solved.
Which was quite unexpected, since I use the same one for the NAS and it runs for ~2years in full GBit mode. Especially since they are U/FTP Cat 6 cables with just 5m.
Maybe one of them has a production error.
Thanks for your quick reply Sam and have a nice Weekend.

edit: I just tried to use the “working” cable from the NAS on the Vero4k and it was the same issue… so as it seems, its not the cable but for some weird reason the vero4k doesnt like the cable type o.O
Maybe it’s got something todo with the fact that it is a flat cable. I guess I order 1 or 2 different ones and try them out.

That’s odd. Maybe the cable isn’t making a good connection. It should make a little bit of a click when connected.

I had bad experience with short (50cm) flat patch network cables. Bought from a reputable place and claimed Cat 6 compliance but had a range of intermittent issues: dropping off the network and then connecting again. Connection speed fluctuating from 1G to 100M.

My advice: stick with standard network cables.

1 Like

Hey there, it has been a few weeks. This is my update report:

  • I bought a brand new super duper Ethernet cable (cat6, good shielding, not flat) and… nothing changed. According to multiple iperf3 tests i get varying network speeds between 4MBit and 18MBit. During the test the bitrate temporarily drops down into the kBit range…
  • I was surprised, cause when I used one of the cables I had lying around, I got good speed. However, this was a 100MBit cable.
  • As it turns out, if I block pins 7 & 8 of my brand new GBit Cat6 cable (which downgrades the connection to 100MBit), I get super steady 95MBit network speed. This is solemnly the case with the Vero4K - all other devices in my network work with 1GBit speed. Even using another switch instead of the router doesn’t change the situation.

Conclusion:
My Vero4K seems to have an issue with GBit connection speed - using 100MBit works perfectly. As it is enough speed for 4k videos and such i will leave it at that; hoping I won’t need GBit anytime in the future.

Hi,

May be worth providing some logs, probably fixable or would least help indicate if it is indeed a hardware fault:

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

Regards Tom.

Hi Tom,

thanks for the effort.
I did as you posted. However, once I reboot the device, the logging settings got turned off again… Tried using the regular reboot button as well as cutting power.

Anyway, here are the logs:
https://paste.osmc.tv/niseqozezu

Hi,

I missed this:

So you’ve had a cable that solved the problem, so why not just use this cable? Or Have misunderstood?

If I have misunderstood, could you please clarify your setup: -

  • Is is straight run to the router or is there switch or a powerline adaptor involved?
  • What make is the router?
  • Does the router have a jumbo frames setting? If so it should be turned off.

Thanks Tom.

100 MBit connection does work.
1000MBit connection does not work.
Cable is fine. Tried a simple switch instead of the router = same issue.
This lets me assume, that the vero4k is at fault here.

The router is a cbn CH7466CE and, as far as I can tell, it doesn’t have a jumbo frames setting.

It seems that the V4K+ was announced on 25 July 2018 so it would have been an early model.

@sam_nazarko

@Nyalee - what’s the order number?

Order number:
[#19496 ]

That shipped on 17th September – we were on top of the problem by then.

Can you please provide the iperf results in both directions?

Are you using a shielded network cable? If so then that may cause some issues as they are not fully compatible with all network plugs. They are also very unlikely to provide any benefit in most applications.

What do you mean by this? Do you mean that it was only Cat 5 and not 5e, or that it only had two pair connected (which would be highly unusual). Unless you have a particularly long run, or one with a lot of external interference, a regular Cat 5 (100mb/s) cable would normally have zero issues maintaining full gigabit. Using Cat 6 for a gigabit network outside of structured cabling is rather pointless and a waste of money.

That was a useful test.

The log shows that the ethernet interface negotiated 1000 Mbits / full duplex with the router. It also shows that it was taking a very long time to ping the internet.

Using the same switch, which I assume is gigabit, can you provide iperf3 figures – in both directions – to a PC/laptop that’s also connected to the same switch. This should take your router out of the equation.

Here are some more iperf3 results.

Can you provide some context to the results? For example, in which order should they be read?

One of the switch tests is showing full gigabit speeds, which is interesting. Are you aware of anything that might have changed to cause this, and did you run a further test afterwards?

In future would you please copy/paste text, rather than pasting an image, and format with the </> button.