Vero4k+ Very Slow Send Network Speed


I have a vero 4k+, wired via gigabit ethernet connection, to a NAS on my network via my router (a Netgear R7800 Nighthawk router)

I’ve been trying to figure out a networking issue which I’m hoping someone can help with.

It seems my unit suffers from an unexpectedly slow network speed when sending, but as fast as should be expected when receiving.

For example, if I run:

NAS: iperf -s
OSMC: iperf -c nas.local

I get (on the OSMC side):

Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
[  4] local port 5001 connected with port 47670
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-11.3 sec  1.75 MBytes  1.30 Mbits/sec

Alternatively, if I run:

OSMC: iperf -s
NAS: iperf -c # the vero4k's ip address

I get (on the NAS side):

Client connecting to, TCP port 5001
TCP window size: 85.0 KByte (default)
[  3] local port 52036 connected with port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.03 GBytes    882 Mbits/sec

I’m able to reproduce these results if I use my laptop in place of my NAS, and using a different ethernet cable between the router and the vero4k, and plugging the vero4k into a different ethernet port of the router, so at this point I’m pretty sure the problem exists on the vero somewhere.

Is anyone able to offer some hints as to where the problem may be? Or other diagnostics to run to point me in the right direction?

Kernel version is 3.14.29-156-osmc

Thanks very much!

Your iperf figures suggest the opposite. The client sends and the server receives.

So the Vero4k+ transmit speed is 1.38 Mbits/sec.

Was this device from an early batch of the Vero4k+?

Thank you for the correction; I’ve corrected my post and title.

I think the unit would have been from an early batch. The order was placed on August 1, 2018, which if I remember correctly, was pretty soon after it was released.

Indeed it was. I checked the V4k+ announcement on the OSMC blog and it’s dated 25 July 2018.

I think this is one for @sam_nazarko

Sounds like it may be a faulty unit from the very early days.

I would suggest raising a support ticket


Thanks very much @sam_nazarko and @dillthedog. Ticket raised (#495722)