Vero4k freezing issues... easily replicated on all 3 devices

Hello people, I was gonna pester Sam direct on messenger but thought I’d try save him the work and ask if you guys-n-gals if you know a solution…

I have a Vero4k in my kids bedroom, they use it mostly to watch films via a NFS share to a mycloud nas server downstairs… what tends to happen is they get put to bed just after 7pm, and watch a film, when finished it quits back to the film selection screen… the problem I’m finding is that 95% of the time the next day the box is frozen and won’t respond to the remote, and with no other means of control it means pulling the power, after which it works fine there after… until the next day.

So far I’ve found if I exit all the way back to the main menu at night, normally it’s fine the next day… when it’s froze I’ve tried unplugging and reconnecting the remote USB but the box remains frozen… I have another 2 Vero4k in the house on other tvs and I can replicate the same issue on them all… however the others tend to be used on on.tapp tv in the evenings so don’t get left on the movie screen, and therefore don’t freeze up…

Any ideas?

Would suggest to try accessing it via SSH to know if it is just the GUI that is froozen.
If you still can access it via SSH you then also can provide logs via grab-logs -A you might also want to enable debug logging to ensure we can find whats happening

That’s a good plan, and one I hadn’t thought off… I have tried unplugging the usb and the hdmi but it made no odds.

Thanks and I’ll see how it goes

Sounds similar to what another user reported.

If running this command via SSH:

curl --header 'Content-Type: application/json' --data-binary '{ "id": 1, "jsonrpc": "2.0", "method": "Player.Stop", "params": { "playerid": 1 } }' ''

makes Kodi responsive again, then it’s a Kodi bug and I’m working on a solution.


Hi Sam,

Is there any news on a fix for this issue? This sounds like the same problem I’ve been having every day for about a week now. For me, though, I find it frozen in the morning AND in the afternoon when I come home from work. So it seems to be freezing during periods of about 8-9 hours inactivity.

I usually keep one terminal open on my mac ssh’d into my vero4k and another terminal ssh’d into my seedbox, so I can tell you that when I find it frozen, I always find a broken pipe message in the terminal which is ssh’d into the vero:
packet_write_wait: Connection to port 22: Broken pipe

…while the one ssh’d into the seedbox is still connected. Trying to ssh into the vero again fails until I’ve pulled the plug and let it reboot.

I don’t think there were any updates around the time the freezing started.

EDIT: Maybe this is related seeing as it started happening at the same time as the problem described above… After 5 minutes of inactivity on the vero my TV switches to another channel.

I don’t know whether the TV is switching to another channel because the vero has stopped sending a signal to my TV or because my TV has stopped receiving the signal the vero is sending.

Either way I end up having to switch back to HDMI1 to see the OSMC interface again.

EDIT: Since I posted this, the vero has frozen twice during playback as well. SSH was frozen too and I had to pull plugs to reboot.

I’ve actually been struggling with coming home to a frozen (or at least unresponsive) Vero as well. I’ve only been using the device for a few weeks so wasn’t sure if it was a known issue, and I haven’t really had a chance to delve too deep just yet.

Next time it happens I’ll try and SSH in to see how severe it is, and will provide logs if necessary after that.


The issue was reported a few months ago. It doesn’t seem to be related to a specific software problem.
I would recommend disabling CEC if you can and seeing if this improves things.


Hi Sam,
Same here. After a few days, with the TV on and off a few times too, I cannot control the box via cec with my TV remote anymore.
I didn’t try to ssh yet (just noticed this hint), but also I would be unhappy with switching off cec because I want to use the TV remote.

Okay. I’ll try it and let you know.

EDIT: Okay, after disabling CEC, it stopped freezing. That didn’t resolve the issue where would switch to another channel after 5mins. However, I found I had a screensaver plugin that was no longer functioning properly. After disabling the plugin, I no longer had the switching channel issue either. Had a couple of freezes during playback but that seems to not longer be occurring so it’s all good for me now. Cheers

Keep your OSMC remote dongle plugged in.
It would be good to know if you can control OSMC with this when the box appears to be frozen. Another good way to see if things are frozen is to check the time on the display. If the clock is quite off, you also know when it froze.


I will try that. But, I am using the picture slideshow screensaver, so the effect is I cannot exit the slideshow. No checking of the time is possible therefore

Maybe disable the screensaver for the time being to make testing easier… :slightly_smiling_face:

Short update : no response from the TV remote after the TV being switched off for a day or so. I am still able to ssh to the Vero though.
My guess is, that the ece connection is lost somehow.
I have no idea how to reestablish this.

Same procedure as for pi.

Ahem, I think it’s easier to just unplug the Vero - that’s what I did so far when this occurred. But I am unhappy with pulling the plug on the Vero and I am curious if there is any better way to archive the same result

sudo reboot from ssh

I assume this is a softer option for restarting the Vero. Or is it just the same as pulling the plug? Does the Vero care?

But, what I am hoping for is to refresh the ece connection somehow while having both devices running

This would be the preferred, more graceful way to restart the Vero.

I’m not certain but, Sam may have implemented a new HDP (?) lock, maybe in MyOSMC settings that may resolve this issue.

If you keep pulling the plug on Vero 4K, it will not be happy one day.
I think your issue isn’t related to that of other posters: as your device does remain responsive, CEC just breaks.

The suggestion to reset the TV should be a ‘fix it for good’ solution; so it would potentially resolve your problem permanently.

There’s a CEC fix for a very small number of displays coming soon. It’s possible this may yield some improvements for you.


@osmc_fan I see this occasionally when I turn my TV on. If I switch the TV to another source, and back to the Vero it always restores CEC. See if that helps you.