Vero4k Remote - Mapping broken in Pictures slideshow

Hi,

Last week I received my new Vero4k … really like the device, even though some setup steps are not straight forward.

The mapping of the remote control when using the picture slideshow seems to be broken. I haven’t changed anything (so my setup uses all default options), however, I cannot pause a slideshow, check the details of a picture in the slideshow, or use any of the keys. (Only 4 actions work: stop a slideshow, rotate a picture, and move forward/backwards)

Is there any option to manually configure an action for each of the buttons of the remote? (e.g. pressing pause for pausing the slideshow, pressing a button for showing the meta infos of a picture, …)

Thanks
Pete

Hi

You have probably received our new remote. We are still adjusting the keymap and will have this solved in a few days.

Sam

Thanks for the quick response.

Please keep me posted. I’m happy to test the fixed mapping.

You should be able to view the file information currently by holding down the play/pause button. Unfortunately Kodi seems to only be programed to pause a slideshow with a “pause” button and so we have to tweak a keymap for that. Also unfortunately the keymap editor add-on is not going to work for this. If you don’t mind getting your hands a little dirty and you want to SSH into your Vero then you can type in…

nano ~/.kodi/userdata/keymaps/gen.xml

and copy paste in the following…

<?xml version="1.0" encoding="utf-8"?>
<keymap>
	<slideshow>
		<keyboard>
			<play>pause</play>
			<play_pause>pause</play_pause>
		</keyboard>
		<remote>
			<play>pause</play>
		</remote>
	</slideshow>
</keymap>

Then ctrl-x, y, and enter to save and exit. You can then type in…

kodi-send --action=reloadkeymaps

and that should allow you to pause a slideshow with the play button.

Logging in let ssh was no issue… and I updated (actually created the file … there was no file at this location) the key maps file as described.

However, the pause action does not work. Tested with reboot and manual reloading of setting :frowning:

That file is only there when you have used the keymap editor add-on. I didn’t have you go that route as that button cannot be mapped with that program without a funky workaround. I noticed that I accidentally added an open tag to that xml I posted (sorry) which probably kept that keymap from working. I updated that post with revised code. If you do have the new remote that should work as it does with my testing. If you actually have one of the old remotes i’m not sure if that is the correct identifier or not, and I don’t have one of those remotes to test myself.

Did the updated keymap get this working as you expected?

Unfortunately, I cannot test the fixed xml snippet, since the Vero is now at my parents place… so I have to wait till I visit them next time to do some checks.

Maybe there will be an update in the meantime which fixes the bug anyway.

This has been included in with our longpress update that is currently in testing. You can find out more in this thread…