Vero4k+ Shutdowns itself if not in use

Hey Guys,
I have a Strange Problem with my Vero4k+.
If my Device is not in use (and TV is off) it shutdowns itself and is not reachable over SSH after it goes off.

But if i stop (pause) my Videoplayback and turn off my TV, Vero4k will stay on.
I checked my Kodi Logs and this is the Line before my Vero4k shut itself down:

2020-04-08 21:54:32.921 T:4064817152   ERROR: CPythonInvoker(7, /    home/osmc/.kodi/addons/ script didn't stop in 5 seconds - let's kill it
2020-04-08 21:54:37.215 T:3849302752 WARNING: CPythonInvoker(2, /usr/share/kodi/addons/script.module.osmcsetting.updates/ the python script "/usr/share/kodi/addons/script.module.osmcsetting.updates/" has left several classes in memory that we couldn't clean up. The classes include: N14PythonBindings31XBMCAddon_xbmc_Monitor_DirectorE,N9XBMCAddon7xbmcgui6WindowE,N9XBMCAddon7xbmcgui12ControlImageE
2020-04-08 21:54:37.243 T:3815731936  NOTICE: Skin Helper Service --> Shutdown requested !
2020-04-08 21:54:37.246 T:3815731936  NOTICE: Skin Helper Service --> Skin Helper Service version stopped
2020-04-08 21:54:40.225 T:4064817152  NOTICE: Application stopped
2020-04-08 21:54:40.425 T:4064817152  NOTICE: XBApplicationEx: destroying...
2020-04-08 21:54:41.149 T:4064817152  NOTICE: unload skin
2020-04-08 21:54:43.496 T:4064817152  NOTICE: unload sections
2020-04-08 21:54:44.056 T:4064817152  NOTICE: XBApplicationEx: application stopped!

Maybe someone can help me with this :slight_smile:

We need to see full logs, not just a part of the Kodi log.

Does the light on the front turn red?

Yes, the light turns red and the device is not reachable over ssh.
It appears only if the device is in an idle state (Vero4k is at the home screen).

Here is my full Kodi log:

That normally means shutdown due to overheating. So suggest to watch CPU usage and Temperature via SSH while you have the Vero on idle.

I tested it this way.

  1. I let my device at the Homescreen with a turned off TV after 10 minutes it was going off.
  2. I started a Video Stream e.g YouTube and let a 1 hour Video played with a turned off TV. After the 1 hour the Device was still on.
  3. I started a 4K Video Stream from my NAS Server and paused the Video after an hour of watchin it I turned off my TV.
    6 hours later I started my TV and pressed the play button on my remote control, so I can resume my playback and everything works perfect.

I really don’t think it’s due to overheating.
It looks more like that something is triggering a shutdown if the Device is in an Idle state.

But nevertheless I’ll test it and report to you ))

If you can reproduce so easily I suggest for SSH windows:

  1. tail -f .kodi/temp/kodi.log
  2. sudo journalctl -f
  3. htop (may need to install first with sudo apt-get install htop)
  4. watch cat /sys/class/thermal/thermal_zone0/temp

Okay i reproduced every step on my mac laptop and putted my Vero4k+ to my home screen.
After 1 min my Display goes black (screensaver).
This time i let my TV on (going to watch some Netflix over Android TV APP) and will watch the CPU Temp of my Vero4k with my Laptop.
I will report than back to you, if my Device is shutting itself down (with TV on) or not.

Thanks for helping.
May i ask you what this command does “sudo journalctl -f” ?

That shows the system log as they are recorded.

Update 1hour Later:
TV is on (watching Netflix)
Vero4k+ is in Idle mode
CPU temp around 59°C nothing out of ordinary in the logs for now.
I have a feeling it somehow depends on if my TV is on or not. Maybe something with CEC…

If nothing out of ordinary happens within the next hour, i’ll turn off my TV and let my ssh sessions open.

Out of curiosity, what skin are you using?

Update after 1,5 hours my Vero4k shutted itself down.
TV was on
CPU Temp was 60°C
All other Windows didn’t show any changes. Maybe cause my PC went to screensaver 5 min before Vero Shut itself down…

@stefannh deafult OMSC skin

Edit: I will replicate all the logging steps on my main PC. I turned off all hibernation function, so i can watch this all in realtime

Back in post #2 @bmillham said:

You provided just a Kodi log. We still need to see full logs to have any chance of helping.

How do i get the full logs?
is this right?
Settings -> System -> Logging -> and selecting Enable Debugging ??
And then uploading the kodi.log?
or should i do this via my osmc?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Guys i think i maybe found the Solution.
I hope at least so.
If you go to the Power Off Menu it opens a Sidebar.
In the German translation there is not enough space to display the whole sentence.
So i can only guess what is written there but i think it say: Shutdown if idle allowed.
I pressed it and now it should say: Shutdown if idle disallowed.
Hopefully that will fix it.

If thats the solution, its kind of a contradiction in the translation.
cause now it says “Shutdown if idle disallowed ??”
i would assume if i press it it will disallow the shutdown not allow it.

I will report back ))

Okay that above didn’t help me either.
I upload everything i logged so far.
my device was the whole time in idle mode.
Debug logging was enabled and I restarted my Device twice as you suggested.
The only thing i deleted from the log are my opnvpn keys, cause my device automatically connects to a VPN on startup.

Here are the logs:

Kodi full log:
tail -f .kodi/temp/kodi.log:
journalctl -f:
CPU temp: was at 60 Degree at the moment of the shutdown

Those aren’t full logs. As noted above in post #15:

If using My OSMC, choose the “All configs and logs” option.

i used the ssh method and got and url from this

Please post the URL.