Vero4k thermal shutdown

Short description: Vero4k goes to standby on it’s own, despite settings.

Long version: Vero worked just fine last month. Now after a short break from using it, the device goes to stanby when left alone. It can no longer be turned on by remote, just by power cycling by pulling the cord.

Vero is connected like this: Vero4k -> Yamaha YSP-2700 -> Samsung KS7005. Vero physically sits behind the soundbar on an open shelf.
HDMI-CEC is on in all devices. Vero4k CEC-settings are set to allow HDMI control, but the only change it’s allowed to make is to vhange input when turned on. When shutting down TV or soundbar, Vero stays on but shuts down/standbys on it’s own at some point (for example in the night).

Vero power saving settings are off, so no stanby timers on.

I am using the Mimic skin and Plexkodiconnect if those should matter? The system worked for a long time and this behaviour started recently. I’m not sure if it was before or after the latest monthly update, probably after.

Have I understood correctly, that logs can’t be accessed after power cycle, so I can’t see the logs for explanation on this?

Hi,

Please upload logs via myosmc and provide the url. The logs from before the powercycle will be attached.

What colour is the led when it goes in to standby?

Have you tried removing the HDMI cable and re-attaching? Could be the TV has lost the signal?

Thanks Tom.

1 Like

Hi,

I’ll do the logging the next time I use the Vero and upload the log.

The led stays blue when I turn off the TV and soundbar, then at some point (haven’t clocked time it takes, usually during the night) it turns red and Vero can’t be accessed and needs to be power cycled.

I have tried removing all HDMI-cables going between Vero, TV and soundbar. This was needed to fix HDMI ARC issues between TV and soundbar. Even when ARC has been down in the past, Vero has been working so those are not related.

1 Like

This sounds like overheat shutdown. In standby the Vero still would be reachable by network.

1 Like

So it should be accessible by SSH connection?

HDMI input switching or the remote haven’t worked. I actually didn’t try connecting via SSH, will try that next time.

The box should get air, but is not in the most ventilated spot. It seems odd that it would be an overheating problem, since the box worked just fine in that spot for three months. That of course doesn’t mean it isn’t, just odd.

Please take a photo so we can see how the Vero is positioned

The Vero sits behind the soundbar on the shelf. The soundbar itself doesn’t get hot while watching, so it shouldn’t push out a heatload on the Vero.

The space on the shelf is about 10cm tall.

Suggest you connect by ssh and monitor the temperature with the following command
watch -n 0.5 "echo -n 'temp: '; cat /sys/class/thermal/thermal_zone0/temp; echo -n 'cpu speed: '; cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq"

1 Like

Try moving it and see if it improves.

1 Like

Watched shows for an hour, enabled logging and rebooted. Let’s see if it turns off during the night so I could grab the logs.

What strikes me as strange if it indeed is a heat shutdown is that it worked just fine in the same location for 3 months. This started suddenly, and our indoor temps have been inside 2c range the whole time.

But let’s see what happens, if it shuts down, I’ll upload the logs and if not, will be happy but try to move it anyway after monitoring logs via SSH as suggested.

I’ve seen it somewhere, but can’t seem to find it: what are normal operational temps for the Vero4k and what’s the thermal shutdown threshold?

Thanks for all your help guys!

Vero 4K will shut down if the device reaches 120c.

Sam

1 Like

Started to tinker with this, because the HDR hotfix made colors in SDR shows look really red, but that’s another thing. Anyway, was trying to remove that stuff from rc.local and decided to run this as well.

The output was:

temp: 113000
- n cpu speed:
667000

So it seems to be quite near the thermal threshold. So maybe it is that…

113C is quite hot, so it does seem like this would be the issue.

1 Like

Well, Vero didn’t crash last night, last observed temp behind soundbar was 106-108c. Moved the box temporarily on top of the shelf, in the open. Now reading about 96c when not watching.

So seems to be an overheating case anyway, although it is strange that it suddenly started without the ambient temp rising. But thank you all for your help, now on to solving 4:4:4 and color issues in the correct thread! :slight_smile:

Edit: Also edited the thread title to correctly refer to the issue.

Thanks for this @fzinken! It help diagnose the problem in an easy way.

Any new addons or skin changes?

Also: how hot is it in Finland?

I did change to the Mimic skin before this started. I’m used to running kodi on Intel NUCs, so didn’t realize this could be an issue in the long run. Shutdowns didn’t start immediately, maybe a week later.

No new addons, infact pretty much the only one I use outside standard OSMC installation is PKC.

It’s been anything between 8-30c here for the past month. It stays 24-26c inside the flat, even on hot days.

Okay – we do have some temperature reductions coming soon in the next update; so this may also help.

Let’s keep an eye on things and let me know if any problems happen again.

Sam

1 Like

Good to know. Vero shut down last night even though it is now on top of the tv-stand in open air. I had just disabled debugging logs, so those are not available.

I asked for the modified temp logging script from the other thermal shutdown topic, let’s see if that tells us something.

Seems quite harsh, if the Mimic skin is causing this while idling without any animations happening.

If it’s Mimic, then we can fix it easily.
You could try switch to a lighter skin for a while to see if it helps, but I’d be surprised if you experience problems from this.

Sam