Very slow movies and tv's database browsing

Hi Guys,

Yesterday I encounter a problem with my Vero. I have Vero for some time and configuration is that it connects to my NAS, using mysql database. And yesterday after i clicked all movies Vero freezed completely (even logging stops) for few minutes and it looked like that:

I created log file and it’s available here Link

All other network connectivity works fine - I can connect to my NAS, play a file using tablet, transfer rates are fine etc.

I saw that yesterday was some update applied and maybe this was the issue. I tried yesterday to reboot Vero and shutdown today, but everything freezed both times and I had to take off plug for both cases. I don’t turn off Vero at all, so I don’t know if it happened yesterday or was before that.

I had some changes in my network configuration - I’ve got a new router, but it worked for few days fine and yesterday stopped.

I hope this could be solved really fast :smile:


Can you temporarily try the old router to see if things improve?


I could, but this would require a total fresh setup to be performed, as this router was reseted to clean.

I’ll do that this evening, but I don’t think it will solve the problem as new router worked for few days w/o any problems, before this problem occurred. And it happened after some updates I installed on Vero.
Is there in my logs anything pointing towards this slowness?


Ok, I’m officialy lost. I’ve switched to old router (which took me an hour, thanks IE and MS :wink: and it started to work perfectly fine. At the moment I have no idea, why my router is causing this kind of problems. I’ve created log file when I’m using old router, browsing my library, switching to new router and trying to browse.
Link to logs

Maybe, if you take a look it would tell you anything. I’m going to TP-LINK forum for any solution, but with limited hope for solution


I also have a TP-Link Router:

N600 Wireless Dual Band Gigabit ADSL2+ Modem Router
Model No. TD-W8980

As I’ve posted elsewhere, wireless performance with the Vero is poor compared with that of an RPi+ running OSMC. (The Pi is wired to an old Airport Express.)

I also have slow TV database browsing with the Vero. With the Pi, the list of TV shows appears almost instantly after clicking the TV icon. With the Vero, it takes five to ten seconds before the list of shows appears. It also takes much longer for a show to start up with the Vero than with the Pi.

I am running a shared MySQL database and shared media files, both hosted on a wired MacMini.

osmc@osmc:~$ paste-log /home/osmc/.kodi/temp/kodi.log

I found somehow solution, but it was a brutal one - I’ve installed Vero from scratch and it started working.

I heard there are some problems with DLNA on TP-Link router, but I couldn’t turn this off :frowning:
I hope you’ll find a better solution, than I

I did some comparisons between the Pi B+ and the Vero:

Time between clicking TV icon and display of the list of shows:

B+: 3 seconds
Vero: 17 seconds

Time between clicking on a series title and display of the list of episodes:

B+: instant
Vero: 7 seconds

Time between clicking on a video and the start of video playback:

B+: 3 seconds
Vero: 40 seconds

This is really not very useable.

Kodi Log:

What can I do to fix this?


Just to clarify

  • Both Pi B+ and Vero are connected via a Wired Ethernet connection?
  • The Vero is slower to browse shares on a Wired connection in comparison to Kodi?


Look here for a complete description of the setup and documentation of the performance issues:

To put it briefly:

The Vero is wireless. It is almost in line-of-sight with the router and less than three meters away.

The pi B+ is wired to an old Airport Express. It is about ten meters and two concrete walls away from the router.

When I had a Pi B and an Airport Express where the Vero is now, there were no throughput issues.