Very slow wireless on my Vero

I’ll check this out if I get some time to do some testing. If not, I’ll wait on the next release.

wireless is very slow, I can’t watch youtube, anyone knows fix it?

I’m seriously disappointed in the Vero, and I had such high hopes. If I can, I’m going to insist on a refund. The wifi adapter is a deal breaker. I don’t want to run cable from my office to the living room.

Had the same problem, ended up mounting an external antenna on the Vero.

Not without loosing your warranty.

I’m also having problems with poor wireless network performance.

I have two OSMC installations, one on a Pi B+ and one on the Vero.

I normally watch 480p videos, so network throughput is not much of an issue. But, today I was watching a 720p video (Media Info at the end of this post) and buffering on the Vero happened every few minutes. I watched the same video on the Pi with no buffering at all.

On the Vero I’m using the built-in WiFi adapter. The Vero is almost line-of-sight with my router.

The Pi is wired to an old Airport Express. There are two concrete walls between the Airport Express and the router.

Can anything be done to enable me to watch buffer-free 720p videos on my Vero?

Media Info:

General
Unique ID                                : 207860921814076730527614919210402789077 (0x9C608EAF13C4FB8283F63F53B4BB36D5)
Complete name                            : /Volumes/Media/TV/Manhattan/Manhattan.S01E01.Manhattan.720p.WEB-DL.AAC2.0.H.264-BS.mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 1.74 GiB
Duration                                 : 56mn 50s
Overall bit rate                         : 4 374 Kbps
Encoded date                             : UTC 2014-07-28 16:48:56
Writing application                      : mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
Writing library                          : libebml v1.3.0 + libmatroska v1.4.1
DURATION                                 : 00:56:50.464000000
NUMBER_OF_FRAMES                         : 106577
NUMBER_OF_BYTES                          : 163702272
_STATISTICS_WRITING_APP                  : mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
_STATISTICS_WRITING_DATE_UTC             : 2014-07-28 16:48:56
_STATISTICS_TAGS                         : BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L3.1
Format settings, CABAC                   : No
Format settings, ReFrames                : 2 frames
Format settings, GOP                     : N=1
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 56mn 50s
Bit rate                                 : 3 903 Kbps
Width                                    : 1 280 pixels
Height                                   : 718 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 23.976 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.177
Stream size                              : 1.55 GiB (89%)
Language                                 : English
Color primaries                          : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics                 : BT.709-5, BT.1361
Matrix coefficients                      : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio
ID                                       : 2
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Mode extension                           : CM (complete main)
Codec ID                                 : A_AC3
Duration                                 : 56mn 50s
Bit rate mode                            : Constant
Bit rate                                 : 384 Kbps
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 KHz
Bit depth                                : 16 bits
Compression mode                         : Lossy
Stream size                              : 156 MiB (9%)
Language                                 : English

Text
ID                                       : 3
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Title                                    : CC
Language                                 : English

Just to follow up on the above. I tried to continue to watch this video on the Vero, but the buffering got so bad I gave up and finished on the Pi. No buffering at all.

As an experiment, I used It’s Playing Pro on an iPad to stream the same video from the same source. I put the iPad right in the same spot where the Vero sits. No buffering at all.

In the networking section of My OSMC, the WiFi signal strength is shown as two bars.

Apple’s Airport Utility reports that the WiFi connection with the Airport Express is “Excellent”, 115Mb/s, RSSI -56dBm.

Hi.
I know that the antenna is mounted on the top inside of the Vero, and most of the inside is covered with aluminium, which will weakening the signal.
So as a test, is it possible that you try to lay down the Vero, so that the top of the Vero points in the direction of the router.
I know it’s not a solution (if it works) but It would be very interesting to see if the reception gets better this way.

1 Like

Yeah, that seems to have helped. The signal strength still shows two bars, but I could watch without buffering. I could also watch at 2X and 4X, but it balked at 8X.

Oddly, when I went to look at the network configuration it showed:

“Status: No wireless connection”

I had to disable and enable the adapter in order to look at the configuration (IP address, etc.).

Seems like a poor design if you have to set a device on its side in order to get WiFi to work.

Yes you are right, not the best design, but even worse, it is not something that can be fixed with a software update :worried:

1 Like

Ah, well. Thanks for the suggestion. Given the size and shape of the box, I don’t think anyone but me will ever realize it’s sitting on its side…

I decided to install iperf on the Vero and run some brief tests. I didn’t tweak any parameters. The MacMini hosting the media files is the client, the Vero the server. The first and last results are with the Vero sitting upright. The middle two results are with the Vero on its side:

Client connecting to 192.168.0.180, TCP port 5001
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.75 port 62499 connected with 192.168.0.180 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.1 sec  11.9 MBytes  9.90 Mbits/sec
Bleach:~ mnewman$ iperf -c 192.168.0.180
------------------------------------------------------------
Client connecting to 192.168.0.180, TCP port 5001
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.75 port 62509 connected with 192.168.0.180 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec  21.8 MBytes  18.2 Mbits/sec
Bleach:~ mnewman$ iperf -c 192.168.0.180
------------------------------------------------------------
Client connecting to 192.168.0.180, TCP port 5001
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.75 port 62513 connected with 192.168.0.180 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec  17.4 MBytes  14.5 Mbits/sec
Bleach:~ mnewman$ iperf -c 192.168.0.180
------------------------------------------------------------
Client connecting to 192.168.0.180, TCP port 5001
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.75 port 62560 connected with 192.168.0.180 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-17.4 sec  12.0 MBytes  5.79 Mbits/sec

Doesn’t that seem very, very slow?

I was going to install iperf on the Pi, but I can’t figure out how to do that:

osmc@osmc:~$ sudo apt-get install iperf
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package iperf

and

osmc@osmc:/etc/apt$ cat sources.list
deb http://mirrordirector.raspbian.org/raspbian jessie main contrib non-free
deb http://apt.osmc.tv jessie main

I’m not smart enough to know what’s wrong….

You need to run sudo apt-get update first. Iperf is definitely available.

Yeah, thanks. Stupid me….

Here’s iperf results with the Pi/Airport Express:

Bleach:~ mnewman$ iperf -c 192.168.0.151
------------------------------------------------------------
Client connecting to 192.168.0.151, TCP port 5001
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.75 port 49825 connected with 192.168.0.151 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec  27.1 MBytes  22.6 Mbits/sec

Just for comparison purposes:

The Vero is about three meters (ten feet) from the router and is, pretty-much, line of sight. The only barrier is the wood sidewall of the entertainment cabinet.

The Pi/Express is about 10 meters (33 feet) from the router with two intervening concrete walls.

I remembered that I have iperf on my iPad3, so I set it up as a server and placed it right over the Vero.

Here are the results:

------------------------------------------------------------
Client connecting to 192.168.0.140, TCP port 5001
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.75 port 57086 connected with 192.168.0.140 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec  38.9 MBytes  32.6 Mbits/sec
Bleach-2:~ mnewman$ iperf -c 192.168.0.140
------------------------------------------------------------
Client connecting to 192.168.0.140, TCP port 5001
TCP window size:  129 KByte (default)
------------------------------------------------------------
[  4] local 192.168.0.75 port 57117 connected with 192.168.0.140 port 5001
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-10.0 sec  43.9 MBytes  36.7 Mbits/sec

As one can see, the throughput is about double what the Vero gets when on its side, and about four times what the Vero gets when upright.

I stuck the iPad next to the Pi and still got 26.3 Mbits/sec.

Any fix in the works or are we just stuck with this?

So, no help on this at all?

Vero is a commercial product for which we paid a premium in the expectation that we would be getting a box with superior design and quality implementation. The expectation of decent support goes right along with that.

I don’t feel very good about having paid nearly two hundred bucks for a video player that only works properly when lying on its side. It especially hurts that a $35 RPi B+ and an ancient Airport Express run circles around it when it comes to WiFi performance.

I guess you can continue to ignore me, but do you really want unhappy paying customer?

No one is ignoring you, we are watching the thread. While the attenuation is not as high as it could be, I still think there are some driver issues to be worked on as well. If you wget a speed file you will notice the fluctuations – resolving this could be promising in that it will give more reliable results, but it won’t work miracles.

Sam

1 Like

Thanks for your reply. Sometimes just a few words work wonders…

This is what I have to do to get my Vero to play a 480p video without buffering.

My Pi B+ wired to an Airport Extreme can receive wireless signals through two concrete walls and still stream a 720p video without buffering.

This is not right and needs to be fixed.

It’s a hw design bug … not really much can be done about it. Buy an external wireless stick, details were shown by @thansen_dk who deconstructed it …

Btw. newer cuboxes don’t ship wireless internal anymore … cause it seems they learned from that … only the old models have wireless integrated.