Very slow wireless on my Vero

The wireless on my Vero is very slow, and it’s impossible to play stuff from my NAS.
When the Vero is in the same room, and less than 1 meter away from my router (Asus RT-N66U), my routers traffic monitor tells me that the speed is a maximum of 2 MB/s (3/4 signal bars).
When the Vero is in the room next to it, the speed is 200 KB/s (2/4 signal bars).
My Pi B (with a mini wifi dongle) standing next to it in the other room is getting peaks of 1 MB/s or higher and 4/4 signal bars.
On a wired connection the Vero is playing fine at high speeds, but I can’t have a wired connection to the other room.
I’ve tried with RC1, RC2 and the newest updates on RC2.

Any ideas on what’s wrong? Do I need some wireless fix?
Would love to get this fixed, so that I could start using the Vero as a media player.

A wireless router signal is attenuated, when close other wireless routers are transmitting on the same channel. (neighbors?)

You might try to select a different channel. You can set this in the configuration of your router,then choose that channel that is used least

Already got the least used channel.
Every device got great signal, except for the Vero.

It seams to me an issue with the integrated antenna then.I do not know this, but is there a possibility to connect an external antenna to the Vero ??

Not that I know of.

Is there any way that I can use the mini wifi dongle on my Vero? To check if that’s increasing the wireless performance?

I am hoping that there’s a fix for this. My Vero wifi speed is extremely slow. Speeds on all other devices are great.

I’m starting to think that the built in wifi adapter is complete junk. It drops internet, and has virtually no signal strength.

Has anyone successfully used an external dongle?

Did you tried to attach it to the Vero?

(I dont own a Vero, so I dont know if it has a) USB ports and b) additional drivers. I would simply try…)

Ofc I have tried to attach it to the Vero.
The problem is that there isn’t a menu to choose between the internal wireless on the Vero and the usb dongle in OSMC.
In OSMC on my Pi it’s working fine, but the drivers might not exist on the Vero version of OSMC.

You could try to deactivate the internal wifi via ssh (on my Pi I had to install ifupdown first):

ifdown wlan0

Maybe you need to change ‘wlan0’ to what its named on the Vero.

Then you should be able to find out whether there are drivers for different wifi dongles (one might think that it would be to complicated to exclude the wifi drivers in the Vero build but include them in the Pi build).

The current release version of the OSMC networking GUI doesn’t recognise multiple wireless adaptors but we added support for this a while ago in the development builds so the next major release should support selecting between multiple adaptors.

In the mean time it is possible to connect on a secondary wireless adaptor (assuming that there is a suitable driver in the kernel for the adaptor) by using connmanctl from the command line.

Is this an issue with the OSMC software or the wifi adapter on the Vero?

I’ll check this out if I get some time to do some testing. If not, I’ll wait on the next release.

wireless is very slow, I can’t watch youtube, anyone knows fix it?

I’m seriously disappointed in the Vero, and I had such high hopes. If I can, I’m going to insist on a refund. The wifi adapter is a deal breaker. I don’t want to run cable from my office to the living room.

Had the same problem, ended up mounting an external antenna on the Vero.

Not without loosing your warranty.

I’m also having problems with poor wireless network performance.

I have two OSMC installations, one on a Pi B+ and one on the Vero.

I normally watch 480p videos, so network throughput is not much of an issue. But, today I was watching a 720p video (Media Info at the end of this post) and buffering on the Vero happened every few minutes. I watched the same video on the Pi with no buffering at all.

On the Vero I’m using the built-in WiFi adapter. The Vero is almost line-of-sight with my router.

The Pi is wired to an old Airport Express. There are two concrete walls between the Airport Express and the router.

Can anything be done to enable me to watch buffer-free 720p videos on my Vero?

Media Info:

Unique ID                                : 207860921814076730527614919210402789077 (0x9C608EAF13C4FB8283F63F53B4BB36D5)
Complete name                            : /Volumes/Media/TV/Manhattan/Manhattan.S01E01.Manhattan.720p.WEB-DL.AAC2.0.H.264-BS.mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 1.74 GiB
Duration                                 : 56mn 50s
Overall bit rate                         : 4 374 Kbps
Encoded date                             : UTC 2014-07-28 16:48:56
Writing application                      : mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
Writing library                          : libebml v1.3.0 + libmatroska v1.4.1
DURATION                                 : 00:56:50.464000000
NUMBER_OF_FRAMES                         : 106577
NUMBER_OF_BYTES                          : 163702272
_STATISTICS_WRITING_APP                  : mkvmerge v7.1.0 ('Good Love') 64bit built on Jul 27 2014 13:06:55
_STATISTICS_WRITING_DATE_UTC             : 2014-07-28 16:48:56

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L3.1
Format settings, CABAC                   : No
Format settings, ReFrames                : 2 frames
Format settings, GOP                     : N=1
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 56mn 50s
Bit rate                                 : 3 903 Kbps
Width                                    : 1 280 pixels
Height                                   : 718 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 23.976 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.177
Stream size                              : 1.55 GiB (89%)
Language                                 : English
Color primaries                          : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics                 : BT.709-5, BT.1361
Matrix coefficients                      : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

ID                                       : 2
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Mode extension                           : CM (complete main)
Codec ID                                 : A_AC3
Duration                                 : 56mn 50s
Bit rate mode                            : Constant
Bit rate                                 : 384 Kbps
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 KHz
Bit depth                                : 16 bits
Compression mode                         : Lossy
Stream size                              : 156 MiB (9%)
Language                                 : English

ID                                       : 3
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Title                                    : CC
Language                                 : English

Just to follow up on the above. I tried to continue to watch this video on the Vero, but the buffering got so bad I gave up and finished on the Pi. No buffering at all.

As an experiment, I used It’s Playing Pro on an iPad to stream the same video from the same source. I put the iPad right in the same spot where the Vero sits. No buffering at all.

In the networking section of My OSMC, the WiFi signal strength is shown as two bars.

Apple’s Airport Utility reports that the WiFi connection with the Airport Express is “Excellent”, 115Mb/s, RSSI -56dBm.