Video files sometimes playable, sometimes not

I have a strange problem that sometimes TV episodes are played normally and sometimes the player overlay is displayed but playback is stopped at 0:00. I can seek and then it would say ‘buffering’ but nothing happens. Finally I can press stop again and maybe try another file.
Log of this recently happening (Supernatural, last log entries)

Sometimes, OSMC even freezes during this and I can only connect via SSH and send a reboot command (sudo reboot). However, there are some strange messages in the log and instead of rebooting, the system halts at ‘Reached target Shutdown’. The only option left then is to cut power and reconnect again.

Do you have a USB drive attached?
Are you running many services on the device?

I’ve had exactly the same problem the last couple of weeks (on two different Vero 4K’s). Every 3+ video’s I play have this problem (timer appears but stuck at 00:00. If I press STOP and wait a while I can get back to the menu. Select Reboot from menu. Similar pqd errors. Works fine after the reboot. I’ve not had time to capture logs or anything yet, I was too busy ruling out my NFS server and Network as I thought it might be related to them. Good to see I might not be the only one with this :slight_smile: I’m running Kodi and TVHeadend.

No USB drive. I have about the same configuration and (I guess even fewer, since I completely reinstalled) services running, as on my previous Vero (1st gen) device. Besides OSMC it’s running:

  • Sonarr
  • CouchPotato

All media is stored on a NAS, which is accessed via NFS and the NFS share is mounted manually at boot (via /etc/fstab). The device is connected via LAN to a router and the NAS is behind a Wireless Bridge.

It might have started with the March update but I’m not completely sure.

Did one of these get an update recently?
@DBMandrake also has some odd lockups and I think he is running these services.

If you can reproduce this easily enough, is there an opportunity to disable these services for a while to see if there is improvement?


I have to check if there were updates but I would guess so. Disabling them is possible - will try that for the next couple of days.

Mmmhh, I’m not sure but the logs shows you tried to start playback of

OnPlayMedia /home/osmc/Serien/Supernatural/Supernatural - S13E11 - Breakdown HDTV-720p.mkv

So, means there are sources added to the mediacenter named “Serien” and “Filme” but they are loctaed in the root file system … at least I do not see a mointpoint to /home/osmc/Serien and /home/osmc/Filme at a glance?

NFS is mounted at boot to a local dir (you can see unmounting of /i-data/… in the screenshot) and the mounted dir has a symbol link in the home folder.

Mount options:

…… /i-data/e2115f28/nfs/media nfs noatime,rsize=32768,wsize=32768,nolock 0$

Had these options since I was on a slow network but never changed them since then.


... nfs  defaults,x-systemd.automount,noauto   0   0

a try in your /etc/fstab.

Thanks, but changing the NFS settings didn‘t help. Will try disabling the two programs now.

Also, just had the problem occuring during watching an episode. Playing after fresh reboot worked at first but when I started seeking forward, it didn‘t load/buffer again.

Disabling Sonarr and Couchpotato didn‘t help either. This evening I had to reboot, watch an episode and then it already stopped working until another reboot three times.

Device or resource busy on /dev/video10 is strange.

Can you try restarting just Kodi and seeing if this helps next time?

Can you also run ls -l to check permissions on that file?


We found some overheating issues with some services.
We will have a solution shortly and I will ping you then



Sorry, I haven‘t had time to try your previous suggestions. But this now sounds promising - thanks!

I think I’ve managed to resolve my issue (which looked/sounded identical). I believe it was a Spotify plugin I had installed. @PreacherAT I notice in the logs you are also using the same Spotify plugin. You may want to try temporarily disabling it and seeing if it helps?

1 Like

Thanks for the tip! Just disabled it — let‘s see if it helped.
Can you tell me if it was „Spotify“ or „SpotiMC“ on your system?

I had/disabled: (marcelvelt v1.1.56)

No issues since yesterday — this seems to have done the trick. Thank you very much! :grinning: