Video hangs, audio continue

Since yesterday’s update it seems that playing a file, it random hangs.

@19:55 and 19:56 it sudden stops and then moves

Earlier it hangs for longer time, but that wasn’t captured.

Is this known?



Format : Matroska
Format version : Version 2
File size : 7.92 GiB
Duration : 1 h 51 min
Overall bit rate : 10.1 Mb/s
Encoded date : UTC 2014-10-18 09:08:00
Writing application : mkvmerge v3.2.0 (‘Beginnings’) built on Feb 12 2010 16:46:17
Writing library : libebml v0.7.9 + libmatroska v0.8.1

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings : CABAC / 5 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 5 frames
Duration : 1 h 51 min
Bit rate : 8 654 kb/s
Width : 1 920 pixels
Height : 802 pixels
Display aspect ratio : 2.40:1
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.234
Stream size : 6.58 GiB (83%)
Writing library : x264 core 142 r2479 dd79a61
Encoding settings : cabac=1 / ref=5 / deblock=1:-2:-1 / analyse=0x3:0x113 / me=umh / subme=11 / psy=1 / psy_rd=1.00:0.05 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-3 / threads=12 / lookahead_threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=13 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=0 / bitrate=8654 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=40000 / vbv_bufsize=40000 / nal_hrd=none / filler=0 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:0.60 / zones=152606,159404,q=31,deblock=1:2
Default : Yes
Forced : No

ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Codec ID : A_DTS
Duration : 1 h 51 min
Bit rate mode : Constant
Bit rate : 1 509 kb/s
Channel(s) : 6 channels
Channel layout : C L R Ls Rs LFE
Sampling rate : 48.0 kHz
Frame rate : 93.750 FPS (512 SPF)
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 1.18 GiB (15%)
Language : English
Default : Yes
Forced : No

ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Language : Dutch
Default : Yes
Forced : No

There wasn’t an update released yesterday.

Have you tried a cold boot?
Does it happen with all files?

Hi Sam,

Strange as i run the updater this afternoon and it found something to update, i had to choose install it. It seems the buster repository was updated yesterday in the early morning. which needed for a restart after installation and i performed a reboot. I already did a warm and cold reboot, both stayed the same with this movie. I’ll watch some another movies to see if it repeated.

I had the same update appear, reboot the machine into update mode, and then reboot again into osmc… seeing the same random video issues (hanging picture with sound continuing, occasional green frames; reboot fixes it until it doesn’t).

1 Like

Need to see some logs.
There were some reports of issues playing HEVC issues but I pushed a solution and users reported success.

Try checking to see if your device has further updates to install.

1 Like

No osmc updates are shown as available… this 100% started happening after the ‘phantom update’ that got triggered Sunday night.

The playback seemed to have two different ‘states’… it would glitch out / not decode blocks of the video frame and present green artifacts randomly; those showed as spurts in the debug log (I was tailing). When the video ultimately froze, nothing showed up in the log for a while, and then the ‘stillframe detected’ showed up. I eventually stopped playback when it became apparent there’d be no recovery.

1 Like

@sam_nazarko refers to updates via the testing repository


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

I’d also recommend you deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Awesome! I’ve updated with the devel channel and I’m re-playing the same movie; So far nary an issue to be found. Thanks for the quick response (although now I’m wishing I hadn’t chosen such a high-concept movie to test against…)!

I also had an OSMC update available yesterday for my Vero 4k.

Arg guess I spoke too soon… it made it much further but I eventually got a frozen screen :confused:

I’ve updated as well, so far it seems to be better at the test-version.

Actually the fix was pushed to release and not the testing repository. There’s nothing new in the testing repository regarding playback.

I guess that the fix then caused the hanging video. Something else might be impacted then…

Start-Date: 2021-12-14 07:43:08
Commandline: /usr/bin/apt-get-real -o APT::Status-Fd=4 -o APT::Keep-Fds::=5 -o APT::Keep-Fds::=6 -f -y dist-upgrade
Upgrade: python-samba:armhf (2:4.9.5+dfsg-5+deb10u1, 2:4.9.5+dfsg-5+deb10u2), libwbclient0:armhf (2:4.9.5+dfsg-5+deb10u1, 2:4.9.5+dfsg-5+deb10u2), samba-libs:armhf (2:4.9.5+dfsg-5+deb10u1, 2:4.9.5+dfsg-5+deb10u2), vero3-userland-osmc:armhf (1.9.7, 1.9.9), samba-common:armhf (2:4.9.5+dfsg-5+deb10u1, 2:4.9.5+dfsg-5+deb10u2), libsmbclient:armhf (2:4.9.5+dfsg-5+deb10u1, 2:4.9.5+dfsg-5+deb10u2), samba-common-bin:armhf (2:4.9.5+dfsg-5+deb10u1, 2:4.9.5+dfsg-5+deb10u2), libnss3:armhf (2:3.42.1-1+deb10u3, 2:3.42.1-1+deb10u4)
End-Date: 2021-12-14 07:43:18

This movie was not a HEVC file and before I yesterday performed the release update (previous update was the 2021.11.2 update end of November), i didn’t saw those hanging parts in movies.

Hope this will give any idea where to look.

Now i’m on the test-release version, which also updated many parts…

I have the exact same problem, after a fresh install of 2021.11-2 on a Vero 4K+

After the install there is actually a update available on the release channel, if you use the gui to search for updates.

If you use command line, here is what you get.

osmc@osmc:~$ apt list --upgradable
Listing... Done
libc-bin/unknown 2.28-110.1 armhf [upgradable from: 2.28-10]
libc6/unknown 2.28-110.1 armhf [upgradable from: 2.28-10]
libnss3/oldstable 2:3.42.1-1+deb10u4 armhf [upgradable from: 2:3.42.1-1+deb10u3]
libsmbclient/oldstable 2:4.9.5+dfsg-5+deb10u2 armhf [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
libwbclient0/oldstable 2:4.9.5+dfsg-5+deb10u2 armhf [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
python-samba/oldstable 2:4.9.5+dfsg-5+deb10u2 armhf [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
samba-common-bin/oldstable 2:4.9.5+dfsg-5+deb10u2 armhf [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
samba-common/oldstable,oldstable 2:4.9.5+dfsg-5+deb10u2 all [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
samba-libs/oldstable 2:4.9.5+dfsg-5+deb10u2 armhf [upgradable from: 2:4.9.5+dfsg-5+deb10u1]
tzdata/oldstable-updates,oldstable-updates 2021a-0+deb10u3 all [upgradable from: 2021a-0+deb10u2]
vero3-userland-osmc/unknown 1.9.9 armhf [upgradable from: 1.9.7]

So vero3-userland-osmc is upgradable, I guess it is this this Github update.

And after the update, there are some file that wont play correct.
The demo file can be downloaded from here

Debug log can be found here

Media info for the file.

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L5.1
Format settings                          : CABAC / 3 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 3 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 2 min 12 s
Source duration                          : 2 min 12 s
Bit rate mode                            : Constant
Bit rate                                 : 116 Mb/s
Nominal bit rate                         : 125 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Variable
Frame rate                               : 29.970 (30000/1001) FPS
Minimum frame rate                       : 29.970 FPS
Maximum frame rate                       : 30.000 FPS
Standard                                 : NTSC
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.467
Stream size                              : 1.80 GiB (100%)
Source stream size                       : 1.80 GiB (100%)
Language                                 : English
Encoded date                             : UTC 2012-12-23 11:49:33
Tagged date                              : UTC 2012-12-23 11:49:33
Color range                              : Limited
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
mdhd_Duration                            : 132966
Codec configuration box                  : avcC

ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 2 min 12 s
Source duration                          : 2 min 13 s
Bit rate mode                            : Variable
Bit rate                                 : 125 kb/s
Maximum bit rate                         : 211 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 1.99 MiB (0%)
Source stream size                       : 1.99 MiB (0%)
Language                                 : English
Encoded date                             : UTC 2012-12-23 11:49:33
Tagged date                              : UTC 2012-12-23 11:49:33
mdhd_Duration                            : 133013

It looks like this some times, other times it plays with black screen, or other visual errors, but the sound is always ok.

Thanks for the sample. I’ll check that later.


I had a similar picture, but blue instead of green, with a bar at the top, as it would shown the sad-face, but now without the sad-face. Unfortunately this was before i could grab it into the logging.

1 Like

The first picture was just one of many different errors, here is another :slight_smile:

I have three Vero units, of them one I have not allowed the pushed update to install. On the non updated unit, I can confirm playback is normal on my test movie, whereas on the two other (updated) units it has the described issues.

1 Like

playing your sample give the same output here. First it starts but doesn’t display, then is switches to black, picture comes up and stuttering a lot and then it got flashing green.

I saw the update and am also having random playback issues, multiple skins.
Logs reported on my ‘scrolling through movies’ thread.