Video hangs (freezes) often on Vero 4k after upgrade to Kodi Matrix

Hello,
after a long time I’ve upgraded my Vero 4k from version 2020.11 to latest version. After upgrade the video started to hang each several minutes - and it doesn’t matter if the video is played from tvheadend, internet or samba. Each time the video hangs, the log contains following error messages:

2022-09-02 23:26:49.357 T:2721 ERROR : GetString: error reading /sys/class/amhdmitx/amhdmitx0/aspect
2022-09-02 23:26:49.361 T:3127 ERROR : GetString: error reading /sys/module/am_vecm/parameters/cur_csc_type
2022-09-02 23:26:49.365 T:2721 ERROR : GetString: error reading /sys/class/amhdmitx/amhdmitx0/aspect
2022-09-02 23:26:58.219 T:3126 INFO : Skipped 21 duplicate messages…
2022-09-02 23:26:58.219 T:3126 INFO : CVideoPlayerAudio::Process - stream stalled pts:461.305 clock:461.399
2022-09-02 23:26:59.574 T:2721 ERROR : GetString: error reading /sys/class/amhdmitx/amhdmitx0/aspect
2022-09-02 23:27:09.737 T:2721 ERROR : Skipped 19 duplicate messages…
2022-09-02 23:27:09.736 T:2721 ERROR : GetString: error reading /sys/class/amhdmitx/amhdmitx0/aspect

This problem never appeared before upgrade the Vero.
Please, could you help me? My Vero is now almost unusable…

Jirka

Can you please upload full logs?

Thanks

Sam

Hello, there is a full log with debug enabled:

https://paste.osmc.tv/tulixicafo.xml

What I did:

  • disabled some add-ons (some of them have flooded the debug log a lot)
  • fresh reboot
  • started to playback a locally stored file (h264 video)
  • after several minutes the video stopped playing, after a while the sceen became full green and didn’t recovered until reboot (service mediacenter stop / start didnt help, the screen remained green)
  • the problem starts at time 06:32:42

Thank you

These are only Kodi Logs. Please provide Full Logs via MyOSMC or grab-logs -A

Hello, now I’ve been waiting a little bit longer but error appeared again - now while playing stream from the internet.
Output of grab-logs -A:

https://paste.osmc.tv/efanujelid

Hello, could you, please, provide any clue how to resolve the problem described above? The problem still occurs, randomly, several times a day. I’ve also replaced the hdmi cable and tried to use different hdmi input of my TV to ensure that there is not problem in connection and it didn’t help.
Thank you very much
Jirka

Thanks for your patience.

If you disable TVHeadend client, does the issue still occur?

Sam

Hello, you have led me to possible clue. I did some experiments regarding tvheadend and I discovered that there is something wrong with the SD card, that is used by tvheadend for timeshift function (timeshift has crashed randomly). The filesystem behaviour was strange - for example the “df” command was not working etc. When I removed the SD card, reformatted it in another machine and put it back, the problem seems to be away - since the card format the video playback seems to be working properly. I’ll be observing the behaviour to prove if it is really OK and if the root cause of the issue was in the damaged filesystem on SD card. But I still don’t understand the relation between video playback (from various resources not related to the mounted SD card) and the corrupted fs on SD card… Thank you, I’ll write if I find anything else or problem appears again.

There could be a task holding up playback performance or leading to general system instability.

Hello, after several days without playback problems, the issue is back :frowning: . I’ve tried to upgrade to September upgrade and I removed the SD card (to be sure that the SD card is not the problem) - and the video playback freezes after several minutes. Nothing else changed, I can’t explain, why the issue was gone for several days and now it is back.

Can we see some new logs?

Issue occured - while playing video from local network.
Logs: https://paste.osmc.tv/fezakagabe

The video freezes at the same time when the error ERROR : GetString: error reading /sys/class/amhdmitx/amhdmitx0/aspect in log appears.

Hi,

I can see an HEVC decode error.

We have some HEVC improvements in our staging repository, and this will be released as an update shortly.

To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Thanks

Sam