Video Stuck/Slowmotion since last update (MAY)

Since the last update (May) i have seen a view videos are lagging

(audio is running correctly and in normal speed, but the video is like slow motion)

most videos i could see this are WMV/WMV HD codec

is there a solution? Maybe it is the CPU because i have never seen the cpu at 1600MHz or even 1000MHz The CPU is most the time at 768MHz even if such a movie is running.

Any help for this?

UPDATE:

i tried these command to see the cpu frequence in realtime

sudo watch -n 1 cat /sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq

and i really cant get over 768MHz even if i scroll through the libary or if a movie is running.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Ok lets try again

Since the May update some videos run in slowmotion (only video the audio is running correctly)

Seems to be videos with WMV WMV HD codec

and 2nd i have never seen my cpu more than 768.

this is my log:

http://paste.osmc.io/edogivaked.vhdl

Hope this will help now.

Thanks

We will only increase the CPU frequency if there is a need for it. If the CPU is running at 768Mhz, then it’s not being used aggressively enough to warrant increasing the speed. This is because video playback is usually a VPU-bound rather than CPU (ARM) bound task.

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC output

I already postet my log, don’t know what to post more. If i enable debug log i can see that my frames in such video files fall down to 10 - 16 fps. maybe this is the problem for the slowmotion effect.

We need the MediaInfo

The frame rate from the overlay isn’t accurate, it is showing the refresh rate of the overlay, not the video

Videofile: WMVHD, 1080p, DTS-HD-MA, Filetype MKV

Hope this will help.

Anything new on my problem?

Screenshot you provided is not equivalent to the Mediainfo output that was requested.

Could u give me a answer how to do and what exactly u need? I am a user, not a developer or a programmer, so please give a clear answer and how to do it

It’s well documented in the link that both @sam_nazarko and I provided.

http://paste.osmc.io/iburemeyol.coffee

Same problem here as well. Slow motion on quite a few files.

Debug output here:

http://paste.osmc.io/mizururotu.tex

And to clarify: this video played OK before the update?

yes. worked well before the may update.

Thanks for letting me know this is a regression. I have an idea what may be causing this issue and will work on improving this.

Sam

Any update on this please?
I tried a few other low res videos, and similar problems :frowning:
A bit frustrated with the price I paid for the vero2!

I will send you a test build today if you are willing to try it. This will only fix the issue if it was definitely not problematic before the May update

Best,

Sam

I just reconnected my Pi2, and it works perfectly both pre and post may install, with all “problematic” videos.

So its definitely the vero2 build :frowning:

On the vero2, pressing O on a keyboard during playback shows a lot of dropped frames on “problematic” videos. the Pi doesn’t.