Video stutter / Caching - only on certain files

I have this issue which is driving me mad. I have a load of home videos taken on Iphone - copied to NAS then accessed from OSMC via smb share.

Certain videos will always stutter / cache where as others run fine even though they are identical and stored in the same location.

I’ve tried all the settings i can think of and can’t figure out what’s different. My very amateur look at the logs show that the videos with issues show: CVideoPlayerAudio::Process - stream stalled

Attached link to logs -

20160814_145328000_iOS.MOV is a video with issues.
20160815_111317000_iOS.MOV is a video from my perspective identical which plays fine.

Any help to resolve and I’d be eternally grateful!


Have you tried playing these videos with issue, locally; either from usb or the sdcard?

If they playback correctly, you should consider:

I would look at modifying the video cache.

I would even consider using nfs shares instead as smb, as this will provide better throughput.

I would also consider fstab mounts, as these also provide better throughput than the kodi software mounts.

Thanks Tom.

Thanks for taking the time to respond. It played fine from a USB so must be something to do with the network. I tried playing with the cache including recommended settings you’d posted Here, however only made it worse and caused issues with the videos that were previously playing OK.

I’ve read a ton of articles about nfs & fstab but completely out of my depth with no Linux experience so fear I am doomed for failure.


You try an nfs share, if your nas provides this? Then you can you add the share via browse and network file system (nfs). This should provided better throughput than non fstab mounted samba shares.

Failing that, I think the following should get the share mounted via fstab; more details about your nas would help.

You will need access to the command-line

sudo mkdir /mnt/video

sudo nano /etc/fstab

Add this line at the bottom, update your nas.ip and name of share.

//nas.ip./nameofshare /mnt/video/ cifs noauto,systemd.automount,ro,uid=1000,gid=1000,iocharset=utf8 0 0

If you are using user and password you will need to add to this entry, searching the forums will help with this.

Now reboot osmc. Now if you try add a new source and browse to root file sytem, mnt and video, and you can see your shares; then it has mounted correctly.

Thanks Tom.

Using nas4free I made nfs share and connected to it via kodi gui however still have same issue. It means I know I’ve created the nfs share ok though but probably need to try mounting in fstab.

I might be talking rubbish but looks like the instructions you gave are using cifs- now I know I can create nfs share OK from NAD is there a better way I should mount using nfs?


The instructions provided were for cif/samba, in case you wished to stay using samba shares.

fstab tab entry for nfs:

ip:/mnt/nameofshare /mnt/nameofshare nfs x-systemd.automount,noauto,ro

Thanks Tom.

Just had the chance to try this and looking like it’s worked! - Mounted NFS via fstab.

Thought it’d all broken when trying the same for other shares however that seems to be a Nas4Free bug that I found a work around for.

Really appreciate the help!

1 Like