Videos drop sound or go to black screen (OMX/MMAL accel issue)

Working fine last night and just received a second or third update today for the July Isengard update - most video files will now not play…

Need to set back to OMXPlayer and MMAL to off. Default settings no longer work on Pi2.

Was working fine yesterday on the previous update with default settings.

Something to do with the acceleration…

Big step backwards from last two Kodi 15.0 updates.

Something for @popcornmix

There were no changes to the behaviour of MMAL with any of these updates – the code was frozen.

A debug log should help here

Not sure what happened but something did @sam_nazarko

I Reset acceleration to default settings:
OMX disabled
MMAL enabled

I found that in Video -> Playback I had to disable Sync playback to display and the AV sync method set to Resample audio.

The videos affected will now only play with Sync playback to display disabled when in the past this has always been on.

There is something not right. Was working fine last night.

Can’t upload… telling me that the document exceeds the maximum length.

Can you try and replicate the problem with a smaller log file? A reboot will help with this

Sam

Ok, best I can do is xbmc.log @sam_nazarko :

Pi2 default settings no longer work for video acceleration.

File NOT working: http://xbmclogs.com/ppgi2x4ui
OMX Player DISABLED
MMAL PLayer ENABLED
Sync playback to display ENABLED

File working: http://xbmclogs.com/ptfp2v7bi
OMX PLayer DISABLED
MMAL Player ENABLED
Sync Playback to display DISABLED

In video settings I have always had “Sync playback to display” enabled

Here is the video file: Copy.com

Could it be CPU issue - going over 100% at commencement of play? I’m running normal overclock.

Also, when you go back and re enable OMX player and disable MMAL player and play the file again there is no sound. Need to reboot to get the sound back.

EDIT: See post below.

Now whatever I do to reset, the files that had issues have lost all sound. Even setting back to OMX Player alone those files have no sound at all.

This is extremely frustrating! Something has gone very wrong somewhere with the updates.

There seems to be a bug in the acceleration settings as it doesn’t seem to retain the settings set. I’m turning OMX Player on and off and the settings do not change.

EDIT: NO BUG. Audio output -> “Support 8 channel DTS HD audio decoding” was selected on which was causing the loss of audio. GUI settings are working fine and as they should.

No sound on the DTS files. Showing on screen as 0.0 whilst palying. If I select MMAL it has sound and shows as 5.1 whilst playing.

What is going on…? This all worked yesterday and an update today borked it…

Hold on, before you go panicking too much, are you sure you don’t have a corrupt guisettings.xml ?

We’d expect to see loads of reports of this sort of problem if it was wide spread but so far nothing much.

Try renaming your guisettings.xml file while kodi is stopped, eg via SSH:

sudo systemctl stop mediacenter
mv .kodi/userdata/guisettings.xml .kodi/userdata/guisettings.bak
sudo systemctl start mediacenter

You’ll have to reconfigure your settings under Settings of course. (But not videos/libraries)

Also post your advancedsettings.xml for us to see in case you have something in there that could be causing it.

Ok, sound is back. Not sure why this made no difference before but Support 8 channel DTS HD audio decoding was selected on.

So, what did you change to get sound working again ? Did you disable 8 channel DTS HD decoding ?

GUI settings are working I was mistaken - it was the 8 channel DTS selection.

Back to original issue…hardware acceleration issue. There seems to be an issue with MMAL enabled and having “Sync playback to display” enabled in unison. Might be something for @popcornmix to have a look at.

Pi2 default video settings do not work with the above file when “Sync playback to display” is selected. Seems to affect all 720p and 1080p DTS .mkv files I have.

Sorry but I can’t reproduce this problem.

I just deleted my guisettings.xml to go back to default settings, downloaded and played your file without problems with:

omxplayer off
mmal on
sync playback to display off

and

omxplayer off
mmal on
sync playback to display on.

Edit: in both cases support 8 channel DTS HD audio decoding is left on the default of on.

BTW contrary to what you said earlier in the thread sync playback to display has always defaulted to off.

Have you tried what I suggested with guisettings.xml yet ?

Try this a few times in a row with that file if you wouldn’t mind.

Yes, definitely something I want to get to the bottom of. Annoyingly it’s not that reproducible.
I’m currently playing the “Planes” sample and it is working every time (with omxplayer disabled, and “sync playback” enabled).
However I am seeing “rr:Inf”, rather than the expected number (close to 1.0), so that is something to investigate.

Aha! Enable DTS passthrough and now I get the stall on playback start. That was the missing setting.
Okay - I can reproduce problem, which makes a solution much more likely.

This will be my next test.

Excellent that you see something popcornmix.

The Planes file is DTS but I have no DTS capable receiver. My KODI settings are:

Enable passthrough
Dolby Digital (AC3) receiver
-Enable Dolby Digital (AC3) transcoding

OMX player DISBLED
MMAL player ENABLED
Sync playback to display ENABLED

These settings give me issues with those files.

Here is another file to test with @popcornmix : Copy.com This one is DD5.1 but has the same issue with above settings.

I got the exact same issue… blank screen and no audio.
Disabling 8 channel audio did the trick with the audio, but I still get blank screens after stopping a movie.
When I disable OMXplayer I get blank screen when it the file starts playing and I can’t stop it with the remote (cec).
In both cases sudo service mediacenter restart is the only option…

http://paste.osmc.io/evifitamiw
This is with OMXplayer disabled and got a blankscreen during playback at the third (and last offcourse) try.