Videos with VC-1 Codec doesn´t play properly

Hi @sam_nazarko!

Unfortunately i have a new problem… some of my untouched movies have extreme stutterings, loss the sound and have frame skips - all of the files playing well with my himedia players!

Have test Iron Man, Iron Man 2, The Incredible Hulk, all have the same problem direct at the beginning! The OSD shows that aq falls to 0% very fast!

The logs:

And the media info:
Format : Matroska
Format version : Version 2
File size : 18.4 GiB
Duration : 2h 5mn
Overall bit rate : 20.9 Mbps
Movie name : IRON MAN
Encoded date : UTC 2016-06-18 14:38:06
Writing application : MakeMKV v1.9.10 win(x64-release)
Writing library : libmakemkv v1.9.10 (1.3.3/1.4.4) win(x64-release)
Original source medium : Blu-ray

ID : 1
ID in the original source medium : 4113 (0x1011)
Format : VC-1
Format profile : Advanced@L3
Codec ID/Hint : Microsoft
Duration : 2h 5mn
Bit rate : 18.0 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.362
Stream size : 15.8 GiB (86%)
Language : English
Default : No
Forced : No

ID : 2
ID in the original source medium : 4352 (0x1100)
Format : DTS
Format/Info : Digital Theater Systems
Format profile : MA / Core
Mode : 16
Format settings, Endianness : Big
Codec ID : A_DTS
Duration : 2h 5mn
Bit rate mode : Variable / Constant
Bit rate : 2 181 Kbps / 1 509 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Frame rate : 93.750 fps (512 spf)
Bit depth : 16 bits
Compression mode : Lossless / Lossy
Stream size : 1.92 GiB (10%)
Title : Surround 5.1
Language : German
Default : Yes
Forced : No

Text #1
ID : 3
ID in the original source medium : 4608 (0x1200)
Format : PGS
Codec ID/Info : Picture based subtitle format used on BDs/HD-DVDs
Duration : 26mn 15s
Bit rate : 1 793 bps
Count of elements : 23
Stream size : 345 KiB (0%)
Language : German
Default : Yes
Forced : No

Text #2
ID : 4
ID in the original source medium : 4609 (0x1201)
Format : PGS
Codec ID/Info : Picture based subtitle format used on BDs/HD-DVDs
Duration : 2h 5mn
Bit rate : 727 Kbps
Count of elements : 14593
Stream size : 650 MiB (3%)
Language : German
Default : No
Forced : No

00:00:00.000 : de:Chapter 01
00:04:19.217 : de:Chapter 02
00:10:30.421 : de:Chapter 03
00:16:46.505 : de:Chapter 04
00:26:00.892 : de:Chapter 05
00:32:46.631 : de:Chapter 06
00:41:58.015 : de:Chapter 07
00:48:38.248 : de:Chapter 08
00:52:36.486 : de:Chapter 09
01:04:53.055 : de:Chapter 10
01:15:01.622 : de:Chapter 11
01:24:38.448 : de:Chapter 12
01:30:27.255 : de:Chapter 13
01:35:43.821 : de:Chapter 14
01:42:17.131 : de:Chapter 15
01:53:29.928 : de:Chapter 16
01:57:15.737 : de:Chapter 17

What´s wrong here? Other movies plays perfect - and the affected movies haven´t this problem with my himedia player so i must see these with the android boxes! :slight_frown:


Hi Mike,

Have you tried playing one of affected movies, from a usb stick?

Does the issue still occur?

Thanks Tom.

Hi Mike,

This usually indicates a buffering issue.
Where are you playing the files from?

If you are playing via SMB, try an fstab mount, as Kodi mounts do not use read-ahead. This fixes most buffering issues.

You sent me a couple of PMs but I chose to reply here as it may help other users.

Will do a test from a usb stick and report then… took some minutes to copy the whole file! I wonder why this occurs only on some movies - other with higher bitrate works perfect!

Remount the SMB share via fstab and the issue will likely go away


Remounting the smb share via fstab doesn´t help, same problems occurs! :frowning:

Does same problem == buffer underrunning still (low vq/aq?)
If so – copy to local storage.

If you can make a small clip and replicate the issue playing back from local storage; then send me a link to the clip and we will of course fix it.


Copy the movie to a usb stick and have also the same problem - buffer underrun… will try to make a short clip from the beginning…


Here is a 1 minute clip from the beginning of “Iron Man”, can replicate the problem playing the clip from a usb stick…


It seems that all movies with the problem have the VC-1 Videocodec!

Hi Mike & @sam_nazarko,

I can reproduce this issue with the clip provided, both local and nfs share. If I disable adjust framerate, the clip plays as it should.

Here are my logs:

6 tests in all, adjust rate: off, always, start stop and playblack local and nfs. Rebooted before uploading logs and tests start: 23:30:02.927

Thanks Tom.

Did you try disabling hardware acceleration?
I’ll take a look at this soon.

Hi Sam,

Just tried that now, with auto adjust set to always. Played ok.

No reboot this time, playback starts: 00:19:09.410.

I’m signing off for the night now, happy to do more tests on this if required; but they’ll need to wait till this evening after work.

Thanks Tom.

Thanks for confirming.

Acceleration can be disabled for only VC1 content in settings. The Vero 4K should have enough grunt to play most VC1 content in software.


I´ve test two movies with HW acceleration off and the files are not playable! Dozen of drops, frame skips and heavy stutterings so this isn´t an option!

Installed the new video scheme forum test build on one of my two Vero and the results are the same… :frowning:

Hi Mike,

Was local playback or via samba share? Due to the late hour I only tested locally with acceleration disabled. It may be worth providing logs showing playback with acceleration off.

I’ll test this evening with Acceleration turned off for VC1 content only.

Thanks Tom.


Test both with no luck, also enabled kodi video caching - the results are the same…


Interesting detail: with the option “set display refresh rate” = off the AQ ist permanent at 99%, but the playback isn´t very smooth according to the frame skipping thread…

Hi Sam,

I can’t find an option for VC1 to test this, I have:

Accelerate MPEG2
Accelerate MPEG4
Accelerate h264

Am I looking in the right place? Under Settings, player, Videos, Processing?

Thanks Tom.

I believe you can just disable amcodec.
But you need to watch the CPU; I remember there was a limitation where VC1 was only played back with one thread in the past (due to the design of the codec). This may still be the case.

Hi Sam,

Already tested that and seems to play ok, and provided log in post 13. Mike has reported since then, that disabling amcodec; didn’t help.

Thanks Tom.