VideoSync not perfect on Vero 4k+ [ SOLVED ]

Hello
Just got my new Vero 4k+
As an experienced linux+kodi user i set it up immediately and noticed some issues so im asking if anyone has any idea of whats going on

Whenever i play a file no matter what the file on PlayerDebug i always get a VideoSync with negative values that fluctuates constantly. VideoSync should always be a positive value non fluctuating in order to get stable frames with stable frame pacing fed to your display.

Vero 4k+ is connected to a LG OLED CX. Same display was tested with HTPC and other brand box ( Don’t want to advertise it ) and VideoSync is stable.
Playback content is any - SDR or HDR , 1080p / 4k - all have the same issue

Auto framerate switching is enabled
Sync playback to display is disabled

What i tried to resolve the issue :

  1. Updating to the testing 4.9 kernel
  2. Updating to the testing Kodi 19
  3. Forcing 10bit 444
  4. Testing multiple HDMI 2.0 Ultra certified cables just in case

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Have you actually tested to see if you can see visual issues? The VideoSync parameter works a bit different on AML.

It would be good to know what file you are playing and post some logs as well.

@Tom_Doyle , @sam_nazarko - debug log will be useless - video sync is not logged there. Do you really need the log ? I don’t have any dropped , repeated or skipped frames during playback if thats what you are asking.

For reproducing the issue i use any test file i can play. Anything you can think of.
The LG OLEDs from 2020 are very sensitive to frame pacing issues and it causes motion issues when doing 5:5
@sam_nazarko how does the VideoSync parameter work in AML if its not a trade secret ? Also have an older AML S905 box and VideoSync is always fine

If you have playback issues, we absolutely need to see debug logs.

But if you don’t have any playback issues, I’m not sure I understand what the issue is and what you’d like us to solve?

The source code is available on GitHub, but unless you’re familiar with PTS and DTS debugging I’m not sure if that will be helpful.
In late 3.14 and 4.9 kernels, we have devolved a lot of synchronisation to the kernel and not Kodi, so Kodi will not always report these correct numbers in userland. But unless you see issues, things are running smoothly.

To rephrase: is there a file which I can therefore play and will experience video playback issues?

Thanks

Sam

1 Like

@sam_nazarko ill send debug logs tomorrow
As i said i see playback issues with all files - any files

Kodi updates VideoSync on how fast the gpu accepts the buffered frame. Last time i’ve read that part of kodi’s source was ~2 years ago. Unless this changed - are you saying that the gpu path afterwards is not synced to Kodi because i don’t see how this is possible

The GPU is not used for video playback on any AMLogic platform, the VPU is used.
It’s a bypass render method, which is not the same on other platforms.

We have our own Git repository with downstream patches for AMLogic. AMLogic support has even been completely removed from Kodi upstream: https://github.com/xbmc/xbmc/pull/16043. We continue to maintain support downstream with our own decode approach.

You say

but also:

So what playback issues are you seeing?
Stuttering? Blackouts?

I don’t understand. Are you just talking about the number you see on screen when the playback debug dialogue is open?

If you are experiencing playback issues, please post logs.

Sam

The VPU outputs via the GPU correct? Its not directly connected to the HDMI port ? Are they using separate clocks ?

Im seeing weird frame pacing issues on a LG OLED CX. The LG OLEDs from 2020 are very sensitive to frame timing so if you send frames that are out of bounds for more than 8ms it has issues with 5:5 pull down. It expects frames to be sent exactly up to max 33ms for 23.976 or it starts having issues. All new OLEDs are like that from LG. VideoSync changing constantly shows how the frames are pushed to the VPU as you say then GPU then display probably arriving late causing issues ?

This is the current hardware i’ve tested with ( same file , multiple files , any SDR files obviously i coulnd’t test HDR on the Minix ( HDR lags ) and the Shield ( 8bit limit ) ) :

  1. Minix U1 S905 AMLogic box - VideoSync stays positive and is not fluctuating - stable 23.976
  2. NVIDIA Shield 2017 - VideoSync is messed up and always was on this device so it has issues since day 1 even on older OLEDs - can’t keep stable 23.976
  3. HTPC with AMD gpu - VideoSync stays positive and is not fluctuating - stable 23.976
  4. HTPC with NVIDIA gpu - VideoSync stays positive but is fluctuating however it works OK - semi stable 23.976
  5. Vero 4k+ - VideoSync - goes from negative/postive - its all random , fluctuates constantly no matter if its negative or positive - 23.976 is never stable

Video is rendered to a separate plane and the GPU is not involved. This is a bypass render method (zero-copy).

GPU is only used for GLES rendering of Kodi. You can play video via command line applications using the VPU only without any GPU involvement.

Again – the GPU is not involved.

At this point, we need to see debug logs, and it would be good if you could confirm whether there is an AVR or anything else between things.

There are other LG OLED owners here. I would suggest posting a small sample file and asking others to confirm if playback is smooth.

I spent some time with a TV in my holiday flat but cannot reproduce the issue whatever video material I tried; videosync is always constant 0 or positive with low fluctuation.

Absolute, see @Tom_Doyle’s post above ! If you could provide a short demo clip out of your video material which let you reproduce the issue, it would be even more helpful to understand your issue. Let’s help us to help you and provide these data.

2 Likes

all demos are links from Kodi’s sample page ( Samples - Official Kodi Wiki ) just to make it as easy for you as possible to test

demo 1 , audio on file , MEGA
e47988960b8f5f4c119c7825b166abab POCAWE_Sample.mkv

run 1 https://paste.osmc.tv/xufeyofugu - videosync fluctuates negative/positive
run 2 https://paste.osmc.tv/seduhicowe - videosync stays negative , fluctuates within negative

demo 2 , no audio on file , FPS_test_1080p23.976_L4.1.mkv - Google Drive
0cc493b2da7b4699ebada57b4c1d54c2 FPS_test_1080p23.976_L4.1.mkv

run 1 https://paste.osmc.tv/xiwunizile - videosync fine during multiple tests
run 2 https://paste.osmc.tv/getugubada - instant crash on playback after 1 second
run 3 https://paste.osmc.tv/duburipemi - vero decided on not auto switching frame rate, videosync 0.0 due to frame mismatch , hdmi cable plugged after boot intentionally , found this as a separate issue

There is no AVR device in the chain.

Vero 4k+ is connected directly to LG OLED CX via HDMI 2.0 ultra certified cable

I don’t believe there are many 2020 LG OLED owners here . Also most LG OLED owners will run their OLEDs with motion interpolation instead of 5:5

constant 0 means your display is out of sync with the vero 4k+'s content frame rate
the value should always be positive and not fluctuating

Looking at your config:

  1. Output configuration: Optimized ===> Default: Best match we suggest Best match as the optimal settings.
  2. GUI Resolution: 3840x2160 @ 59.94p we recommend keeping GUI at 1080 even if that should not influence your current issue.

I know the recommendations :slight_smile:
Any changes to the kodi settings don’t influence the videosync. Even the Kodi and kernel updates didn’t.
I’ve tested everything and that’s why im here

No LG owner in his right mind uses motion interpolation.

2 Likes

Check avforums/avsforum and you will see that most do

I’ll be of no help; with my current available TV in my holiday flat demo1 runs without negative videosync: Videosync is constant 0.0, not a single skip, drop or visual noticable negative effect.

But what I can see is that your audio config is sub-optimal:

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/96/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz, MaxBitRate 640kHz
Dobly_Digital+/ATMOS, 8 ch, 32/44.1/48 kHz, DepVaule 0x1
MAT, 8 ch, 48 kHz, DepVaule 0x3

So, you’re audio settings should be:

  • channel config: 2.0
  • passthrough enabled
  • AC3 enabled
  • AC3 transcoding enabled
  • E-AC3 enabled
  • TrueHD enabled

From my point of view the most important questions is:
Do you see any negative effect while playing the video or only the videosync value is what concerns you?

Hey @JimKnopf :
Please read my posts before commenting.
For the second and last time - If your videosync is 0.0 it means its NOT working. 0.0 means that your display refresh rate is NOT set to the video refresh rate - you obviously have match refresh rate to display disabled or your vero can’t switch to the supported refresh rates on your display causing a 3:2 pulldown applied.
As i already said there are visible issues with frame pacing.
Also there is no such thing as sub-optimal audio config. Just because its optimal for you doesn’t mean its optimal for other people. As i said and im saying for the third time all options were tested before me reporting here ( VideoSync not perfect on Vero 4k+ [ SOLVED ] - #16 by alex11 ) .

Thanks for your polite hint: The old TV here does not not support 23.976 fps but only 24 fps, instead.

For me it is the last time for you. Good luck to find people willing to help you.

1 Like

Im really not impolite to you but i wrote you the same thing 2 times already and you still didn’t accept my response. Anyways thank you

PS If you need help getting that 23.976 playing fine on that 24hz you can set a custom adjustrefreshrate in advancedsettings.xml like that + enable adjust refresh rate + sync playback :

<advancedsettings>
  <video>
    <adjustrefreshrate>
     <override>
      <fps>23.976</fps>
      <refresh>24.000</refresh>
    </override>
    </adjustrefreshrate>
   </video>
</advancedsettings>