VNC server on Vero4K

#1

Hi everybody,

is there a way to install a VNC server on Vero4K? Is the dispmanx server I used on the RPi suitable? Will the installation instructions for this server given in the “Howto” section work?

Your help is most appreciated!

Control Vero4K remotely
#2

Dispmanx is rpi specific and will not work.
Not sure if a generic vnc server will work on a framebuffer.

#3

Hi

Please try this:

sudo apt-get update
sudo apt-get install libvncserver0
sudo wget https://github.com/samnazarko/vnc-vero3/raw/master/aml-vnc -O /usr/bin/aml-vnc
sudo chmod +x /usr/bin/aml-vnc

You should now be able to start the server running /usr/bin/aml-vnc. If you want this to run constantly you can set up a systemd unit to do so. This procedure should be the same on Raspberry Pi.

If you have problems connecting, make sure you are using True Colour (24-bit) or the connection will not succeed.

[HowTo] Install a vnc server on the Raspberry pi
Vero 4K, first questions
#4

Thanks, Sam, for your advice - it works. Seems to freeze sometimes when running as a service, but need to verify. Appreciate your help!

#5

Hm, tried it a little … unfortunately no mouse support (which makes it hard to use on a tablet) and not showing anything when a video is running (dispmanx does, as I’m remoting to my parents to sort things out when needed this came in handy).

Is there any chance to resolve those issues? Or another solution to remote to the Vero 4k OSMC screen? Would be a pity to stick with the RPi just because of this …

#6

We don’t really have plans to support video over VNC as it will never display well.

Perhaps we can add mouse support in the future. This was just a small proof of concept quickly whipped up

#7

Would be great if there was further development … no need for smooth playback, dispmanx performance (approx. 2fps on a RPi 3) would be fully sufficient, idea is to be able to help remotely. Is there a way to port dispmanx to the Vero? Appreciate your great work with OSMC and the Vero!

#8

dispmanx is the Raspberry Pi windowing system, so it won’t work on a Vero 4K. There are improvements to that VNC server that we could possibly introduce to the aml-vnc server.

#9

Thanks, Sam! Look forward …

Cheers and have a nice rest of your weekend!

#10

Mouse is working for me. Not sure if @sam_nazarko updated the version but at least I can say it works with the version I downloaded today.

Have to correct myself. Now mouse is not working for me. Not sure if that was caused by the update or I was dreaming before that it is working

#11

Mouse working in this version, still needs libvncserver:

  sudo wget https://github.com/zjoasan/vnc-vero3/raw/master/aml-vnc  -O /usr/bin/aml-vnc
  sudo chmod +x /usr/bin/aml-vnc

Enjoy

Control Vero4K remotely
#12

My linux skills are weak, and this seems like it should be obvious, but I get this error

/usr/bin/aml-vnc: error while loading shared libraries: libvncserver.so.1: cannot open shared object file: No such file or directory

I have installed libvncserver0 per instructions for Sam’s repo previously, and his version works fine. What would be different with yours?

#13

seems like my system, the one that compiled the binary, had two libvncserver

sudo apt-get install libvncserver1

#14

Seems not to work on vero: E: Unable to locate package libvncserver1

#15

SORRY folks my bad, forgot i was running stretch on this box.Will get back tomorrow with a new binary compiled on jessie

1 Like
#16

@jamie New binary uploaded, this one is jessie based

1 Like
#17

@joakim_s can confirm latest version working. Surely mouse updates are slow but that part you knew alreadty

#18

Hey @joakim_s can you update this thread now that Stretch is released? THANKS!

#19

did you want it with or without mouse support (mouse support makes it lag alot)

#20

Without is fine by me, as I’m just using it for quick bluetooth remote settings/interaction from another room.

I had to install via:

sudo apt-get install libvncserver1

…since libvncserver0 wasn’t found. Looks like library names changed. I no longer have all the build tools on my Vero to Make from your source, so I couldn’t test if that would have solved the problem.

THANKS!
-Zac