VPN Question w/ Zomboided addon


New to RPI and here. Installed OSMC on a new Pi3 and then ssh into and installed OpenVPN. Then followed directions and got the Zomboided addon OpenVPN Manager installed w/ IPVanish. Works great. Checked out a speed test, and #'s were acceptable but not like my home computer. Anyway, wanted to compare speeds w/ and w/out the VPN, and found that I cannot disconnect from the VPN. Whne I click on the Disconnect line, it says it is disconnecting, and then says done. But when I check the status, it still shows connected, go into disconnect/change server and the server I was attached to is still Green and says connected.

Any thoughts? SSH shows service openvpn is not running, but speed tests verify it is still running through the vpn.

Thanks for everything you all do,


Hi Tom,

Have you tried

sudo systemctl stop openvpn
sudo killall openvpn

You can use:

curl ipinfo.io/ip

To check your ip has changed back to your public IP.

Thanks Tom.

No, have not tried that. I am new to system, the limited experience I have w/ Linux has been with a distro that will not switch over. They are proud of this, but I can’t say I understand the reasons.

I will try this evening when I get home. But the bigger question is why this is acting this way? I cannot ssh into the system every time I want to temporarily disconnect from the VPN. Also have not tried yet the pass through function, supposedly I can select an app that would not go through VPN, instead would get out direct. If the manager needs to stop the VPN for something like that, I need to see if it will.

Thanks for the reply,


Hi Tom,

I hope my suggestion, does the required.

But as for why it doesn’t disconnect through the addon, you will need to speak to the developers for Zomboided repo. I tried a quick google search, but this yielded no results for contacting them.

This link, maybe helpful though:

Or you may have luck over at the kodi forums

I’d like to more helpful with the addon, but it wasn’t developed by osmc and I don’t use it my self; so I don’t know much about it.

Thanks Tom.


I’m using zomboided vpn manager and it disconnects no problems. I’m using PIA.

Are you on the latest version 4.0.6?

I use a keyboard shortcut to connect and disconnect from the vpn. Open keyboard.xml in .kodi/userdata/keymaps folder. Add code below. F1 will connect to vpn. F2 will disconnect. F3 displays connection info

Restart kodi after saving. When rebooted. Press f1 to connect to vpn should display connecting then say connected. Press f3 to view info should say that your connected to vpn. Press f2 wait few seconds should say disconnected. Check f3 should say disconnected from vpn. Hope this works.

<f1>runscript(/home/osmc/.kodi/addons/service.vpn.manager/api.py, Connect 1)</f1>
<f2>runscript(/home/osmc/.kodi/addons/service.vpn.manager/api.py, Disconnect)</f2


@Tom_Doyle Tried, no success. Thanks for the suggestion.

@the_bo Do you have it set up to auto start on boot? I think I recall that as an option on init config, but am not sure. Can’t seem to find it again.

I will try to config the keymapping. No time now, But, if openvpn is starting at startup, how does the keymap override the manager?

Thanks for any/all assistance,


There’s an option in VPN manager settings to automatically start on boot disable that.

Don’t have any openvpn start on boot. Check f3 to see if ur ISP is displayed on boot. Then try with f1 to connect.

@the_bo Disabled the auto start in settings. SSH to copy text to the keyboard.xml. Rebooted. At least the VPN did not come up automatically. F keys do not work. Using Ipazz wireless keyboard, maybe not wired right.

So, went into VPN Manager and manually started a VPN session. Once started, impossible to disconnect. Says is, but still connected. Was there something special I needed to do to get this installed? I just installed from zip, and then enabled. It seems to me I have seen another method mentioned that “clicks” on a file and it installs itself (maybe the Hornsby app, I have gotten confused reading so many methods to possible do things.

Anyway, any other suggestions would be appreciated.


I have the same problem as you. I have also noticed that kodi vpn starts openvpn twice, one with sudo, one without.

I don’t use the VPN Manager but it might also have been that kodi starts openvpn only once, using sudo, and this creates a child process that runs under root. This is necessary since kodi.bin runs under user osmc but openvpn needs root privileges to modify the routing table.

You see something similar (but reversed) when kodi.bin is launched (by root) with sudo -u osmc so that it runs under user osmc:

osmc@osmc:~$ ps -ef|grep [k]odi
root      2794  2744  0 Aug12 ?        00:00:00 sudo -u osmc /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /var/run/lirc/lircd
osmc      2801  2794 13 Aug12 ?        03:05:35 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /var/run/lirc/lircd

The parent process ID of 2801 is 2794 but the child process (2801) is the one using all the CPU.

Thanks. I would like not to use the addon for VPN as well but gave up trying after wrestling with connman etc. until my head hurt. Do you know of a reasonably idiot-proof step by step guide to set up VPN over ssh?

Maybe this post will be of help New user needing basic help - #6 by fzinken

Thanks dill, but seeing as osmc is committed to connman, I’d like to figure out how to set up vpn and dns using connman rather than the established debian methods. In short, complete control of the setup for both dns and vpn using the connman system, all over ssh. If I ever sort it all out, I’ll write it up and post it here.

AFAIK connman hasn’t yet been modified to provide VPN support. Sam had said that it’s on his to-do list but perhaps you’ll manage to get there first!

Please do let us know if you make any progress.

Maybe you need to install psmisc

sudo apt-get install psmisc
Psmisc are extra commands to allow tne pi to kill of the old vpn connection.
I had this problem and psmisc solved it .

Sorry, I should have included: