Warning! Free disk space remaining is only 0MB

I arrived back from a few days away to find my Pi2 running OSMC stuck in a boot loop (sad face). I auto reboot it every night so obvioulsy while I was away something went wrong.

On rebooting again I got the warning in the title. " Warning! Free disk space remaining is only 0MB - Kodi will be unable to start if disk space is completely exhausted. Please free sufficient disk space"

I have been running osmc for a few years and have had the issue of insufficient space to download updates but thats usually solved by a clean or autoclean etc. I tried these commands and it didn’t work in solving this issue. My boot partition has space but as can be seen in the attached picture the /dev/mmcblk0p2 partition is full. I haven’t done anything new recently just running kodi and some background programs as usual (transmission, sickrage, openvpn) so not sure what has gone wrong.

I have tried digging around but I am unsure what I need to do to free up space or where I need to free it etc. Any suggestions would be very helpful. Thanks.

It’s probably something in your home. Try:

du -hs /home/osmc/*

to find out what’s using the space.

Had checked alright and there is nothing really there of any size bar less than 1Gb in the sickbeard folder37

Next step to find where the space is used would be:

du -hs /*

Thanks, not seeing anything major here either that would be filling all the space

du -hs /mnt/*

Just my two external HDDs (the 3rd entry is a misspelling of the 2nd HDD which I forgot to remove).55

Ok, because sometimes a failed mount results in a large amount of data being downloaded (by torrent client, etc) to the sdcard unintentionally. Apparently not the case… Very odd that these steps haven’t provided an explanation here though!

Just to be certain and thorough, can you unmount your USB drives and check again?


Strange still showing as 3.9G on one of the mounts even though its not mounted.44

It looks like you wrote 3.9 GB of data onto your mount point, at a time when the external drive wasn’t mounted.

Thanks all for the help. Back up and running now after deleting the data saved to the mount point. It was some stuff that got downloaded there a while back so I must have been very close to the edge of storage on the SD and must have just pushed over in the last week from general build up or what ever.

Thanks again.