Washed out black?

I just got my Vero V and it was replacing an Vero 4k+. And IT seems like an VERY old problem is back. The black in the screen is not really black and crisp like it’s when I have the Vero 4k+ connected.

It’s sort of faded.
I use the same exact settings on both devices and the difference is real annoying.
The settings is 1080p and 60Hz

Any Idea?

So, what is your configuration of setting

GUI -> settings -> system -> display -> use limited colour range ?

If you can’t fix it with that, logs are helpful:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Sorry for my bad error report.
I have uploaded the log files https://paste.osmc.tv/tunaromowu

The only things I changed is Force 422 don’t matter If I chane that back or not.
Same goes for limited colour range, no difference what I enter.


Is it only during playback or also in the interface?

Can you show a photo so we can see a comparison?

It’s in Interface and in playback.
I’ll try to take some picture, but it’s not perfect to take a picture of a blank screen…
(I’ll send the picture’s in E-mail :-D)

It looks terribly you will only have a picture of me reflecting from the sofa I sit in…
Have to try and take picture later when it’s dark out.
Beside my phone will correct any error it find in the picture so I will try to figure that out to.

You can upload images here.

Even if that’s true, turning off limited colour range will create other problems further down the line. Keep it turned on.

Is your Vero V connected to the same HDMI input on the TV that the 4K+ was?

Yea well, it’s not public domain stuff…

Yes! I just shift them.
Same RJ45 and Same HDMI.
And now even the same power, the one from Vero V.

If this was a problem initially with your 4k+ what did you do to correct it with that device?

And if, just for the sake of testing, you plugged the HDMI into your TV instead of your AVR is the condition still present?

Well that’s one think I really can’t do. If it looks great as it does on Vero 4+ It should at least look the same on Vero V so changing how I connect the system don’t really give a meaningful answer.
And I will never connect anything direct to the TV anyway. Everything goes trough the AVR.

And No I didn’t have the problem with Vero 4 I just read about that in the forum before I posted my question. I mean all questions starts with a search?

Sorry that I’m not a native English speaker, but that sounds a bit insulted and uncooperative.
The idea behind @darwindesign’s question might be to find out whether your Onkyo AVR is doing any conversion here and so is part of the problem.
At the moment I’ve also no concrete idea what could causing that. Just to summarize: If you connect the VeroV on that HDMI cable to the Onkyo, you see the problem. If you reconnect the Vero 4k+ to that same cable , all looks fine, right?

1 Like

I’m not a native speaking either (whatever that have to do with anything).
I fully understand what he was trying to do BUT my 2 cents is I have a perfect picture when I connect the Vero 4 and If I connect the Vero V in EXACTLY the same it should be the same?
And I’m saying it’s not. How would it help that I connect in another way that I never will run it at?
Even if the error is in the Onkyo WHY it is not when I connect the Vero 4?

Btw I tried to take picture but my mobil Camera fix the picture. So it’s no use…

Try taking some photos with the selfie side of your phone as it may have less post processing / filtering


1 Like

Well, it’s what you would call the process of elimination.
If you plug it into your TV and it looks fine, then plug it into your AVR and it looks washed out, then that would help narrow down the problem.
No one would suggest that the fix is to just leave it plugged into your TV, but it would be helpful to know what the behavior is both ways.
My guess would be that the settings are not identical, then I would suspect that the AVR is handling the V different than the 4K+, but it could be a bad unit too, anything is possible, but if it looked proper when plugged into the TV directly then obviously we wouldn’t think the unit is bad but rather it must be some setting with the V or the AVR or a combination of both.
Is it too difficult to plug it directly into the TV?
(That’s a serious question, I know some people have some pretty crazy setups.)

1 Like

Sorry already tried that. My mobil will just fix the picture…

I give up! I bought my first Vero 4+ in 2019 and it was not perfect then but over the years it has evolved to a pretty decent product. But it has come to end with the ever-changing media and the CPU was surly to week to manage all that we could throw at it.

I will go back into hiding and wait, and perhaps the Vero V will be a perfect product after updates that will come. Perhaps IT is the AVR and perhaps that I will buy a new one in the feature like I did before.

So, you can close this case down I will go back into hiding and wait.

Some of these A/V devices have per device settings (ie not per port) and some AVR’s do some video processing on their own. Additionally there can be reporting of capabilities from different Video devices that will change how the signal is sent from a Vero as it tries to make sure it only sends out a compatible signal. It sounds like your under the impression that what you are experiencing is some kind of a known bug and are frustrated by the lack of an immediate solution. You searched the forum, when was the last relevant issue that was something other than the limited color range setting? I can’t recall one off hand and I’ve read almost every post here for years. I assume that there is probably just some setting in your TV or AVR that needs to be tweaked as incorrect color rendering isn’t something that we have been getting reports on with this device.

Hello, @matte31 .
It might be helpful to try to take a video instead of a photo and then pull out a short part from it or take a picture from it.
So you need two videos instead of two photos.

Please don’t give up! As people have said, this is most likely an issue with limited/full range settings. Washed out blacks suggests a limited-range signal is being shown on a display set to full-range. Or else the display is badly calibrated. As you did a search of this forum before posting, doubtless you read this.

It’s a complicated subject - the TL;DR is if your display is a TV make sure everything is set to limited range (or, maybe ‘Auto’ on your display) then play a ‘PLUGE’ test to check your display settings.

As for why Vero4k is different from Vero V I can’t immediately think why that could happen. No-one else has reported a difference. Maybe you could post logs from the vero4k for comparison? You could also look at the output of
cat /sys/class/amhdmitx/amhdmitx0/config on the two devices. Is it the same for the GUI and when playing a video?

What are the makes/models of your AVR and display? In particular, does the AVR have two HDMI outputs so it could be sending a ‘made-up’ EDID to the Vero?

We would really like to understand why you are seeing this issue in case there’s anything we can do to the software to make it less likely to happen for you and other users.

Update: I think I can guess what’s happening. You have probably got quantization range set to full on the vero4k. Since your display does not support full-range video using YCC this means your blacks should be too black (‘crushed’). Vero V is smarter - it won’t output full-range video to a display that doesn’t support it. Hence you have brighter shadows. But it’s Vero V that’s correct and vero 4k that’s wrong. Here, a PLUGE pattern looks the same on Vero 4k and Vero V as long as both are set to output limited range.

Have a look at recalibrating the black level on your display.