Web server problems


for a while I am having problems with the web server. In a browser the web interface controls are working, although no media is shown. Every few seconds it shows up ‘Lost websocket connection’.
Yatse is not working at all. It shows connected, but no control input is working nor does it list any media.
For a while OSMC did not remember the username and password of the webserver settings. Every time I did set them again Yatse started working, but after the next reboot they were unset in the menu and it stopped working again. Today though I entered them again and they stay even after reboot, but still have the connection problems.

This problem exist for at least one version if not longer (can’t tell when it started or how often it updated since). Tried Chorus and Chorus2 skins with no avail.


I would appreciate your help to fix this without having to reinstall. Thank you.

Yatse requires some explicit configurations to be in place in Kodi in order to function properly.

1 Like

It looks like you’re on port 8080 for Chorus. Change it to port 80 on Kodi and see if that makes a difference.

And Chorus2 is so much better!

1 Like

Ah thanks. Had forgotten bout another setting I had enabled before but did reset itself (or wasn’t saved?): “Allow remote control from applications on other systems” Now Yatse works again.

Yeah, changing port to 80 solved the websocket problems. Thanks!
But what is the problem with port 8080? And why is this the default?

I wish I new! :wink: I had exactly the same issue and simply tried port 80 since it’s the standard port for http.

As for why 8080 is the default, that’s a question for the Kodi forum. Port 8080 is the “alternative” http port.

1 Like

Unfortunatly the web server settings have reset again. It was all fine after reboot but then after the next poweroff and on it was reset. Username and password fields are empty, port is back to 8080 and the previously mentioned checkbox is unchecked again.
What is going on there?

Generally, it’s recommended to run these devices continuously, rather than switch then on/off each day.

One possibility is that the SD card is broken and won’t hold data. You can easily test this by connecting to the Pi by SSH and creating a file. Running the command touch testfile will be enough. Then power off the Pi, switch it on again and see if the file is still there.

Never heard that this was the recommended way. I’m not using it often enough to legitimate having it running all the time. Mine is powering off when TV goes into standby and gets powered on (reset) through a USB adapter when TV is turned on.

Test passed, the testfile is still there after a power cycle.

If the testfile is still there, then it’s difficult to know where the problem lies.

It could be that the machine isn’t being shut down correctly. Are you using CEC to run a controlled shutdown of the Pi or does it simply lose the power on TV standby?

It costs about $6/year for it to run all the time. You aren’t really saving/wasting anything at all by leaving it on.

It’s a controlled shutdown.

Then I’m out of ideas. First, see if it’s 100% reproducible or only occurs occasionally over a few reboots (no power off) then shutdowns (power off).

So it’s also happening on reboot.
I had just changed settings level to Expert before and it also reverted back to Standard.

Could it be

ERROR: CSettings: unable to load settings from special://masterprofile/guisettings.xml, creating new default settings

or this one?

WARNING: JSONRPC: Could not parse type “Setting.Details.SettingList”

The would be file /home/osmc/.kodi/userdata/guisettings.xml.

See if you can edit it. Look for webserverport and try to set it to 80.

This was a known problem and should have been fixed. See thread: Skin changes lost after a reboot
It’s often hard to say if the error comes from a bug or the SD card. I had both, on one Pi it was the bug from older versions, on another Pi it was the SD card… If you have a second SD card gice it a try, if the problem still exists I think the other thread is the right one.

I’m thinking more towards a corrupted xml file. We’ll see.

This installation is also >2yrs old. Is this still the original SDcard or have you migrated at some point?

This worked.

Might be [quote=“ActionA, post:17, topic:36961”]
Is this still the original SDcard or have you migrated at some point?

I think it’s still the original one. At least that old. Should I run a h2testw?

i can’t see any reason not to.