Weird staircase-like distortion patterns in UHD videos since September update


so it turns out I was too early celebrating no problems with the September update. Noticed something weird this morning. When watching a UHD vid, a weird staircase-like pattern flickers across the TV. Noticed this behaviour with YouTube (3840 × 2160, VP9, 60 FPS, SDR and HDR alike) as well as a file from my NAS (LG’s Chess demo, 3840 × 2160, MP4, HEVC, 60 FPS, HDR), which has worked countless times before.

This is what it looks like on a picture:

A video’s worth a thousand words, so here’s two short vids of the erratic behaviour:

TV is an LG OLED B6. Last but not least, here’s the log for settings and stuff:

Does this have to do anything with the new video stack mentioned in the patch notes? Just let me know if you need any additional info to analyse the error. Cheers!


First and foremost – have you tried the staging repository to see if this issue has been solved since the update has been released?

Secondly – will playing the YouTube link you’ve posted above allow us to reproduce the issue? Are you able to reproduce it on another display



Hi Sam,

Do Chillbo’s instructions still apply for switching from stable to the staging repo?

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Yes, it should reproduce the error but so would any other 2160p YT vid. I’ve tried with other UHD vids on YT, the one linked was just an example. It happens with all of them as long as they’re 2160p. 1080p and 1440p are not affected.

If switching to staging won’t solve the problem, the only other displays with which I can test are my two 1080p PC monitors. No idea if playing the local 2160p file and having Kodi downscale it to 1080p for the monitor will yield the same results but we’ll see.

Thanks for your suggestions! I’ll try and report back with the findings this evening.

After the latest update the instructions would be


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

1 Like

Thanks, switching to staging did the trick! :grinning: YT UHD vids as well as some other local UHD video files are working flawlessly now.

However, the LG chess demo vid still shows distortion. It’s different from the one before, no white staircase lines but … glitching pixels. Here’s a vid of it:

Could anyone try on their OSMC installation with a Vero 4K if the file is rendered correctly? No worries because of the MEGA link, it’s an LG demo file that’s also available on YT without copyright/DMCA claims. Unfortunately, the site from which I downloaded it regularly exceeds their Google drive download quota. My only idea for the reason it’s still distorted is a certain combination of video parameters.

ID                                       : 0 (0x0)
Complete name                            : H:\LG Chess UHD HDR Demo.mp4
Format                                   : MPEG-TS
File size                                : 842 MiB
Duration                                 : 1 min 53 s
Overall bit rate mode                    : Constant
Overall bit rate                         : 62.0 Mb/s
FileExtension_Invalid                    : ts m2t m2s m4t m4s tmf ts tp trp ty

ID                                       : 257 (0x101)
Menu ID                                  : 1 (0x1)
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main 10@L5.1@High
HDR format                               : SMPTE ST 2086, HDR10 compatible
Codec ID                                 : 36
Duration                                 : 1 min 52 s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 59.940 (60000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Writing library                          : ATEME Titan KFE 3.7.3 (
Color range                              : Limited
Color primaries                          : BT.2020
Transfer characteristics                 : PQ
Matrix coefficients                      : BT.2020 non-constant
Mastering display color primaries        : Display P3
Mastering display luminance              : min: 0.0500 cd/m2, max: 1000 cd/m2

ID                                       : 258 (0x102)
Menu ID                                  : 1 (0x1)
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Format version                           : Version 4
Muxing mode                              : ADTS
Codec ID                                 : 15-2
Duration                                 : 1 min 52 s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy

I’ve the same demo file as a testfile for every update, so far no issues on my side with it.
Same file located on NAS, via NFS played (autofs), flawlessly.

Did you tried to play the demo from USB, does it give the same result?

Hope it helps you narrowing it done.

Worth a try! I’ll give it a shot this evening and report back.

Vero 4K, connected to a FHD TV here: all fine.

1 Like

Just tried playing the file from a USB pen drive attached to the Vero 4K. Same pattern, no change. :neutral_face:

That is a pity.

My file came from the same site

For clarity i have a 4K+. Maybe that helps narrowing it down.

1 Like

Chillbo already tested with Vero 4K (non-plus) and it’s working for him (no idea how much the FullHD display plays into this, though). It’s still weird. Not a big issue since “normal” movies play without any errors.

This file plays without artefacts for me, too - at 2160p, 59.94Hz, HDR10. My TV is an LG G6.