What is the difference in these 2 pics?

I am already chatting to Sam about this directly so not raising a bug as such, but out of sheer curiousty can anyone tell my what the difference is between these 2 pictures?

Same timestamp both streamed from my NAS, one via the Vero and one via my Panny ub900.

The 2 things I notice as being different are the amount of detail in the dark (not just brightness levels I don’t think as the black is still black), and that the skin tones are much more natural (the darker one has a red / grey / blotchy thing going on).

The lighter one (Panny) is how i think the image should look, but curious to get other input.

Thoughts welcomed!

Did you set the bit depth correctly? If rc.local didn’t exist, then you might need to run chmod +x on it


I think so. Screenshot of ssh below:



#!/bin/sh at the top

When you save the file, run sudo chmod +x /etc/rc.local.
If it works, then on reboot cat /sys/class/amhdmitx/amhdmitx0/attr will show 444,10bit

1 Like

Ok - given it a try and see the following - is this correct?


I ran sudo chmod +x /etc/rc.local from the main screen but it just gave me a new line:


That means the command did not have an error and is assumed to be successful.


Thank you. So looking at Sam’s line below, what am I rebooting and where do I see the updated info?

If it works, then on reboot cat /sys/class/amhdmitx/amhdmitx0/attr will show 444,10bit

just type reboot, ssh in again and type

cat /sys/class/amhdmitx/amhdmitx0/attr

Thanks again. Does this look right:


Yep, that’s what you should see.

Brilliant - thanks all. I love this forum. All very helpful and polite!

1 Like

This might improve the picture quality for you.


So did it fix your problem? If so, please mark your solution so others can benefit from your experience.

Let me put the kids to bed and report back

So, strange problem now occuring. I can see the normal menu and naivgate around for maybe 8-10 seconds and then completely blank screen. No images or sound. Have unplugged and rebooted on seperate occasions, and get circa 10 seconds of normal behaviour, then nothing. Tried other 2 sources and they work fine, but Vero is fine. Any ideas??

First, since you can ssh in, it’s a bad idea to just pull the power. Instead:

sudo reboot

To revert your change, just put a # at the beginning of the new line you added to rc.local:

#echo "444,10bit".......

and reboot. If the problem goes away, then we will need more info, logs would help.

Thanks and done. Will check tomorrow.

Strangely the Fire TV is now exhibiting the same behaviour on an entirely different input which suggests it may be something else. However, I have had flawless playback for 2 years without anything like this, so the same behaviour on 2 inputs at the same time following a change suggests it is the same thing (no idea how updating the vero 4k would impact other player though…?)

Sorry, how would I supply logs?

You could just disconnect the Vero to make sure it isn’t causing a problem.

As to logs:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.