What's the current generally accepted Spotify solution

Sometimes finding up-to-date information can be quite a struggle.

I’m currently running the OSMC test build with Kodi v19 (Matrix) successfully and smoothly.
I went with this build because it was needed for the F1TV add-on I found on github. Amazon VOD and Netflix also work great after replacing the thermal pad in my Vero 4K+ (poor contact with heatsink).

The next add-on in my agenda is Spotify. But there seem to be multiple implementations and I’d like some help figuring out which one fits my needs and actually works.

I’d like to have both the possibility of using an add-on as a standalone player, and as an external player.

I found a fork of the Spotify add-on made to support python3 but it seems to require a browser to login.

Is there a way to use a browser in OSMC? Are there any other recently verified working solutions for Spotify on OSMC?

Hi,

This is indeed possible, but surely not the best solution.

Unfortunately I don’t know much about Spotify but I’m sure others can advise.

Sam

I’m looking into this again, raspotify isn’t working. And the unofficial Spotify-kodi addon, for v.19 I havent manage veryify the app. Might be my family plan messing that up.

1 Like

I too am on a family plan but I don’t think that’s the problem. When using the add-on, you need to authorize it as a spotify-compatible application, that’s why a browser is requested.

Bumpity bump. Anyone come with a reasonable Spotify solution yet? My music playlists on youtube are mostly full of “Deleted Videos” now a days and isn’t really an alternative at all.

For me librespot solution works very well:

Cheers

Which version of raspotify are you using? Tried the latest on a fresh install, with 4.9 kernel and Kodi 19. And it didn’t work out of the box.

I‘m on kodi 19 with RPi4 and I used the autosetup script (so latest version of librespot). With that I hadn‘t any problems and it worked immediatly!

Cheers

Ok, pi4. Guess there might explain it, had issue getting it to run on a Vero4k, downoading latest released .deb

I’m using OSMC on a Pi 2. I followed this article and it worked great for me:

I did method 2 which is installing the add-on directly from a zip file: https://github.com/ldsz/plugin.audio.spotify/archive/refs/heads/master.zip
I have a family plan and it works perfectly! It logged in my account automatically through Spotify Connect.

Hope this helps! Cheers.

This would be a great feature, Actually when I try to install that repo GitHub - dtcooper/raspotify: Spotify Connect client for the Raspberry Pi that Just Works™ I get into an unmet dependency:

Unmet minimum required package version(s):

libc6 >= 2.31 is required but 2.28-110.4 is installed.
systemd >= 247.3 is required but 241-7~deb10u8 is installed.
libasound2 >= 1.2.4 is required but 1.1.8-1 is installed.
alsa-utils >= 1.2.4 is required but 1.1.8-2 is installed.
libpulse0 >= 14.2 is required but 12.2-4+deb10u1 is installed.

Please make sure you are running a compatible armhf (ARMv7), arm64, or amd64 Debian based OS.

@DigitalPeak I moved your post to a thread on the same topic that wasn’t four years old. In case you were not aware there is also a HowTo on this site for Spotify-Connect.

You need an older version for Vero as it’s not on the latest Debian yet.

The version you need to download is:

0.31.4 of raspotify.

This will install clean without dependency error.

It runs just fine.

Thanks, that worked!!

1 Like