Where do I start with a Vero 4K+ (not older Vero 4K)?

I am a complete moron when it comes to this stuff, and everything I have read so far assumes that I at least know SOMETHING.

  1. Is there a place where I can find a DUMMIES guide? I mean, I know what OSMC is, and I have heard of Kodi, and I am familiar with other boxes to play movies from my server, but upon plugging in the ethernet connector, the HDMI connector to my TV, and the power supply that came with the Vero 4K+ that I bought about a month ago, I am totally stuck.

  2. There is a “+” symbol on the front of the unit that lights up in red as the unit boots up, but then it goes completely dark. Shouldn’t it be green once booted?

  3. At that point I am at a screen which I assume is for setting the language, but I don’t know for sure, as I can not do anything. Even though I have properly removed the clear plastic insulator in the battery compartment, the remote does not do anything. I have looked into the front of the remote and there is a tiny blue LED which flashes every time I press a key, but the 4K+ does not respond at all. Is there an IR receiver built in to the front of the Vero 4k+?

Then I tried plugging the IR receiver extension into one of the unmarked ports (1/8" stereo jack) in the back of the Vero 4K+…no better. Then I tried the other unmarked port…still no better. I can’t plug in the IR extender into a USB port like is mentioned in the Wiki, as the extender does not have a USB connector on it.

Also, the “pairing” procedure seems to apply to the older Vero 4K and not the Vero 4K+, so when I tried the old procedure, that doesn’t seem to work either.

I am sorry for all of the noob questions, but after a couple of hours I am pretty frustrated with the outdated instructions that I have found in trying to do my own research. The older 4K is simply not “close enough” to help a 4K+ user. And there are very little, if any, diagrams and specific hardware operational descriptions that I could find.

If anyone is willing to give me a hand, I would greatly appreciate it.

Hello and welcome to the forums.

Firstly, the Vero 4K is very similar to the Vero 4K +. Instructions for either device will work.

Your best bets would be:


and File sharing with a NAS, media server, windows share or other device

There is only a red LED, displayed when booting or if the device is in standby.

It sounds like you haven’t plugged the USB remote receiver in. If you wish to use the supplied remote control, you’ll need to plug that in. It is a small receiver and would have arrived taped to the back of the PE bag which your remote control arrived in. Once this is plugged in, the remote should then work as expected.

The pairing procedure applies to all generation of OSMC remotes, but obviously needs the USB plugged in.



Ahhhh…that was it! I never saw that USB receiver - just the large red IR extender. I searched carefully and found that it was taped under the cardboard box insert.

Gotcha…thanks! Now it makes sense…:slight_smile:

[quote] Your best bets would be:


and File sharing with a NAS, media server, windows share or other device[/quote]

I had already read the quickstart guide and a lot of the Wiki, and now I will read the text on file sharing.

Many thanks, Sam! I probably would have never found the USB-IR dongle if you hadn’t spelled it out to me. I thought that the IR was handled differentlt from the 4K to the 4K+ and was just not documented…now I know better…:smiley:

The IR is if you want to use your own remote.


Well, once I got the remote working, everything went quite well…excellent video quality, passes Atmos and DTS-X just fine, and decodes multi-channel FLAC within an MKV container - my main reasons for switching to this system. All the rest of the features and add-ons are just gravy, and I feel like a kid in a candy store.

UNTIL…I tried installing the YouTube add-on. Everything went fine until it failed to work because it had invalid API keys. I researched the problem and went through a lot of agony creating an API key, but I even got that done. The problem comes when trying to enter the API information. I went to settings-youtube/api and was told to “enable personal API keys” - a setting that I can not find on Kodi 18.6. I even tried accessing the API configuarion page (which I was able to do successfully), and there I can only find three things - API ID, API secret, and API key, and still no option to “enable personal API keys”. What am I doing wrong?

Make sure your settings level is Expert.

Yup…I am set to expert. All of the other settings appear. I am only missing the top line “enable personal API keys”. I even went through much pain to enter the 3 keys manually in the YouTube settings/api area, and it was no better.

My Settings-YouTube/API screen is arranged like this:

API Secret
Allow developer keys (enabled)
http://:/api (see HTTP server)
Enable API configuration page (enabled)

That’s it…there are no other items to modify, enable, or otherwise change. I have seen screen shots on the web showing the missing line, but I don’t have that line.

Maybe I should uninstall the app and then reinstall? If I do that, will that remove any previously entered information, like the Connexion : comptes Google codes that I have already entered?

I don’t know much about the YouTube add-on. I know it’s a royal pain to set up now.

Ok, thanks Sam…I guess I will just uninstall it and forget it…:frowning:

I have an Amazon Prime Video account…I wonder if that one will be easier, especially considering it is not in the Kodi add-on reository.


I take it you are working from these instructions:

Have you looked at method 3, you will need access to the commandline:

nano is the easiest way to edit the file:

nano /home/osmc/.kodi/userdata/addon_data/plugin.video.youtube/api_keys.json

Once you’ve made the change ctrl-x and yes to save and exit

Thanks Tom.

The problem is that even with method 3, it says to “enable personal API keys” and I do not have that option ANYWHERE, despite the fact that I am in the expert mode.

Oh, and yes, the link you provided was the procedure that I followed.


Sorry Yes its been awhile since I set this, I thought I had enabled the api key via the conf file. Anyway I’ve just checked the setup on my PI (should be the same on vero4K+, if not I’ve got one here so I can do further testing). All I’ve got filled in is the API key, API id & API secret and Allow developer keys is checked; also http://:/api (see HTTP server) is left as default. All works, so I’m guessing the instructions for client side are slightly out of date.

As for Amazon Prime, from what I remember its just a case of installing the Sandmann79 repo and installing the addon, you are limited to 720p though.

Thanks Tom.

Thanks Tom.

Thanks, Tom! I will try to do as you suggest with my new installation. Did you enter those keys manually?


Yes after I created them, I ssh(ed) in and copied and pasted them into api_keys.json

sudo systemctl stop mediacenter
nano /home/osmc/.kodi/userdata/addon_data/plugin.video.youtube/api_keys.json
sudo systemctl start mediacenter

Thanks Tom.

Ok, gotcha…thanks again!

1 Like

@Oddwunn, have you checked the settings for the YouTube add-on? If you go into Settings - Add-on browser - My add-ons - Video add-ons - YouTube and then select Configure, you’ll be tweaking the settings for the add-on itself. There’s a section called “API”.

Arrgghhh…I’m getting frustrated again, so I will just put it down for awhile. Now every time I try to connect over the web or SSH, I get a “connection refused” message. It was working fine yesterday before I updated OSMC. I can not access the API page and I can not get in with Putty. I can get into my servers with no problem (running UnRAID), but I can not access the Vera 4K+ other than through its video interface using the remote. All worked fine yesterday using the exact same network, computer, etc.

BTW, The 4K+ accesses my servers just fine, and I can scrape metadata, and I can download apps…I just can’t get in from the outside.