Why won't my Vero 4K+ update manually

Any help here please

also why won’t it bitstream the correct audio, its not showing Atmos just pcm

any help would really be appreciated tia :+1:

What version are you on?

Did you configure audio settings under Settings → System?


hi Sam

i’m on Oct 2020 and yes we have configured the audio

it’s done this before regards the audio and doing an update seemed to cure it, for whatever reason unknown to me now it doesn’t want to update

Without logs, or a demonstration of the problem, nobody will have the faintest idea, either.

So help me to help you with what you require

A photo showing that it won’t update and/or showing pcm won’t help you so explain what you ask so i’ll do my best to supply what you need if you tell me


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Regarding configuring audio, see Audio hardware and software configuration - General - OSMC.


hi everyone

so a bit of an update, I’ve taken some screenshots which I hope will allow you to see what’s happening, I’ve disabled sync playback to display and rebooted twice as recommended and that seems to have cure the audio playback, all my other settings were correct afaik.

I’m still unable to update though, it’s still saying no available updates and as I type this, the Updater - Cache Updated-please wait window is still showing on screen

any further help and ideas would be most welcomed



There is currently no update newer than your November 2020 version unless you change to the Testing Version of OSMC. The next stable update is expected in the next weeks.

Your device is already on the latest version.


so that clears that little issue up then lol, so it appears I’m good to go and working fine

Many thanks, especially on the audio side because that had me stumped tbh

Thanks everyone, Allan :+1:

My Vereo 4k does not want to update manually either.
Version installed: OSMC November 2020 2020.11-1

According to the OSMC homepage, the latest version should be 2021.12-1, right?

Have you tried the hotfix?

Which HotFix ID do I have to enter?

It’s explained in this link.

Hotfix ucawobahij worked.
Thank you for your notice