Widevine add-ons stopped working from 01/09

If you’re reading this, you’re likely experiencing a problem with an add-on such as Netflix or Amazon Prime Video, which use Widevine CDM encryption to implement DRM.

Since 1st September, Google deprecated a number of Widevine CDM library versions and only a newer library is supported.

Support for this new version will work out of the box in the next OSMC update. For now, support is available via the testing repository.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

The implementation of Widevine CDM was never an officially supported method and has always remained experimental. As such, it has been plagued by a few issues: playback has been limited to lower resolutions and lacked hardware acceleration. This meant that playback had to be decoded in software, which in turn limited the maximum resolution and bitrate of streams further. The library changes today were just another sign of how we are at the whim of Google.

Last year, OSMC signed the Widevine Master License agreement, giving OSMC permission to reproduce and distribute Widevine libraries for secured OSMC devices. We have been working on delivering support for hardware accelerated Widevine (including Widevine L1 support which provides access to higher resolution streams) for Vero users. We will continue to work on this – even after reinstating support for the current Widevine L3 support, so that we can aim to deliver a more reliable and feature filled experience in the future.

Thanks for your understanding

Sam

6 Likes

I know how you usually feel about time estimates, Sam :slightly_smiling_face: but do you have any idea at all when we might see some of this?

Also, you say:

That begs the question, what about Pi users?

So not before 2022 would be my guess

1 Like

They should get back L3 support with bullseye

When it’s ready – the library update sets us back a bit, because we need to get new libraries from AMLogic and Google. This is tricky at the moment.

We had success recently, but reporting the HDCP2.2 status to the Widevine key provisioning server had some issue and was intermittent.

Unfortunately the Pi doesn’t integrate the security features to make it suitable, so things are unchanged here.

When we move to the new version of Debian as @fzinken covered – you should get Widevine L3 software decoding support back, but it’s still at the whim of Google to revoke whenever they want.

Sam

As of right now, Netflix and Disney Plus are still working (despite dire warnings in the latter). I wonder how long for.

EDIT: I’m using a Vero 4K+, with Widevine 13729.56.0

Are you sure ? I have just tried to use DAZN on my Raspberry pi2 osmc setup and it’s not works.

IT’s not a big trouble for me because i can use DAZN app on my LG smart tv (even if the TV is certainly not of the latest generation).

I can know on what device you have tested netflix and disney+ ?

1 Like

Vero 4K+.

Disney+, just now “newer widevine not supported”(in orange), Older installed(last working) REWOKED(in bold red letters), used that one anyway, lots of warnings but played video. haven’t tested netflix the last 3 days yet.

Device: Vero4k

Amazon VOD (prime video) is no longer working, but the F1TV plugin still works so I’m at least good for the weekends.

Is there a workaround by installing an older osmc + widevine?

Hi. Effectively since September 1st, there’s a problem with Widevine / inputstream.adaptive. I bought a Vero 4k+ a week ago, I was very happy, cause I’ve exprimented OSMC since several years on a Raspberry pi 3B+, and for a multimedia entertainement in the living room, it’s quite a good choice,. However I’m a bit disappointed now because I didn’t know this problem would occur on Septembre 1st. As my TLive TV plugin didn’t work anymore 2 days ago, I thought first there was a problem with my config, then with the Vero. After a big search and lots of tests, I found in fact without any help that this was a problem with inputstream.adaptive and/or Widevine. Both are linked. My Vero4k+ was configured with the 2020 November disk image. Under Windows 10, there’s no problem with Widevine and everything goes on, with Kodi Leia or Matrix. That’s the reason that I tried to migrate to latest Vero image, with Kodi Matrix, and I must admit, it was a big mistake : nothing is working like I want to. Plugins and skin are still beta with Kodi Matrix… but the behavior was the same and the errors in the log for widevine were also the same. so I decided to downgrade to a new proper installation with 2020 November image, I put my backup, and tuned everything like it shoud be (hyperion, plugins etc) and with great sadness… no more TV with catchup TV and more, no more Amazon Prime. However, as said above, Disney+ and Netflix are still working. I even tried to compile a new inputstream.adaptive (2.4.8) with no success : I suppose I miss some Vero specific libraries (same problem on Raspberry but we can find these libraries easily). The package is installing as a Kodi plugin and updates the original inputstream.adaptive 2.4.6, but there are some errors in kodi.log when being used. I tried each release of Widevine libs, with no success. 3 days long I have been testing all that was possible, with no success, and I’m not a beginner. This recent problem was discussed nowhere on Internet, until I discovered this topic by chance… This post is my testimonial. I’m afraid I’m looking for a Windows solution, as I’d like to keep a single solution for everything, instead of a tv decoder + chromecast + etc. I’m afraid I won’t wait for a year for a solution. On the other side, everything works perfectly on a Playstation (Amazon Plex Netflix Disney+, except for TV that doesn’t exist on PS4) … no problem with DRM… how is it possible ? mystery… Very, very disappointed. I’d like a solution for the current release too, upgrade to Matrix is not a solution for me (too unstable), as far as plugins and templates are not totally implemented for Matrix.

There will be a solution in the future – however it will rely on Kodi v19 Matrix and Debian Bullseye. Due to the nature of the problem, it won’t work on older versions of OSMC.

Hope so… wait’n see. It’s really in the future ! 2022 so far. Meanwhile I must find another solution. It’s a pity. Vero is a good box. Sometimes it’s unstable and hangs or freezes and needs hard reboot with unplugging (when stopping ou clicking next / SPDIF and full digital TOSLink configuration)… but it’s quite a good box.

You should start a post about your v19 issues so we can solve these for you.

After the next update, we will begin the work on Bullseye.

No, the problem isn’t to do with the link between OSMC and Widevine, it’s to do with the interaction between Widevine and the video source. Amazon has decided not to allow older versions of Widevine to access its videos any more (and OSMC can’t yet run a newer version). Netflix and Disney Plus will probably do the same in the not too distant future (although we can’t be sure).

1 Like

Thanks, I’ll do it later. The biggest problem was widevine. For the sound, I begin with reading everything about that in the forum, and of course, I’ve read and applied your own procedure about Vero audio specific settings. But sometimes, Vero hangs randomly, but always when stopping or forwarding a video (TV, local or network video, or streaming or plugin like Netflix). The Raspberry Pi 3 with a Hifi DAC with spdif ouptut never hangs for that reason (same config and same plugins and template). I can suppose the sound driver could perhaps be buggy.

Concerning widevine, I’ve found this other recent topic

I suppose I can migrate to LibreElec that seems to be patched, even with Kodi 18 (9.2.8 version). Such a pity, I must buy a new raspberry Pi in order to reconfigure my home solution, and install LibreElec, waiting for the future OSMC update…

Its been known by everyone who needed to know for the last 3-4 months.
I guess it’s just knowing where to look.

But no one knew when google was going to actually enforce it.
If they enforced it back when they suggested, then no OS’s would have been ready.

2 Likes

I want to make an ironic consideration :slight_smile:
since when did the “old” library still work on raspberry devices ?

Lol on my case i have start to use it… not even two weeks and I find myself in the same condition as before … lol.

Perfect timing :slight_smile:

Agreed Matt and I’m hoping this is fixed soon so your great addons work on OSMC again.

1 Like