WiFi dongle stopped working after last update

Hi all,

I am creating a topic because I have an issue. I have the TPLINK T2UH wifi dongle. I’ve plugged it in and it worked out of the box on OSMC. I just had to add dtoverlay=sdhost in the config.txt (I am on rpi3).

The issue is that I updated, rebooted and lost connection. The dongle simply doesn’t work. I tried commenting out dtoverlay=sdhost . I got the integrated WiFi working and used it to grab a log:


The dongle shows 148f:761a on lsusb

Let’s be totally clear here. I am not sure at all the update caused it, Sam on another topic confirmed no changes had been made. I would just be glad for any help to make it work again.

Both (the internal and external) dongle are found a wlan device added

Apr 16 18:49:03 osmc connmand[313]: wlan0 {create} index 3 type 1 <ETHER>
Apr 16 18:49:03 osmc connmand[313]: wlan0 {update} flags 4098 <DOWN>
Apr 16 18:49:03 osmc connmand[313]: wlan0 {newlink} index 3 address 00:00:00:00:00:00 mtu 1500
Apr 16 18:49:03 osmc connmand[313]: wlan0 {newlink} index 3 operstate 2 <DOWN>
Apr 16 18:49:03 osmc connmand[313]: Adding interface wlan0 [ wifi ]
Apr 16 18:49:03 osmc connmand[313]: wlan1 {create} index 4 type 1 <ETHER>
Apr 16 18:49:03 osmc connmand[313]: wlan1 {update} flags 4098 <DOWN>
Apr 16 18:49:03 osmc connmand[313]: wlan1 {newlink} index 4 address B8:27:EB:68:11:9C mtu 1500
Apr 16 18:49:03 osmc connmand[313]: wlan1 {newlink} index 4 operstate 2 <DOWN>
Apr 16 18:49:03 osmc connmand[313]: Adding interface wlan1 [ wifi ]

I guess that maybe for some reason the internal dongle was not correctly disabled.
Maybe a firmware change on the Pi3?

it looks to me that this comes after I commented out dtoverlay=sdhost to get internet access so it is normal I would say.
However I’ve just seen this in the log, I don’t know what it means but it seems to be related to the wifi dongle

Well we can close the topic, it’s back working… the mysteries of wifi dongles…

Ok I updated to the last update and once again I lost Wifi connectivity. I do not even have the wireless option in MyOSMC>Network anymore.

Just like last time (see beginning of the topic), it happened just after the update. I really do not understand. The dongle appears on lsusb. However it’s light is off (should be green).

Since I have no idea as to what helped me get the connectivity back last time, I come to you for help.

First try to update again. As second step provide dmesg logs by giving URL of dmesg ¦ paste-log

I tried to update again, it did update but it is still not working. I have commented out dtoverlay=sdhost so that I have access to the internal Wifi of the Pi 3. It works, while the dongle is still connected (there used to be a conflict when I had this line commented out). So I suppose the dongle is totally inactive. Still here is the result of dmesg paste-log: https://paste.osmc.tv/onizinutur

Can you provide output of:
sudo modprobe mt7610u_sta

lsusb :
Bus 001 Device 005: ID 0781:5567 SanDisk Corp. Cruzer Blade Bus 001 Device 004: ID 148f:761a Ralink Technology, Corp. Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Module Size Used by nls_utf8 1656 0 cifs 283785 0 bnep 12438 2 hci_uart 22213 1 btbcm 8478 1 hci_uart bluetooth 441852 24 hci_uart,bnep,btbcm brcmfmac 246785 0 sg 23944 0 brcmutil 9412 1 brcmfmac cfg80211 593457 1 brcmfmac uas 16435 0 snd_bcm2835 24874 0 bcm2835_thermal 2541 0 snd_pcm 116611 1 snd_bcm2835 snd_timer 25831 1 snd_pcm snd 78726 3 snd_timer,snd_bcm2835,snd_pcm rfkill 21996 5 bluetooth,cfg80211 bcm2835_gpiomem 3940 0 uio_pdrv_genirq 3885 0 uio 10300 1 uio_pdrv_genirq fixed 3285 0 fuse 113570 1 ipv6 461576 44

sudo modprobe mt7610u_sta doesn’t do anything. What should it prompt?

Well it should load the driver and if no feedback that seems it loaded it.

check dmesg again if the wlan device now has been created.
If not than it might be that T2UH is not based on mt7610 evenso it seems to indicate that

here’s what I get, I do not really not what to look for:


Ok, doesn’t seem that your T2UH is not be supported by mt7610 at this moment.
Not much I can recommend in the moment other than maybe trying the April image which seemed to have worked for you. If you get it working on that image than provide dmesg to investigate.

Thank you for helping me! Is there anyway to roll back to the april version without loosing all my kodi configurations and addons?

Easiest is to do a backup via myOSMC and then install the April version

Is there anyway to check if the dongle is even powered? because I see not light on it and it used to have a red light when malfunction occured.

Well if you run lsusb and it is displayed there than that would indicate that it is powered.
You might need to install usb-utils sudo apt-get install usb-utils if you haven’t done before.

lsusb shows the dongle. I’ll try to install a previous image of OSMC as you said.

OK I rolled back to april image and my dongle is back on ! But weird issue now…
I have added back dtoverlay=sdhost to the config, rebooted. In osmc , wireless I see numerous SSIDS but not my 5.0 wifi. And even weirder: when I look into my modem it says osmc device is connected! !

With which MAC address?

With the external dongle’s mac adress. However, it only connects to the 2.4ghz Wifi. And the 5.0 doesn’t appear (while appearing on other devices… )