Wifi Not Connecting

I have a RPI 3B+ with a fresh install of OSMC on it and it is failing to connect to the wifi
This is my second 3B+ with this issue. First one I updated at the end of Dec and after the update my Pi wouldn’t connect via wifi. I switched to another 3B+ with a fresh install and it connected once but after that it won’t connect to wifi.

Its using built in wifi, no dongle
Log files: https://paste.osmc.tv/kinecapaku

connmanctl scan wifi shows nothing
connmanctl enable wifi shows wifi enabled
connmanctl services shows my SSID
/etc/network/interfaces doesn’t exist
/etc/wpa_supplicant is missing .conf file


wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet  netmask  broadcast
        ether b8:27:eb:0c:81:03  txqueuelen 1000  (Ethernet)
        RX packets 217  bytes 20092 (19.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 243  bytes 33602 (32.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

The interface exists and appears to be up. Have you got tethering enabled?

Thanks Tom.

Did you enter your wifi creds during the download. There is an issue with that. Better to leave it blank and then connect from the GUI once installed.

cat /etc/connman.conf shows PersitentTetheringMode=true

SSH is enabled but I’m unable to connect to it


Did you set the ip address for the wifi interface?

Thanks Tom.

It was set automatically

Is you WLAN and LAN using the same DHCP server?
Do you normally have IP Addresses in the range of 192.168.10.x or 10.0.0.x?
Is StarLordWifi your wifi you are trying to connect to?

Normal IP range is the 10.0.0.x
WLAN and LAN both run off Xfinity router which sets the IP addresses on the network
StarLordWifi is the SSID i’m trying to connect to

All my devices connect over wifi and none of them are having connection issues

Neither seems your Pi3 has an issue as you are connected with So you are saying you can’t ping from any device in your LAN? What does arp -a says if you run it on your Notebook or Router?

my pi was connected just fine on the 10.0.0.x ip until a month ago
current ip address is a 10.0.0.x
arp -a gives a table of IPv4 addresses, 3 are 10.0.0.x, 4 are 224.0.0.x, and

Based on your logs it is still connected as therefore we are trying to understand what exactly is your problem.
After you do ping does that arp -a include an entry with and or b8:27:eb:0c:81:03?

After I ping it it shows up in the arp table
arp on the Pi, gives nothing back

The problem is that a) I can’t ssh into it (ssh is enabled) and b) the kodi app isn’t detecting it and manually configuring isn’t connecting either

If I exit OSMC to command line and ping I get ‘network is unreachable’, but if I ping the Pi it responds
If I go to Network in MyOSMC the status is connected but there are no connection details (ip, gateway, etc)

With the MAC of b8:27:eb:0c:81:03?

What is ip ro giving you?
Does ping work?

With the MAC of b8:27:eb:0c:81:03?


ip ro



network is unreachable

That is really odd.
Can you manually add a default route ip ro add default via dev wlan0?

Also if you connect the LAN cable as you did for uploading the logs what does ip ro say?

sudo ip ro add default via dev wlan0

Error: Nexthop has invalid gateway

with LAN cable ip ro gives:

default via dev eth0 via dev eth0 dev eth0 proto kernal scope line src dev eth0 scope link

Really odd, not sure what could cause that on a fresh install.
Did you try with a Raspbian install to check if that connect stable on Wifi?

I tried out jellyfin on rasbian before putting OSMC on it and it was working fine with jellyfin

I’m kinda thinking of doing @bfunke1’s suggestion and re-flashing my SD card, reinstalling but not inputting wifi creds until after it finishes the install and seeing what happens

Yes do that as presedding has issue currently


If that doesn’t help, can you please try setting a static IP (Configure Network Manually under MyOSMC ->Network->Wired). Could be that its not correctly receiving its gateway or mask correctly via dhcp.

Thanks Tom.