Wifi on Pi1 B 512 with TL-WN723N not working

Hey there,

first post here. Hope you can help me.
Downloaded latest OSMC version from the home page and it basically works very well - but WiFi.
According to my (intensive…) scans over the web, the dongle should be supported. It said also “linux” on the box when I bought it, so I was confident.

My kernel is 4.4.27.
It seems to load the wifi dongle’s driver as r8188eu.
It seems OSMC seems to actually work with it, as I see the list of networks (just one), I can “connect” to it - I just don’t seem to get any working internet…
I always get a 169.254.x.x address, and the text says “no internet”.

Many other devices connect to the same network, most linux and android, but also some windows devices, So it definitely can’t be the network - it must be my pi, osmc and/or the dongle.

Couldn’t execute lsusb on the pi (is it not available on osmc?) but running it on another box I get:
Bus 002 Device 005: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

I really would love to get this running. I want a low-power consumption media center from which to play my music collection and watch some stuff.

I hope you have instructions for me. I’ve tried to find a different driver on EngMan’s page, but indeed haven’t been able to find any suitable.
I am fine compiling my own driver if given instructions…

I hope we can get this to run! Thanks everyone

P.S. I have two other dongles…none works with OSMC :(. One never worked with any of my linux distros, so that’s expected. The other though has been working on other boxes, and also has been working with this same pi in the past (just different distro…).
So…please don’t advise to buy a different dongle…:slight_smile: I’d rather try a different distro altogether than buying a new dongle!

P.S.2 I run my Pi with an externally powered usb hub. I’ve tried to use both the Pi’s usb power connection and the usb hub power source ,but that didn’t work. Running through the externally powered hub seems to work fine. Just to illustrate my setup.

According to this post the “8188EU is supported and distributed in OSMC”.

Though not installed by default, the usbutils package can be installed using apt-get.

Running grab-logs -J -K with the dongle installed would provide us with useful information.

The other dongle I just happen to try is:
Bus 002 Device 006: ID 050d:110a Belkin Components F9L1101v2 802.11abgn Wireless Adapter [Realtek RTL8192DU]

This one happens to connect. However also only gets a 169.254.x.x address.

I tried to manually set if config, then add a route with gw.

Pinging somehow works, but I get around 80% packet loss!!!

Why are all these wifi drivers so crappy?
I guess it’s not OSMC to blame, but any suggestion?

not sure I can provide the grab-logs results - no internet from my Pi.
when starting it, I got an error saying it can’t upload (which would make sense without internet), but that
it would would write to /boot.

No log file in /boot though.

Through connman I get this error:
Agent request canceled by ConnMan
Error /net/connman/service/wifi_: Operation aborted

Sorry, I expected that you’d have a wired connection available. I guess you’re not going in by SSH!

You can run grab-logs -J -K -C which should create the file /boot/uploadlog.txt. If you can get that to another machine, eg via a USB drive, please paste it to https://paste.osmc.tv

hey @dillthedog

Thanks for chiming in and disposition to help first of all.

Yeah, I was “Exit” from the UI and entering the command line, no ssh.

Here are the logs:

Curious to hear if you can find anything.
Thanks again!

This line seems relevant:

osmc net.agent[348]: ERROR: /sbin/ifup not found. You need to install the ifupdown package.

Nope. It appears on all logs.

The driver and firmware are there and, in theory, should work.

  1. Please install usbutils and then run lsusb

  2. Run md5sum /lib/firmware/rtlwifi/rtl8188eufw.bin

  3. Run lsmod

couldn’t install lsusb yet…but as m fromy original post, you may see the result from another machine:

Bus 002 Device 005: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

md5sum: aaef52a47852e599cbff63a3e7f96a94

lsmod: Module Size Used by sg 23990 0 uas 17270 0 joydev 9938 0 r8188eu 525419 0 evdev 13895 0 cfg80211 552034 1 r8188eu rfkill 25367 2 cfg80211 snd_bcm2835 23559 0 snd_pcm 115645 1 snd_bcm2835 bcm2835_thermal 2435 0 snd_timer 28816 1 snd_pcm bcm2835_gpiomem 3823 0 snd 79485 3 snd_bcm2835,snd_timer,snd_pcm bcm2835_wdt 4197 0 uio_pdrv_genirq 3846 0 uio 10288 1 uio_pdrv_genirq fuse 112619 1 ipv6 433811 28

Boy, I’m obviously not firing on all cylinders right now!

Firmware’s md5 checks out and driver is loaded. I need to do a bit more research on this one. It’s getting a bit late here so I’ll pick it up again tomorrow.

@sam_nazarko Perhaps you have some insight as to what’s happening here. It’s a Pi 1 B and the WiFi dongle is an RTL8188EU, vid/pid 0bda:8179. The log shows it’s being detected:

Jan 01 04:28:20 osmc kernel: usb 1-1.2: new high-speed USB device number 4 using dwc_otg
Jan 01 04:28:20 osmc kernel: usb 1-1.2: New USB device found, idVendor=0bda, idProduct=8179
Jan 01 04:28:20 osmc kernel: usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 01 04:28:20 osmc kernel: usb 1-1.2: Product: 802.11n NIC
Jan 01 04:28:20 osmc kernel: usb 1-1.2: Manufacturer: Realtek
Jan 01 04:28:20 osmc kernel: usb 1-1.2: SerialNumber: 00E04C0001

but the driver fails to connect:

Jan 01 04:32:15 osmc wpa_supplicant[285]: wlan0: Trying to associate with 30:b5:c2:c2:2a:b0 (SSID='serendipia' freq=2412 MHz)
Jan 01 04:32:15 osmc wpa_supplicant[285]: wlan0: Association request to the driver failed
Jan 01 04:32:17 osmc wpa_supplicant[285]: wlan0: CTRL-EVENT-DISCONNECTED bssid=30:b5:c2:c2:2a:b0 reason=0
Jan 01 04:32:17 osmc kernel: R8188EU: ERROR indicate disassoc

awesome @dillthedog
thank you very much.

I have been using linux since end of 90s so if there’s something you suggest exploring I am happy to do that.

8188EU is supported in OSMC, and quite a mature driver (tested here to check for regressions).

OP needs to mention if they’re using encryption on their network and give more of a description of their setup

8188EU dongles aren’t well renowned for great signal strength. Usually a connection issue means signal is poor.

The user should try connecting via connmanctl and reporting the output of that.

@sam_nazarko the only thing about my wifi:

The osmc would connect to a repeater, but the repeater is quite close to where the dongle is - max 5m. No walls in between. The repeater gets its signal (and DHCP) from a WiFi signal around 25m from there.
I have a password on my SSID, not sure what kind of encryption is used but assume some standard for home networks

With this setup, I have 2 Android connecting, one linux box for work usually, another linux box which is the current media center and which I would like to replace with the osmc pi, and occasionally two windows boxes from visitors. Never have any issue with the network.

I’ve tried connecting via connmanctl and got:
Agent request canceled by ConnMan Error /net/connman/service/wifi_: Operation aborted
as reported in a previous post in this thread

Thanks !

Post the actual commands (and output) you ran? I can’t see this anywhere in your post history.

I assume these other devices aren’t connecting with a Realtek 8188EU based WiFi adapter?

This isn’t really helpful.
It’s all well and dandy that it works for other devices, but I assume you want it to work for OSMC.

mind you I am typing this, as I don’t have network on my osmc yet

connmanctl > scan wifi
Scan completed for wifi
connmanctl>agent on
Agent registered
connmanctl>connect wifi
Passphrase = [ Type=psk, Requirement=mandatory ]
Agent Report Error wifi
Agent request cancelled by ConnMan
Error /net/connman/service/wifi
: Operation aborted

Just to recap: Firmware and driver seem to be ok but you’re having problems connecting to your WiFi repeater, which seems to be a TP-Link device, according to its MAC address.

First, it would be useful if you could install wireless-tools. You can download the .deb package onto another machine from http://mirrordirector.raspbian.org/raspbian/pool/main/w/wireless-tools/wireless-tools_30~pre9-8_armhf.deb and then move it across on a USB drive. Install by running:

sudo dpkg -i wireless-tools_30~pre9-8_armhf.deb


iwlist wlan0 scanning

If nothing else, it’ll give us a better idea of what the dongle can see and what encryption is being used on the repeater.

I also noticed a couple of lines in the system log that need further investigation:

Jan 01 04:28:31 osmc wpa_supplicant[285]: nl80211: Driver does not support authentication/association or connect commands
Jan 01 04:28:31 osmc wpa_supplicant[285]: ioctl[SIOCSIWAP]: Operation not permitted

Hey @dillthedog,

thanks for hanging in here.
Unfortunately I had to wait to be able to post any further message, as the forum rules seem to limit the amount of messages for a new member.

I’ll do as suggested and install wireless tools asap.
As for the other lines for investigation, I’ve read elsewhere that it may be related to the buggy default driver, and that a custom compiled driver would not have these issues. Unfortunately, I couldn’t find the appropriate driver on MrEngman’s page nor have I been able to compile it myself on osmc, or I would have at least tried it.

I am against my first statements considering buying the osmc-own dongle, but only after having tried anything else.


As mentioned above, Sam is of the opinion that this is a mature and well-tested driver.

Compiling your own drivers can be done but must normally be repeated each time you update the kernel, so shouldn’t generally be done unless there’s no other path available. And since the WiFi dongle is your Pi’s only lifeline to the outside world, it could get quite tricky after an update. :wink:

Ok, after a few days of pausing, here an important update to this convo
(again, thanks @dillthedog and @sam_nazarko for disposition and quick help )

After failed attempts at configuring wifi, I tried re-installing osmc.
Same experience.
Then, I thought, why not give LibreElec a try. Installed-
Same experience.

Then I had an insight. I setup my Android as hotspot, to see if the Pi would connect to it.
And…babapam - it worked! (Still on LibreElec though)

So @sam_nazarko’s suggestion that it could be my home wifi network, which I shrugged off as unlikely, actually seems to have been spot on.

Now…I am not sure I can actually change my config, and if so, how. I live in a house, but internet is arriving at another house 25m away. So my local Wifi AP acts is setup as Repeater. It’s a TL-WA901ND, and it has other operation modes (Bridge, Repeater, AP, Client, MultiSSID). I am investigating if some other setup might be suitable for me, but I definitely need the remote signal to be amplified so to get decent connection here. I suspect that, due to the distance, DHCP is taking longer than some default entry, and that’s maybe why the Pi doesn’t get an IP address and gets stuck with 169.254.x,x.

So I am not done with this project yet, and my issue is not fixed, but I deemed it fair to report where I left.